Стандартные программы Windows

Хорошо ли вы знаете Windows? Я думаю, что да. Знаете ли вы его на 100%? Вряд ли. Потому что парни из Microsoft очень постарались, пряча некоторые функции и возможности от пользователей. Речь здесь пойдет о программах: самых обычных стандартных программах операционной системы, которые при установке ставятся по умолчанию и присутствие которых никак не афишируется. Более того, разработчики, как нарочно, пытаются отпугнуть пользователей от работы с этими утилитами. Посудите сами: программы нигде не упоминаются (ну, может быть в справке), на них нет ярлыков в меню "Пуск", а при попытке зайти в каталог Windows, где они, собственно, и находятся, появляется страшная надпись о том, что сюда заходить не надо, дабы не испортить системных файлов. Это может отпугнуть новичков. А ведь там немало полезных программ.

Последнюю версию справочника Программы и файлы Windows вы всегда можете найти на сайте пользователя Александра Климова


Новые программы

Новые программы (Windows 7)

  • bcdedit.exe
  • cttune.exe
  • dccw.exe
  • dfrgui.exe
  • dism.exe
  • displayswitch.exe
  • djoin.exe
  • dvdmaker.exe
  • ehshell.exe
  • expand.exe
  • isoburn.exe
  • journal.exe
  • MdSched.exe
  • mip.exe
  • narrator.exe
  • osk.exe
  • powershell.exe
  • PowerShell_ISE.exe
  • psr.exe
  • recdisc.exe
  • regini.exe
  • resmon.exe
  • robocopy.exe
  • SnippingTool.exe
  • StikyNot.exe
  • tzutil.exe
  • vsp1cln.exe (Windows Vista SP1)
  • xpsrchvw.exe

Удаленные программы и файлы

  • clipbrd.exe - Программа папки обмена удалена была еще в Windows Vista. Но можно было скопировать эту программу из Windows XP
  • compcln.exe (Windows Vista SP2)
  • dfrg.msc - оснастка Дефраграментация диска была заменена на программу dfrgui.exe (Дефрагментация диска)
  • digitalx.exe - Программа Помощник по цифровой корзине была включена в Windows Vista, но была убрана из Windows 7
  • drwtsn32.exe - программа Доктор Ватсон в Windows удалена за ненадобностью для пользователй
  • HelpCtr.exe - Центр справки и поддержки представляет собой справочное приложение для Windows XP и Windows Server 2003. Центр справки и поддержки не входит в состав Windows Vista, и его функции не поддерживаются.
  • lpq.exe
  • sndvol32.exe - вместо нее появилась программа sndvol.exe
  • WinHelp.exe и WinHlp32.exe - Справка Windows в Windows Vista удалена. Чтобы просматривать файлы справки с расширением .HLP в Windows Vista, необходимо загрузить и установить компонент "Справка Windows" в центре загрузки Microsoft.
  • Приложение Outlook Express модифицировано и перемещено, и теперь носит название Windows Mail.
  • boot.ini - этого файла в системе больше нет
  • wincal.exe - Программа Календарь Windows появилась в Windows Vista, но затем ее убрали из Windows 7
  • WindowsPhotoGallery.exe- Программа Фотоальбом Windows появилась в Windows Vista, но затем ее убрали из Windows 7


alg.exe

Местонахождение

WINDOWS\system32

Описание

Служба шлюза уровня приложения (Application Layer Gateway Service)

Оказывает поддержку протоколов третьей стороны протоколов PnP для общего доступа к подключению к Интернету и подключений к Интернету с использованием брандмауэра. Эта служба нужна при использовании Брандмауэра Интернета/Общего доступа к Интернету для подключения к интернету.

Значение по умолчанию | Рекомендуемое значение
Вручную | Вручную

Зависимости от данной службы

Брандмауэр Интернета (ICF) /Общий доступ к Интернету (ICS) (Internet Connection Firewall/Internet Connection Sharing)


appwiz.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Программы и компоненты

Описание

Элемент панели управления (.cpl)

Компонент панели управления Программы и компоненты используется в основном для правильной деинсталяции программ.


arp.exe

Местонахождение

Windows\system32

Описание

Команда Arp TCP/IP

Команда Arp используется для просмотра, добавления или удаления записей в таблицах трансляции адресов IP в физические адреса. Эти записи используются при работе протокола Address Resolution Protocol (ARP)

Синтаксис

arp -a [inet_addr] [-N [if_addr]]
arp -d inet_addr [if_addr]
arp -s inet_addr ether_addr [if_addr]

Параметры

-a
Отображает текущие ARP-записи, опрашивая текущие данные протокола. Если задан inet_addr, то будут отображены IP и физический адреса только для заданного компьютера. Если ARP используют более одного сетевого интерфейса, то будут отображаться записи для каждой таблицы.
-d
Удаляет узел, задаваемый inet_addr. Параметр inet_addr может содержать знак шаблона * для удаления всех узлов.
-g
То же, что и параметр -a
-s
Добавляет узел и связывает адрес в Интернете inet_addr с физическим адресом eth_addr. Физический адрес задается 6 байтами (в шестнадцатеричном виде), разделенных дефисом. Эта связь является постоянной
-N [if_addr]
Отображает ARP-записи для заданного в if_addr сетевого интерфейса.
ether_addr
Определяет физический адрес
if_addr
Если параметр задан, он определяет адрес интерфейса в Интернете, чья таблица преобразования адресов должна измениться. Если параметр не задан, будет использован первый доступный интерфейс.
inet_addr
Если параметр задан, он определяет адрес интерфейса в Интернете, чья таблица преобразования адресов должна измениться. Если параметр не задан, будет использован первый доступный интерфейс.


at.exe

Местонахождение

Windows\system32

Описание

Интерфейс командной строки службы расписаний

Команда At предназначена для запуска команд и программ в указанное время по определенным дням. Для использования команды AT необходимо, чтобы была запущена служба расписаний. Возможна работа с удаленными компьютерами. Для запуска задач пользователь должен обладать необходимыми правами.

Синтаксис

AT [\\имя_компьютера] [ [код] [/DELETE] | /DELETE [/YES]]
AT [\\имя_компьютера] время [/INTERACTIVE] [ /EVERY:день[,...] | /NEXT:день[,...]] "команда"

Параметры

\\имя_компьютера
Имя удаленного компьютера. Если этот параметр опущен, используется локальный компьютер
код
Порядковый номер запланированной задачи
/delete
Отмена запланированной задачи. Если код задачи опущен, отменяются все задачи, запланированные для указанного компьютера
/yes
Отмена запроса на подтверждение при отмене всех запланированных задач
время
Время запуска команды
/interactive
Разрешение взаимодействия задачи с пользователем, работающим на компьютере во время запуска задачи
/every:день[,...]
Запуск задачи осуществляется по указанным дням недели или месяца. Если дата опущена, используется текущий день месяца
/next:день[,...]
Задача будет запущена в следующий указанный день недели (например в следующий четверг). Если дата опущена, используется текущий день месяца
"команда"
Команда Windows NT или имя пакетного файла


atmadm.exe

Местонахождение

Windows\system32

Описание

Диспетчер вызовов ATM

Контроль подключений и адресов, зарегистрированных диспетчером вызовов ATM в сетях с асинхронным режимом передачи (ATM). Вызванная без параметров команда atmadm отображает статистику для контроля состояния активных ATM-подключений.

Синтаксис

atmadm [/c][/a] [/s]

Описание параметров есть в справке Windows


attrib.exe

Местонахождение

Windows\system32

Описание

Утилита атрибутов

Утилита командной строки позволяет просматривать, устанавливать или снимать атрибуты файла или каталога, такие как «Только чтение», «Архивный», «Системный» и «Скрытый». Выполненная без параметров команда attrib выводит атрибуты всех файлов в текущем каталоге.

Синтаксис

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[диск:][путь] имя_файла] [/s[/d]]

Описание параметров есть в справке Windows

Пример

Сделать все файлы в папке D:\Test только для чтения, а саму папку сделать скрытой можно с помощью команд:

attrib +R D:\Test\*.*
attrib +H D:\Test

Скрыть на диске C: все файлы текущего каталога и его подкаталогов, кроме текстовых файлов:

attrib +H C:*.* /S
attrib -H C:*.txt /S

Примечание

Атрибуты файлов также можно просмотреть с помощью команды командной строки DIR с ключом /A


audiodg.exe

Местонахождение

Windows\system32

Описание

Изоляция графов аудиоустройств Windows

Процесс audiodg.exe не имеет видимого окна и при его отключении падает звук. Запускается процесс когда работает звук (игры, музыка и т.д.), если минут 5 звук не работает, он завершается (В диспетчере задач его нет). Больше 20 Мб памяти он обычно не потребляет. Однако случаются и неприятные ситуации, когда это процесс начинает неимоверно пожирать память и процессор. Данная проблема описана в Базе Знаний Microsoft по номером 981013.


bcdboot.exe

Местонахождение

%WINDIR%\System32

Описание

Служебная программа Bcdboot

Утилита bcdboot.exe используется для создания или восстановления среды загрузки, расположенной в активном системном разделе. Утилита также может быть использована для переноса файлов загрузки с одного жесткого диска или раздела на другой.

Синтаксис

BCDBOOT источник [/l язык] [/s буква_диска] [/v] [/m [{GUID_загрузчика_операционной системы}]]

Параметры

источник
Указывает расположение каталога Windows, используемого в качестве источника при копировании файлов среды загрузки.
/l
Необязательный параметр. Задает язык среды загрузки. По умолчанию используется английский (США).
/s
Необязательный параметр. Указывает букву диска системного раздела, куда будет установлены файлы среды загрузки. По умолчанию используется системный раздел, заданный микропрограммой BIOS.
/v
Необязательный параметр. Включает режим подробного протоколирования работы утилиты.
/m
Необязательный параметр. Объединяет параметры вновь созданной и уже имеющейся загрузочной записи хранилища и записывает их в новую загрузочную запись. Если GUID загрузчика операционной системы задан, для создания загрузочной записи объединяет объект загрузчика с шаблоном системы.

Смотри также

Восстановление загрузчика Windows 7 вручную при помощи утилит bootrec.exe и bcdboot.exe


bcdedit.exe

Местонахождение

%WINDIR%\System32

Описание

Редактор данных конфигурации загрузки

Файлы данных конфигурации загрузки (BCD) обеспечивают хранилище, которое будет использоваться для описания приложений загрузки и параметров приложений загрузки. Объекты и элементы хранилища по сути заменяют Boot.ini в предыдущих версиях Windows.

BCDEdit - это средство командной строки, предназначенное для управления данными конфигурации загрузки. Оно может использоваться для различных задач: создание новых хранилищ, изменение существующих хранилищ, добавление параметров меню загрузки и многого другого. Программа BCDEdit выполняет те же функции, что и Bootcfg.exe в более ранних версиях Windows, но имеет два существенных преимущества: предоставляет расширенные параметры и имеет лучшую поддержку сценариев.

Чтобы использовать BCDEdit для изменения данных конфигурации загрузки, необходимо обладать административными правами.

BCDEdit является основным средством изменения конфигурации загрузки Windows Vista и более поздних версий Windows.

Синтаксис

BCDEdit/команда [аргумент1] [аргумент2] ...

Параметры

/?
Отображает список команд BCDEdit. Выполнение этой команды без аргумента выводит список доступных команд. Чтобы отобразить подробную справку по определенной команде, выполните bcdedit /? команда, где команда - это имя команды, для которой требуется справка. Например, команда bcdedit /? createstore отобразит подробную справку по команде Createstore.
/createstore
Создает новое пустое хранилище данных конфигурации загрузки. Созданное хранилище не является системным.
/export
Экспортирует содержимое системного хранилища в файл. Этот файл можно использовать в дальнейшем для восстановления определенного состояния системного хранилища. Команда допустима только для системного хранилища.
/import
Восстанавливает состояние системного хранилища с помощью файла данных резервной копии, созданного с помощью параметра /export. Эта команда удаляет существующие записи в системном хранилище перед выполнением операции импорта. Команда допустима только для системного хранилища.
/store
Этот параметр может быть использован с любой командой BCDedit для определения используемого хранилища. Если параметр не указан, программа BCDEdit работает с системным хранилищем. Выполнение команды bcdedit /store равнозначно выполнению команды bcdedit /enum active.
/copy
Создает копию определенной записи загрузки в том же системном хранилище.
/create
Создает новую запись в хранилище данных конфигурации загрузки. Если указан известный идентификатор, невозможно указать параметры /application, /inherit и /device. Если идентификатор не указан или он неизвестен, необходимо указать параметры /application, /inherit и /device.
/delete
Удаляет элемент в определенной записи.
/deletevalue
Удаляет указанный элемент из записи загрузки.
/set
Устанавливает значение параметра записи.
/enum
Показывает список записей в хранилище. Параметр /enum является значением по умолчанию для команды BCEdit, поэтому выполнение команды bcdedit без параметров равнозначно выполнению команды bcdedit /enum active.
/v
Режим подробного вывода. Обычно все известные идентификаторы записей представлены в понятной укороченной форме. Указание параметра /v приведет к отображению всех идентификаторов в полном виде. Выполнение команды bcdedit /v равнозначно выполнению команды bcdedit /enum active /v.
/bootsequence
Определяет одноразовую последовательность отображения для следующей загрузки. Эта команда схожа с параметром /displayorder, однако используется только один раз при следующей загрузке компьютера. После этого будет возвращена прежняя последовательность отображения.
/default
Указывает запись по умолчанию, которую выбирает диспетчер загрузки по истечении тайм-аута.
/displayorder
Указывает последовательность, используемую диспетчером загрузки при отображении параметров загрузки.
/timeout
Указывает время ожидания в секундах перед выбором диспетчером загрузки записи по умолчанию.
/toolsdisplayorder
Указывает последовательность, используемую диспетчером загрузки при отображении меню Средства.
/bootems
Включает или отключает службы аварийного управления для указанной записи.
/ems
Включает или отключает службы аварийного восстановления для определенной записи загрузки операционной системы.
/emssettings
Устанавливает глобальные параметры служб аварийного восстановления для компьютера. Параметр /emssettings не включает и не отключает службы аварийного восстановления для определенной записи загрузки.
/bootdebug
Включает или отключает режим отладки загрузки для указанной записи. Несмотря на то, что эта команда применима к любой записи загрузки, она эффективна только для приложений загрузки.
/dbgsettings
Указывает или отображает глобальные параметры режима отладки для определенной системы. Эта команда не включает и не отключает режим отладки ядра. Для этого используйте параметр /debug. Чтобы настроить отдельные глобальные параметры режима отладки, используйте команду bcdedit /setпараметры_отладки тип значение.
/debug
Включает или отключает режим отладки ядра для указанной записи загрузки.
Чтобы устранить неполадки новой установки, включите режим отладки, изменив файл настройки конфигурации загрузки (BCD). Например, используйте следующий синтаксис для включения отладки ядра или загрузки.
bcdedit /set <идентификатор> debug on-
Или
bcdedit /set <идентификатор> bootdebug on
где <идентификатор> - это GUID объекта загрузчика, который используется для загрузки операционной системы. Можно использовать «Default», если операционная система является параметром по умолчанию в меню диспетчера загрузки.

Смотри также

Как восстановить стандартный бутскрин Windows 7 (Справочник Народные советы.Windows)

Дополнительные материалы

Параметры командной строки BCDEdit - описание программы на сайте Microsoft


bitsadmin.exe

Местонахождение

%WINDIR%\System32

Описание

Программа администрирования BITS

Дополнительные материалы

Bitsadmin Overview: File and Storage Services


bootcfg.exe

Местонахождение

%WINDIR%\system32

Описание

Средство конфигурации загрузки

Программа bootcfg.exe позволяет из командной строки управлять загрузочным меню, редактируя, добавляя или удаляя записи в файле boot.ini. Функции программы аналогичны ручному редактированию файла, однако, позволяют автоматизировать процесс настройки меню загрузки, использовать команды в .bat файлах.

Описание параметров есть в справке Windows


cacls.exe

Местонахождение

%windir%\system32

Описание

Изменение таблиц управления доступом

Программа служит для просмотра или изменения файлов избирательных таблиц управления доступом (DACL).

Синтаксис

cacls имя_файла [/t] [/e] [/c] [/g пользователь:разрешение] [/r пользователь [...]] [/p пользователь:разрешение [...]] [/d пользователь [...]]

Параметры

/t
Позволяет изменить таблицы контроля доступа (DACL) указанных файлов в текущем каталоге и всех его подкаталогах.
/e
Параметр указывает на то, что DACL следует не заменить, а редактировать
/c
Изменения в DACL будут вноситься, несмотря на обнаруженные синтаксические ошибки.
/g
Позволяет предоставить пользователю определенные права и может иметь одно из пяти значений: n (никаких прав), к (право на чтение), w (право на запись), с (право на изменение), а (полный доступ)
/p
Параметр указывает, что произойдет изменение прав пользователя. Права обозначаются также, как в параметре /g
/r
Отменяет все текущие права доступа
/d
Запрещает доступ для пользователя, указанного в команде.

Описание программы есть в справке Windows


calc.exe

Местонахождение

%windir%\system32

Описание

Калькулятор для Windows

Калькулятор предназначен для выполнения тех же операций, что и обычный калькулятор: сложение, вычитание, а также функции инженерного калькулятора, например нахождение логарифмов и факториалов

В это приложение не вносились изменения, начиная с Windows 95. Но в Windows 7 наконец-то поменялся интерфейс, а также был добавлен новый функционал. Например, стали доступны новые возможности для выполнения простых действий, связанных с программированием, инженерных и статистических вычислений.

Как и раньше, его кнопки можно нажимать как при помощи мыши так и вводя символы с клавиатуры, доступен ввод цифр и действий с цифровой клавиатуры, когда нажата клавиша Num Lock. Также, для получения результата, можно вставлять математические выражения из буфера обмена.

Функция преобразования единиц измерения

В функционал стандартного калькулятора Windows 7 также добавлена возможности преобразования различных единиц измерения. При включении этой возможности, справа от основной панели калькулятора отображается панель расчёта разницы между датами, расчёта расхода топлива или платежей по кредиту, конвертации физических величин.


charmap.exe

Местонахождение

Windows\system32

Описание

Таблица символов

Таблица символов служит для просмотра символов, включенных в выбранный шрифт. Она отображает следующие наборы символов: Windows, DOS и Юникод.

Отдельный символ или группу символов можно скопировать в буфер обмена, а затем вставить в любое приложение, в котором они будут отображаться. Многие программы, например WordPad, позволяют копировать символы путем их перетаскивания из таблицы символов непосредственно в открытый документ. Более подробное описание программы есть в справке.


chcp.com

Местонахождение

%windir%\system32

Описание

Change CodePage Utility

Программа командной строки служит для просмотра номера текущей кодовой страницы или изменение текущей кодовой страницы консоли. Выполненная без параметров команда chcp выводит номер текущей кодовой страницы для окна командной строки.

Синтаксис

chcp [код]

Для русской кодовой страницы используется код 866

Описание программы есть в справке Windows


chkdsk.exe

Местонахождение

%windir%\System32

Описание

Утилита проверки диска

Вывод на экран отчета о состоянии диска в форме, зависящей от используемой файловой системы. Команда chkdsk также составляет список ошибок на диске и исправляет их. Выполненная без параметров команда chkdsk выводит информацию о состоянии текущего диска.

Синтаксис

CHKDSK [том:[[путь]имя_файла]] [/F] [/V] [/R] [/X] [/I]  [/C] [/L[:размер]]

Параметры

Том
Определяет точку подключения, имя тома или букву проверяемого диска с двоеточием.
имя_файла
Файлы, проверяемые на наличие фрагментации (только FAT/FAT32).
/F
Исправление ошибок на диске.
/V
Для FAT/FAT32: вывод полного пути и имени для каждого файла на этом диске. Для NTFS: также вывод сообщений об очистке.
/R
Поиск поврежденных секторов и восстановление их содержимого. (требует /F).
/L:размер
Только для NTFS: изменение размера файла журнала до указанной величины (в КБ). Если размер не указан, выводится текущее значение размера.
/X
При необходимости предварительное отключение тома. Все открытые дескрипторы для этого тома будут недействительны. (требует /F).
/I
Только для NTFS: менее строгая проверка индексных элементов.
/C
Только для NTFS: пропуск проверки циклов внутри структуры папок.

Ключи /I или /C укорачивают время выполнения CHKDSK за счет пропуска некоторых проверок тома.


chkntfs.exe

Местонахождение

WINDOWS\system32

Описание

Утилита обслуживания томов NTFS

Просмотр или задание планирования автоматической проверки системы для томов файловых систем FAT, FAT32 или NTFS при запуске компьютера. Описание программы есть в справке Windows


choice.exe

Местонахождение

Windows\System32

Описание

Предложение пользователю для выбора

Вы можете запретить завершение сценария до тех пор, пока пользователь не нажмет какую-либо клавишу. Для этого применяется программа choice.exe. Например, при использовании команды Choice /M "Select Y for exit" /N /C Y сценарий не завершится до тех пор, пока пользователь не нажмет на кнопку Y.

Иногда бывает необходимо приостановить работу сценария, пока пользователь не нажмет какую-либо клавишу. Для этого используется программа choice.exe. Например, при использовании команды Choice /M "Select Y for exit" /N /C Y сценарий не завершится до тех пор, пока пользователь не нажмет на кнопку Y.

Очень интересной особенностью программы командной строки choice.exe является то, что она позволяет определить нажатую пользователем клавишу. При этом нажатая клавиша помещается в переменную среды %ERRORLEVEL%. Переменная среды ERRORLEVEL получает значение индекса клавиши, соответствующей выбранному элементу. Первый элемент в списке возвращает значение 1, второй - 2 и т.д. Если пользователь нажимает клавишу, не соответствующую допустимому выбору, подается звуковой сигнал. Если обнаруживается ошибка, возвращается значение ERRORLEVEL 255. Если нажимаются клавиши CTRL+BREAK или CTRL+C, программа возвращает значение ERRORLEVEL 0.

Синтаксис

CHOICE [/C список] [/N] [/CS] [/T тайм-аут /D элемент] [/M текст]

Параметры

/C список
Создаваемый список выбираемых элементов. Список по умолчанию "YN"
/N
Скрытие списка элементов в приглашении. Перед приглашением выводится сообщение и элементы остаются доступными для выбора
/CS
Включение учета регистра при выборе элементов. По умолчание в программе регистр символов не учитывается
/T тайм-аут
Число секунд перед выбором элемента по умолчанию. Допустимыми являются значения от 0 до 9999. Если указан 0, отсутствует пауза перед выбором элемента по умолчанию
/D элемент
Элемент, выбираемый по умолчанию через nnnn секунд. Символ должен присутствовать в наборе элементов в параметре /C; значение nnnn задается в параметре /T.
/M текст
Сообщение, отображаемое перед приглашением. Если не указано, программа выводит только приглашение
/?
Вывод справки по использованию

Пример

   CHOICE /?
   CHOICE /C YNC /M "Y - Да, N - Нет, C - Отмена."
   CHOICE /T 10 /C ync /CS /D y
   CHOICE /C ab /M "a" для выбора параметра 1 и "b" для выбора параметра 2.
   CHOICE /C ab /N /M "a" для выбора параметра 1 и "b" для выбора параметра 2.

Создадим простой сценарий

echo off
rem chcp 866
choice /M "Type number from 1 to 6" /N /C 123456
echo you press key %errorlevel%
pause


cipher.exe

Местонахождение

%windir%\system32

Описание

Программа шифрования файлов

Отображение или изменение шифрование папок и файлов на томах NTFS. Использованная без параметров команда cipher отображает состояние шифрования текущей папки и всех файлов, находящихся в ней.

В жизни каждого пользователя может случится ситуация, когда захочется стереть файл или папку, да так, чтобы её никто не смог восстановить. Традиционно, многие используют сторонний софт, а вот про то, что в Windows 7 можно обойтись встроенными средствами, знают далеко не все.

В состав Windows несколько лет входит утилита командной строки cipher.exe, используемая для обслуживания EFS (Encrypted File System, шифрованной файловой системы) - функциональности, предшествующей появлению Bitlocker.

В Windows 7 утилита cipher.exe обзавелась дополнительным ключом /W. Чтобы затереть навсегда содержимое папки, достаточно выполнить:

cipher /w x:\folder

Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе. Это гарантирует, что затертые данные восстановить будет нельзя. Этот ключ был добавлен для полной очистки пустых папок и разделов жесткого диска

Источник: Удаляем личные данные без возможности восстановления, используя встроенную утилиту Windows 7


cleanmgr.exe

Местонахождение

WINDOWS\system32

Описание

Программа очистки дискового пространства для Windows

Программа очистки диска используется для освобождения пространства на жестком диске с помощью удаления временных файлов Интернета, установленных компонентов и программ, которые больше не используются, и очистки корзины. Программу можно запустить через Пуск | Все программы | Стандартные | Служебные | Очистка диска

Дополнительные материалы

Удаление папки Windows.old


cliconfg.exe

Местонахождение

WINDOWS\system32

Описание

SQL Client Configuration Utility EXE

Программа сетевого клиента sql server cliconfg.exe позволяет настраивать протоколы и псевдонимы.


cmd.exe

Местонахождение

%windir%\system32

Описание

Обработчик команд Windows

В Windows имеется так называемая консоль - программа cmd.exe, которая является командным интерпретатором. При простом запуске, без указания параметров командной строки, консоль отображает версию операционной системы, информацию о защите авторских прав разработчиков ОС и саму командную строку, в которой можно ввести как параметр командной строки самой программы Cmd.exe, так и любую внешнюю команду, например, команду на запуск другого приложения или стандартную команду, типа mkdir, del и т. п.

Параметры командной строки

Синтаксис для командной строки:

CMD [/A | /U] [/Q] [/D] [/E:ON | /E:OFF] [/F:ON | /F:OFF] [/V:ON | /V:OFF]
[[/S] [/C | /K] команда]

Можно использовать одновременно несколько команд, используя между ними специальный разделитель - символы &&, при этом все сочетание нескольких команд должно быть заключено в кавычки, например, "команда&&команда&& команда".

/? - вызов справки
/A - вывод результатов выполнения заданной команды в формате ANSI
/C - выполнение заданной команды с последующим закрытием окна консоли
/D - отключение выполнения команд AutoRun (которые первыми автоматически выполняются при вызове cmd.exe), заданных в специальных разделах реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun и HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun
/E:ON (/E:OFF) - разрешение (запрет) расширений команд. В Windows XP по умолчанию включена расширенная обработка всех команд cmd.exe, этот параметр служит для включения / выключения расширений конкретного процесса. Расширенная обработка включает следующие команды: assoc, call, chdir (cd), color, del (erase), endlocal, for, ftype, goto, if, mkdir (md), popd, prompt, pushd, set, setlocal, shift, start (изменен также вызов внешних команд)
/F:ON (/F:OFF) - разрешение (запрет) завершения имен файлов и папок (по умолчанию выключено) конкретного вызова cmd.exe. Довольно удобная функция, позволяющая не вводить полностью вручную в окне консоли пути к файлам или имена самих папок, а ввести только часть длинного пути и с помощью нажатия специальной комбинации клавиш дать операционной системе найти подходящие варианты и просто выбрать нужный. (Если необходимо включить или отключить завершение имен для всех вызовов cmd.exe, то смотри Автонабор команд). Параметры пользователя имеют приоритет над параметрами компьютера, значение параметра /F командного процессора имеет приоритет над параметрами реестра. Microsoft вносит некоторые разъяснения по поводу использования этой функции: "Если завершение включено с помощью ключа командной строки /F:ON, то используются два управляющих символа: Ctrl+D для имен папок и Ctrl+F для имен файлов. Чтобы отключить конкретный символ завершения в системном реестре, в качестве кода специального символа используется шестнадцатеричное значение символа пробела (0 x 20). Завершение вызывается при вводе одного из этих двух специальных символов. Функция завершения берет строку пути слева от точки ввода, дописывает к ней символ шаблона, если таковой отсутствует, а затем строит список путей, которые соответствуют полученному определению. После этого выводится первый элемент этого списка соответствующих путей. Если же список пуст, то подается звуковой сигнал, и ничего не выводится. После этого повторный ввод того же самого специального символа приводит к циклическому перебору всех соответствующих путей. Нажатие клавиши Shift при вводе управляющего символа позволяет просматривать список путей в обратном порядке. Если изменить выведенный путь, а затем снова ввести управляющий символ, сохраненный список очищается, и строится новый список путей. То же самое происходит, если переключиться с одного символа завершения на другой. Единственное отличие при использовании символа завершения файла состоит в том, что при этом для построения списка соответствия берется и путь, и имя файла, а при использовании символа завершения папки - только путь. Если символ завершения используется в одной из встроенных команд манипулирования папками (CD, MD или RD), то всегда подразумевается символ завершения папок. Символ завершения правильно работает и с именами файлов, содержащими пробелы или иные специальные символы, если при этом строка соответствия заключена в кавычки. Кроме того, если сместить точку ввода влево, а затем использовать символ завершения внутри строки, оставшийся справа от точки ввода текст будет отброшен. Специальные символы, которые требуют обязательного заключения в кавычки: <пробел>&()[]{}^=;!'+,~".
/K - выполнение заданной команды без последующего завершения (окно консоли не закроется)
/Q - отключение вывода команд на экран (ECHO OFF).
/R - аналогичен параметру /C
/S - изменение поведения команды после /C или /K
/T:цвет - задание цвета текста и фона окна консоли. Параметр цвет имеет значение в виде двух шестнадцатеричных чисел: первое определяет цвет фона окна, а второе - текста в окне. То есть результатом выполнения команды "CMD /T:7С" будут светло-красные буквы на белом фоне.
/U - вывод результатов выполнения команды в формате Unicode
/V:ON (/V:OFF) - разрешение (запрет) отложенного расширения переменных среды (для конкретного вызова cmd.exe) с применением восклицательного знака "!" в качестве разделителя. Например, /V:ON разрешает использовать !var! в качестве расширения переменной var во время выполнения. Синтаксис var служит для расширения переменных при вводе, что приводит совсем к другим результатам внутри цикла FOR. При включенном отложенном расширении переменных среды символ "!" (восклицательный знак) может использоваться для замены текущего значения переменной среды во время выполнения; /X - означает то же, что и ключ /E:ON, из соображений совместимости; /Y то же, что и /E:OFF. И еще несколько замечаний. Если указаны ключи /C или /K, то остальная часть командной строки после такого ключа обрабатывается как командная строка, а обработка символов кавычек (") ведется таким образом. Символы кавычек в командной строке сохраняются, если выполняются все перечисленные ниже условия: ключ /S отсутствует; есть ровно два символа кавычек; между ними нет других специальных символов, как то: &<>()@^|; между ними имеются один или несколько пробелов; строка, заключенная в кавычки, является именем исполняемого файла. В противном случае проверяется первый символ, и если он является символом кавычек, то он удаляется, также удаляется последний символ кавычек в командной строке, а весь текст после этого последнего символа кавычек сохраняется.

Таблица для задания цвета текста и фона окна консоли
0 - черный | 1 - синий | 2 - зеленый | 3 - голубой
4 - красный | 5 - лиловый | 6 - желтый | 7 - белый
8 - серый | 9 - светло-синий | A - светло-зеленый | B - светло-голубой
C - светло-красный | D - светло-лиловый | E - светло-желтый | F - ярко-белый

Кстати, цвет и другие настройки можно изменять и другим способом. Щелкните по строке заголовка окна и выберите пункт Свойства. Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Цвета вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB.

На вкладке Расположение настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее.

Текст в окне командной строки

Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Изменить. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Пометить и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Копировать. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Вставить.

Для повторного выполнения команды воспользуйтесь стрелками вверх и вниз, позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls.

Быстрая вставка пути к файлу

Можно не вводить длинный путь к файлу, а просто перетащить файл в окно командной строки.

Автозаполнение

Можно использовать автозаполнение - напечатайте первую часть пути, например, E:\. Затем нажмите клавишу Tab. Все доступные имена файлов и папок будут циклически показываться в окне.

История команд

Нажимая на клавишу со стрелкой вверх, вы можете выбрать предыдущие использованные вами команды. Клавиша со стрелкой вниз позволит перейти к следующим командам. Чтобы увидеть все команды, нажмите на клавишу F7.

Полноэкранный режим

Начиная с Windows Vista, командная строка не поддерживает полноэкранный режим. Если вы нажмете на клавиши Alt+Enter, то получите соответствующее сообщение.

Команды

TITLE - для изменения заголовка строки
TITLE [строка], где строка - это будущий заголовок окна командной строки (записывается без кавычек). После задания заголовка окна он может быть изменен только повторным вызовом команды TITLE. Использование данной команды может быть полезно в командных файлах. Так, выполнение примера, который приведен ниже, будет сопровождаться появлением соответствующей надписи в заголовке окна:

@ECHO OFF
TITLE Копируются файлы...
COPY \\Server\Share\*.doc C:\User\Common\*.doc
ECHO Копирование закончено.
TITLE Процесс завершен

Команда АТ - С помощью этой команды можно запускать команды и программы в определенное время.
AT [\\имя компьютера] [ [id] [/DELETE] | /DELETE [/YES]]
AT [\\имя компьютера] time [/INTERACTIVE] [ /EVERY:дата[,...] | /NEXT:дата [,...]] "команда"
\\имя компьютера указывает на удаленный компьютер, на котором могут быть запущены планируемые задачи. Если этот параметр не указан, то по умолчанию предполагается тот компьютер, на котором запускается команда АТ;
id идентификатор, назначенный указанной команде;
/delete отменяет намеченную команду. Если id опущен, все назначенные команды на компьютере отменены;
/yes этот параметр в случае использования с предыдущим параметром (/delete) автоматически включает подтверждение для всех запросов;
time время выполнения команды (в 24-часовом формате часы:минуты);
/interactive позволяет команде AT обмениваться с подключенными на данный момент в системе пользователями;
/every:дата[,...] выполняет команду в каждый указанный день (дни) недели или месяц. Если дата опущена, подразумевается текущий день месяца;
/next:дата[...] выполняет указанную команду при следующем наступлении указанной даты (например, в следующий четверг). Если дата не указанна, по умолчанию принимается текущий день месяца;
"команда" указывается команда Windows NT или пакетная программа, которая будет выполнена. Имя файла должно указываться полностью. При этом, если выполняется какая-либо из внутренних команд, например, COPY или DIR, а не исполняемый файл, то необходим запуск командного интерпретатора с ключом / С, например: AT 10:00 "CMD /C DIR > C:\test.out.
Команда For - Ее возможности обширны, но мы ограничимся демонстрацией лишь одной из них - Копирование по сети на все машины сразу. Допустим, что требуется скопировать файл на двадцать машин. Делается это очень быстро. Сначала в файл list.txt записываем список всех имеющихся в сети машин. В консоли пишем:

net view > c:\list.txt
Затем, чтобы выполнить, например, копирование файла patch.exe на каждую машину из списка, даем команду:
FOR /F "tokens=1" %i in (с:\list.txt) do copy d:\temp\patch.exe "%i\C$\program files\ICQ"
Переменная %i будет автоматически принимать значение NetBIOS-имени машины из новой строки файла list.txt и на эту машину будет производиться копирование.

Запуск командной строки (cmd.exe) с правами администратора

Для запуска командной строки (cmd.exe) с правами администратороа сделайте следующее:
Нажмите Пуск и в поле поиска ввдеите cmd. На найденном файле нажмите правую клавишу мыши и выберите в контекстном меню пункт "Запуск от имени администратора". Обратите внимание, что заголовок окна примет вид Администратор: Командная строка.

Реестр

В справочнике по реестру Windows смотрите статью Изменение вида приглашения командной строки


cmdkey.exe

Местонахождение

%windir%\System32

Описание

Программа командной строки для диспетчера учетных данных

Создает, выводит список и удаляет сохраненные имена пользователей, а также пароли и учетные данные.

Синтаксис

cmdkey [{/add:TargetName | /generic:TargetName}] [/smartcard] [/user:UserName [/pass[:Password]] [/delete{:TargetName | /ras}] [/list[:TargetName]]

Параметры

/add
Добавляет имя пользователя и пароль в лист
TargetName
Компьютер или домен, с которыми связывается запись
/generic
Добавляет общие учетные записи в список
/smartcard
Получает учетные записи со смарт-карты
/user: UserName
Задает имя. Если не задано, то будет запрошено
/pass: Password
Пароль. Если не задан, то будет запрошен
/delete {:TargetName | /ras}
Удаляет учетную запись и пароль из списка. Если TargetName задан, то запись будет удалена. Если /ras задан, то хранимя удаленная запись будет удалена
/list: TargetName
Выводит список учетных записей. Если TargetName не задан, то все учетные записи будут показаны
/?
Выводит справку


cmstp.exe

Местонахождение

%windir%\system32

Описание

Установщик профилей диспетчера подключений

Установка или удаление профиля службы диспетчера подключений. Выполненная без параметров команда cmstp устанавливает профиль службы со стандартными параметрами, соответствующими данной операционной системе и разрешениям пользователя. Описание программы есть в Справке Windows.


colorcpl.exe

colorcpl.exe (Управление цветом)

Местонахождение

%systemroot%\system32

Позволяет выбрать цветовой профиль для таких устройств передачи графики, как монитор, факс, сканер или принтер. С помощью цветового профиля настраивается адекватная передача цвета на определенном устройстве.

Способы запуска

Если используется вид По категориям, тогда доступ к соответствующему значку можно получить при помощи одноименного элемента категории Оборудование и звук


comp.exe

Местонахождение

%windir%\system32

Описание

Утилита сравнения файлов

Побайтное сравнение двух или нескольких файлов. Команда comp позволяет сравнивать файлы, находящиеся на разных дисках и в разных каталогах. При сравнении файлов с помощью команды comp выводятся их имена и расположения. Выполненная без параметров команда comp запрашивает файлы для сравнения.

Описание программы есть в Справке Windows.

Синтаксис

comp [файл1] [файл2] [/d] [/a] [/l] [/n=кол_строк] [/c]

Примеры

Чтобы сравнить содержимое каталога C:\Reports с содержимым каталога резервных копий \\Sales\Backup\April, введите следующую команду:

comp c:\reports \\sales\backup\april

Чтобы сравнить первые десять строк файлов в каталоге \Invoice и вывести результат в десятичном формате, введите следующую команду:

comp \invoice\*.txt \invoice\backup\*.txt /n=10 /d


compact.exe

Местонахождение

%windir%\system32

Описание

Программа сжатия файлов

Вывод сведений или изменение уплотнения файлов и каталогов в разделах NTFS. Запущенная без параметров команда compact выводит сведения об уплотнении файлов в текущем каталоге. Описание программы есть в Справке Windows.

Синтаксис

compact [{/c|/u}] [/s[:каталог]] [/a] [/i] [/f] [/q] [имя_файла[...]]


ComputerDefaults.exe

Местонахождение

WINDOWS\system32

Описание

Элемент панели управления "Настройка доступа программ и умолчаний"

Компонент «Настройка доступа программ и умолчаний» облегчает изменение программы по умолчанию, используемой для выполнения таких задач, как просмотр веб-сайтов, отправка электронной почты, воспроизведение звуковых и видеофайлов и передача мгновенных сообщений.

Открыть программу можно также через Панель управления\Все элементы панели управления\Программы по умолчанию и щелкнуть по ссылке Настройка доступа программ и умолчаний

Описание программы есть в справке Windows


control.exe

Местонахождение

Windows\system32

Описание

Windows Control Panel

Данная утилита командной строки служит для запуска апплетов Панели управления

Примеры

Брандмауэр Windows

Брандмауэр Windows: control.exe /name Microsoft.WindowsFirewall

Восстановить умолчания: control /name Microsoft.WindowsFirewall /page PageRestoreDefaults

Настроить параметры: control /name Microsoft.WindowsFirewall /page PageConfigureSettings

Разрешенные программы: control /name Microsoft.WindowsFirewall /page PageConfigureApps

Дата и время

control date/time

Защитник Windows

control.exe /name Microsoft.WindowsDefender

Значки области уведомлений

Значки области уведомлений: control /name Microsoft.NotificationAreaIcons

Системные значки: control /name Microsoft.NotificationAreaIcons /page SystemIcons

Мышь

control mouse

Устранение неполадок

Оформление и персонализация: control /name Microsoft.Troubleshooting /page display

Система и безопасность: Команда control /name Microsoft.Troubleshooting /page system

Настройка: control /name Microsoft.Troubleshooting /page settingPage

Центр обновления Windows

Настройка параметров: control /name Microsoft.WindowsUpdate /page pageSettings

Центр специальных возможностей

Использование компьютера без мыши или клавиатуры: control /name Microsoft.EaseOfAccessCenter /page pageNoMouseOrKeyboard

Использование компьютера без экрана: control /name Microsoft.EaseOfAccessCenter /page pageNoVisual

Использование текста или зрительных образов вместо звуков: control /name Microsoft.EaseOfAccessCenter /page pageEasierWithSounds

Настроить кнопки мыши: control /name Microsoft.EaseOfAccessCenter /page pageMouseKeysSettings

Настроить кнопки фильтра: control /name Microsoft.EaseOfAccessCenter /page pageFilterKeysSettings

Настроить повторные и медленные нажатия клавиш: control /name Microsoft.EaseOfAccessCenter /page pageRepeatRateSlowKeysSettings

Облегчение работы с клавиатурой: control /name Microsoft.EaseOfAccessCenter /page pageKeyboardEasierToUse

Облегчение работы с мышью: control /name Microsoft.EaseOfAccessCenter /page pageEasierToClick

Облегчение сосредоточения на задачах: control /name Microsoft.EaseOfAccessCenter /page pageEasierToReadAndWrite

Оптимизация изображения на экране: control /name Microsoft.EaseOfAccessCenter /page pageEasierToSee

Параметры администрирования: control /name Microsoft.EaseOfAccessCenter /page pageAdminSettings

Рекомендуемые параметры: control /name Microsoft.EaseOfAccessCenter /page pageRecommendations

Узнать, как настроить этот компьютер для людей, испытывающих затруднения при работе с текстом: control /name Microsoft.EaseOfAccessCenter /page pageQuestionsCognitive

Узнать, как настроить этот компьютер для людей с ограничениями подвижности: control /name Microsoft.EaseOfAccessCenter /page pageQuestionsDexterity

Узнать, как настроить этот компьютер для людей с ограничениями по зрению: control /name Microsoft.EaseOfAccessCenter /page pageQuestionsEyesight

Узнать, как настроить этот компьютер для людей с ограничениями речи: control /name Microsoft.EaseOfAccessCenter /page pageQuestionsSpeech

Узнать, как настроить этот компьютер для людей с ограничениями слуха: control /name Microsoft.EaseOfAccessCenter /page pageQuestionsHearing

Язык и региональные стандарты

control international

Советы

Справочник Windows.Народные советы. Раздел Автоматический вход в систему - без ввода логина и пароля.

Реестр

Cправочник по реестру Windows: Запрет запуска Панели управления и ее апплетов


convert.exe

Местонахождение

%windir%\system32

Описание

File System Conversion Utility

Утилита командной строки служит для преобразования томов с файловой системой FAT и FAT32 в тома с файловой системой NTFS.

Синтаксис

convert [том] /fs:ntfs [/v] [/cvtarea:имя_файла] [/nosecurity] [/x]

Описание параметров есть в справке Windows


credwiz.exe

Местонахождение

Windows\system32

Описание

Мастер архивации и восстановления учетных данных

Позволяет сохранить имена пользователей и пароли. Для восстановления пароля на основе содержимого файла можно воспользоваться синтаксисом:

credwiz.exe «имя файла»


cscript.exe

Местонахождение

%windir%\system32

Описание

Microsoft (r) Console Based Script Host

Сервер сценариев cscript.exe является консольным вариантом, предназначенный для взаимодействия с пользователем через командную строку (в отличии от GUI-приложения wscript.exe).

Синтаксис

cscript [имя_сценария] [параметры_сервера] [аргументы_сценария]

Описание параметров есть в справке Windows


csrss.exe

Местонахождение

%windir%\system32

Описание

Процесс исполнения клиент-сервер

CSRSS.exe — (сокр. от Client-Server Runtime Subsystem) является критическим процессом операционной системы Windows. Исполняемый файл является частью подсистемы Win32 и поэтому этот процесс нельзя закрыть в менеджере задач. Завершение csrss.exe каким-либо другим способом ведёт к аварийной перезагрузке Windows или при ее завершении система завершит работу с отображением BSOD.

Приложение отвечает за работу:

  • терминальных служб
  • служб удалённого доступа к рабочему столу
  • консольных приложений

Некоторые вирусы используют данное имя приложения, чтобы не вызвать подозрения у пользователя, тем более что для каждого терминального доступа создаётся отдельный экземпляр файла, поэтому на серверных машинах их количество может доходить до нескольких десятков. Оригинальный файл хранится только в папке system32, а его подмена практически невозможна на компьютере с одной ОС.


cttune.exe

cttune.exe (Windows 7)

Местонахождение

%windir%\System32

Описание

Настройка ClearType

Запускает апплет Панели управления ClearType Text Tuner, позволяющий настроить отображение текста вашим монитором. Вы можете, например, немного затемнить цвет текста для комфортного чтения на вашем ноутбуке.


dccw.exe

dccw.exe (Windows 7)

Местонахождение

Windows\System32

Описание

Калибровка цветов экрана

Позволяет настроить отображение изображений на вашем мониторе. Можете корректировать яркость, контрастность и другие параметры. Эта программа также запускается при нажатии на кнопку Калибровка цветов в апплете Панели управления Экран (Панель управления | Оборудование и звук | Экран).


dcomcnfg.exe

Местонахождение

Windows\System32

Описание

COM+

Эта утилита позволяет задавать настройки защиты для конкретного приложения, а также настройки защиты, используемые по умолчанию. Несколько статей о применении утилиты есть на сайте Microsoft


debug.exe

Местонахождение

%windir%\System32

Описание

debug.exe

Синтаксис

DEBUG [[drive:][path]filename [testfile-parameters]]

Параметры

[drive:][path]filename
Задает файл, который вы хотите протестировать
testfile-parameters
Задает информацию через параметры командной строки, необходимую для тестирования файла

После запуска отладки, введите команду ? для показа отладочных команд.


defrag.exe

Местонахождение

%windir%\System32

Описание

Модуль дефрагментатора дисков

Служит для обнаружения и объединения фрагментированных файлов на локальных томах в целях повышения производительности системы.

Синтаксис

defrag <тома> | /C | /E <тома>    [/H] [/M | [/U] [/V]]
defrag <тома> | /C | /E <тома> /A [/H] [/M | [/U] [/V]]
defrag <тома> | /C | /E <тома> /X [/H] [/M | [/U] [/V]]
defrag <том>                      /T [/H]       [/U] [/V]

Параметры

Значение | Описание
/A | Анализ указанных томов.
/C | Выполнение операции для всех томов.
/E | Выполнение операции для всех томов, за исключением указанных.
/H | Запуск операции с обычным приоритетом (по умолчанию с низким).
/M | Запуск операции одновременно на каждом томе в фоновом режиме.
/T | Отслеживание операции, которая уже выполняется на указанном томе.
/U | Отображение хода выполнения операции на экране.
/V | Вывод подробных данных статистики фрагментации.
/X | Объединение свободного пространства на указанных томах.

Также имеются недокументированные ключи

/R - Performs partial defragmentation (default). Attempts to consolidate only fragments smaller than 64 megabytes (MB).

/W - Performs full defragmentation. Attempts to consolidate all file fragments, regardless of their size.

/F - Forces defragmentation of the volume when free space is low.

Примеры

defrag C: /U /V
defrag C: D: /M
defrag C:\точка_подключения /A /U
defrag /C /H /V

Описание параметров есть в справке Windows


DevicePairingWizard.exe

Местонахождение

Windows\System32

Описание

Device Pairing Application

Позволяет подключить устройства к компьютеру. Например, можно подключить пульт от приставки Wii к компьютеру через Bluetooth (смотри статью Используем Wiimote не по назначению).


dfrgui.exe

Местонахождение

Windows\System32

Описание

Дефрагментация диска (Майкрософт)

Программа dfrgui.exe пришла на смену оснастки dfrg.msc, начиная с Windows Vista.

Данную программу также можно запустить с помощью кнопки Выполнить дефрагментацию..., расположенной на вкладке Сервис диалогового окна Свойства, вызываемого из контекстного меню диска.

После запуска данной программы начнется анализ дисков, и если программа обнаружит, что дефрагментация действительно нужна, тогда она предложит ее выполнить.

В окне программы имеются кнопки анализа, запуска процесса дефрагментации, настройки расписания автоматического запуска дефрагментации в указанное время (по умолчанию один раз в неделю). Для использования возможности автоматического запуска дефрагментации необходимо, чтобы служба TASK SCHEDULER была запущена. Если эта служба не запущена, тогда вы не сможете запустить программу dfrgui.exe.

По умолчанию операционная система имеет задание ScheduledDefrag, расположенное в разделе Task Scheduler Library/Microsoft/Windows/Defrag. Данное задание выполняет команду defrag.exe -c –i каждую среду в час ночи.

Смотри также

Команда, которая выполняется после нажатия на кнопку Выполнить дефрагментацию...

Настройка дефрагментации


dialer.exe

Местонахождение

%windir%\System32

Описание

Телефон Microsoft Windows

Стандартная звонилка. Кто-нибудь пользуется этой программой?


diskcomp.com

Местонахождение

%windir%\System32

Описание

Disk Comparison Utility

Утилита для сравнения содержимого двух гибких дисков. При запуске команды diskcomp без параметров для сравнения дисков используется текущий дисковод

Синтаксис

diskcomp  [диск1: [диск2:]]

Параметры

диск1
Задание дисковода, содержащего первый гибкий диск.
диск2
Задание дисковода, содержащего второй гибкий диск.
/?
Отображение справки в командной строке.

Примечания

Команда diskcomp работает только с гибкими дисками и для жестких дисков ее нельзя использовать . Если жесткий диск будет задан в качестве параметра диск1 или диск2, то diskcomp выведет на экран следующее сообщение:

Диск задан неправильно.
Указанный диск не существует либо является несъемным

Если все дорожки на сравниваемых дисках совпадают, diskcomp выводит следующее сообщение:

Различия не найдены.

Если обнаружены несовпадающие дорожки, команда diskcomp выведет на экран следующее сообщение:

Ошибка сравнения:
сторона 1, дорожка 2

После окончания сравнения команда diskcomp выведет следующее сообщение:

Сравнить еще диск [Y(да)/N(нет)]?

При нажатии клавиши Y программа diskcomp выведет приглашение вставить следующий гибкий диск в дисковод для повторения операции. При нажатии клавиши N работа команды diskcomp завершается.

В процессе сравнения не учитываются номера томов гибких дисков командой diskcomp.

Если опущен параметр диск2, команда diskcomp использует текущий диск в качестве параметра диск2. Если не заданы оба параметра, diskcomp использует текущий дисковод для обоих дисков. Если текущий диск совпадает с параметром диск1, команда diskcomp выведет приглашение сменить диски по мере необходимости.

Если один и тот же диск задан в качестве параметров диск1 и диск2, команда diskcomp будет работать с использованием одного дисковода и запрашивать смену дисков, когда потребуется. Возможно, менять диски местами придется несколько раз, в зависимости от емкости дисковода и объема доступной памяти.

С помощью команды diskcomp невозможно сравнивать односторонние диски с двухсторонними, также как и диски двойной плотности с дисками высокой плотности. Если типы дисков диск1 и диск2 отличаются друг от друга, команда diskcomp выведет на экран следующее сообщение:

Несовместимые форматы дисководов или дисков.

Команда diskcomp не работает с сетевыми устройствами и дисками, созданными командой subst. При попытке использовать diskcomp с устройством любого из этих типов программа diskcomp выведет следующее сообщение об ошибке:

Неправильно указан диск.

Если команда diskcomp используется для сравнения диска, созданного с помощью программы copy, diskcomp может выводить сообщение, аналогичное следующему:

Ошибка сравнения:
сторона 0, дорожка 0

Это сообщение может возникать даже в том случае, если файлы на дисках полностью совпадают. Это связано с тем, что хотя команды copy и дублирует сведения, она не обязательно помещает их в то же место, что и на диске-оригинале. Смотрите также дополнительные сведения о сравнении файлов на дисках с помощью команды fc.exe.

Коды завершения команды diskcomp

Код завершения | Описание
0 | Диски одинаковы
1 | Найдены различия
3 | Возникла невосстановимая ошибка
4 | Возникла ошибка инициализации

Для обработки кодов завершения, возвращаемых diskcomp можно воспользоваться параметром уровень_ошибки команды if в пакетном файле.

Примеры

Если в системе установлен только один дисковод гибких дисков (например A) и требуется сравнить два диска, введите следующую команду:

diskcomp a: a:
Программа diskcomp выводит приглашения вставить диски по мере необходимости.

Пример использования параметра errorlevel в строке команды if для обработки кодов завершения программы diskcomp в пакетном файле:

rem Checkout.bat сравнивает два диска в дисководах A и B
echo off
diskcomp a: b:
if errorlevel 4 goto ini_error
if errorlevel 3 goto hard_error
if errorlevel 1 goto no_compare
if errorlevel 0 goto compare_ok
:ini_error
echo ОШИБКА: недостаточно памяти или неверная команда
goto exit
:hard_error
echo ОШИБКА: возникла невосстановимая ошибка
goto exit
:break
echo "Нажата комбинация клавиш CTRL+C" для остановки сравнения
goto exit
:no_compare
echo Диски отличаются
goto exit
:compare_ok
echo Сравнение прошло успешно, диски совпадают
goto exit
:exit


diskcopy.com

Местонахождение

%windir%\System32

Описание

Disk Copy Utility

Копирование содержимого одного гибкого диска на другой гибкий диск. При запуске команды diskcopy без параметров для исходного и конечного дисков используется текущий дисковод.

Синтаксис

diskcopy  [диск1: [диск2:]] [/V]

Параметры

диск1
Задание дисковода, содержащего первый гибкий диск
диск2
Задание дисковода, содержащего второй гибкий диск
/V
Копирование с проверкой правильности переноса данных
/?
Отображение справки в командной строке

Примечания

Команда diskcopy работает только с гибкими дисками и для жестких дисков ее нельзя использовать.

Коды завершения

Код завершения | Описание
0 | Операция копирования прошла успешно
1 | Возникла нефатальная ошибка чтения/записи
3 | Возникла невосстановимая ошибка
4 | Возникла ошибка инициализации

Примеры

Чтобы скопировать диск в дисководе B на диск в дисководе A, введите следующую программу:

diskcopy b: a:


diskpart.exe

Местонахождение

%windir%\System32

Описание

Disk Part

Программа DiskPart.exe — это работающий в текстовом режиме командный интерпретатор, который позволяет управлять объектами (дисками, разделами или томами) с помощью сценариев или команд, вводимых с командной строки.

Синтаксис

diskpart [/add | /delete] [имя_устройства | имя_диска | имя_раздела] [размер]

Описание программы есть в справке Windows

Смотри также описание на сайте Microsoft


diskperf.exe

Местонахождение

Windows\System32

Описание

Конфигурация счетчиков производительности дисков

Утилита комадной строки для конфигурации счетчиков производительности дисков.

Синтаксис

DISKPERF [-Y[D|V] | -N[D|V]] [\\имя_компьютера]

Параметры

-Y
Задает запуск всех счетчиков производительности дисков при перезагрузке системы.
-YD
Включает счетчики производительности физических дисков при перезагрузке системы.
-YV
Включает счетчики производительности логических дисков или томов при перезагрузке системы.
-N
Отключает все счетчики производительности дисков при перезагрузке системы.
-ND
Отключает счетчики производительности физических дисков.
-NV
Отключает счетчики производительности логических дисков.
\\имя_компьютера
имя компьютера, на котором требуется просмотреть или задать параметры использования счетчиков производительности дисков. Компьютер должен работать под управлением Windows 2000.

ПРИМЕЧАНИЕ: Счетчики производительности включены постоянно на системах версии Windows 2000 и более поздних.


dism.exe

Местонахождение

%systemroot%\System32

Описание

Программа обслуживания образов DISM

DISM.exe – это новое средство командной строки в Windows 7

DISM перечисляет, устанавливает, удаляет, настраивает и обновляет компоненты и пакеты в образах Windows. Список доступных команд зависит от обслуживаемого образа, а также от того, находится ли образ в автономном или рабочем состоянии.

DISM.exe можно использовать для работы с образами Windows, как с файлами Windows image (WIM), так и с виртуальными жесткими дисками (virtual hard disk - VHD). Работа с образами позволяет такие операции как: добавление и удаление драйверов устройств, добавление и удаление пакетов операционной системы, добавление заплаток, работа с региональными настройками, а также выполнение аналогичных действий с образами. DISM также может использоваться для обновления образа Windows до другого издания (к примеру, с Business до Ultimate), и для подготовки образа системы к использованию.

DISM.exe также включает в себя функции подключения и отключения образов.

Синтаксис

DISM.exe [параметры_dism] {команда_WIM} [<аргументы_WIM>]
DISM.exe {/Image:<путь_к_автономному_образу> | /Online} [параметры_dism]
         {служебная_команда} [<аргументы_служебной_команды>]

Параметры

КОМАНДЫ WIM:

/Get-MountedWimInfo
Отображает сведения о подключенных образах WIM

/Get-WimInfo
Отображает сведения обо всех образах в WIM-файле. Помните, что установочный образ может содержать более одного образа Windows

/Commit-Wim
Сохраняет изменения подключенного образ WIM

/Unmount-Wim
Отсоединяет подключенный образ WIM

/Mount-Wim
Подключает образ из WIM-файла

/Remount-Wim
Восстанавливает потерянный каталог подключения WIM

/Cleanup-Wim
Удаляет ресурсы, связанные с поврежденными подключенными образами WIM

/get-drivers
отобразить список драйверов, уже установленных в подключенном образе

/add-driver
добавить драйвер в наш подключенный образ

/?
получить справочную информацию

СПЕЦИФИКАЦИИ ОБРАЗА:

/Online
Задает работающую операционную систему как назначение.

/Image
Задает путь к корневому каталогу автономного образа Windows

ПАРАМЕТРЫ DISM:

/English
Отображает данные, выводимые командной строкой, на английском языке

/Format
Задает формат отчета

/WinDir
Задает путь к каталогу Windows

/SysDriveDir
Задает путь к файлу системного загрузчика с именем BootMgr

/LogPath
Задает путь к файлу журнала

/LogLevel
Задает уровень ведения журнала событий (1-4)

/NoRestart
Запрещает автоматическую перезагрузку и вывод пользователю предложений выполнить перезагрузку

/Quiet
Скрывает все сведения за исключением сообщений об ошибках

/ScratchDir
Задает путь к каталогу временных файлов

Для получения сведений об этих параметрах DISM и их аргументах укажите требуемый параметр перед "/?".

Примеры

DISM.exe /Mount-Wim /?
DISM.exe /ScratchDir /?
DISM.exe /Image:C:\test\offline /?
DISM.exe /Online /?

Для удаления бэкапа после установки Windows 7 Service Pack 1

DISM /online /cleanup-Image /spsuperseded
DISM /image:<path_to_offline_image> /cleanup-Image /spsuperseded


displayswitch.exe

displayswitch.exe (Windows 7)

Местонахождение

Windows\system32

Описание

Переключение экрана

Новая программа в Windows 7, позволяющая отобразить дополнительные опции дисплея, например, расширить рабочий стол на второй монитор, получить изображения с ноутбука на внешний проектор и т.д. Эту программу можно вызвать при помощи горячих клавиш Win+P


djoin.exe

Местонахождение

%windir%\System32

Описание

Автоматическая настройка команды для присоединения к домену

Автономное присоединение к домену — это новый процесс, присоединяющий компьютеры под управлением Windows 7 или Windows Server 2008 R2 к домену без необходимости связи с контроллером домена. Это позволяет присоединять компьютеры к домену там, где отсутствует подключение к корпоративной сети. Подробнее об утилите можно прочитать в статье Пошаговое руководство по автономному присоединению к домену (Djoin.exe)

Синтаксис

djoin /provision /domain  /machine <destination computer> /savefile <filename.txt> [/machineou <OU name>] [/dcname <name of domain controller>] [/reuse] [/downlevel] [/defpwd] [/nosearch] [/printblob]

Параметры

/provision
Создание учетной записи компьютера в доменных службах Active Directory
/domain <имя_домена>
Имя присоединяемого домена
/machine <конечный_компьютер>
Имя компьютера, который будет присоединен к домену
/machineou <название_подразделения>
Название подразделения, в котором будет создана учетная запись компьютера. По умолчанию учетная запись компьютера создается в контейнере «Компьютеры»
/dcname <имя_контроллера_домена>
Имя определенного контроллера домена, который создаст учетную запись компьютера. Если контроллер домена не указан, то для выбора контроллера домена используется процесс локатора контроллера домена
/reuse
Повторное использование существующей учетной записи компьютера. Пароль для учетной записи компьютера будет сброшен
/downlevel
Поддержка использования контроллера домена с версией Windows Server до Windows Server 2008 R2
/savefile <filename.txt>
Сохранение предоставляемых данных в файл
/defpwd
Использование пароля учетной записи компьютера по умолчанию (не рекомендуется)
/nosearch
Пропуск задержки конфликта учетных записей. Требуется параметр /DCName
/printblob
Возвращает кодируемый в 64-разрядной форме большой двоичный объект метаданных для файла ответов
/requestodj
Запрос автономного присоединения к домену при следующем запуске
/Loadfile
Выходные данные выполнения предыдущей команды предоставления данных
/windowspath <путь_к_каталогу_Windows_автономного_образа>
Путь к каталогу Windows автономного образа. При использовании параметра /localos укажите %systemroot% или %windir% в качестве значения параметра /windowspath
/localos
Указывает установку локальной операционной системы (не автономного образа) со сведениями о присоединении к домену. При использовании этого параметра параметру /windowspath должно быть задано значение %systemroot% или %windir%. Выполняйте этот параметр только на конечном компьютере, который будет присоединен к домену. Этот параметр заблокирован от выполнения на контроллере домена. Поскольку этот параметр включает данные большого двоичного объекта в образ локально выполняемой операционной системы, компьютер необходимо перезапустить, чтобы завершить операцию присоединения к домену. Это действие также выполняется и при сетевом присоединении к домену


DpiScaling.exe

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Экран

Описание

Панель управления - экран

DpiScaling.exe запускает компонент Панели управления Экран


driverquery.exe

Местонахождение

Windows\system32

Описание

Опрос драйверов

Утилита командной строки для вывода списка всех установленных драйверов устройств и их свойств

Синтаксис

driverquery  [/s компьютер] [/u домен\пользователь /p пароль] [/fo {TABLE|LIST|CSV}] [/nh] [/v] [/si]

Описание параметров есть в справке Windows

Для вывода списка установленных драйверов в виде файла, пригодного для отображения в Excel используйте команду:

driverquery /v /fo csv > drivers.csv.


dvdmaker.exe

Местонахождение

%programfiles%\DVD Maker

Описание

DVD-студия Windows

Программа, с помощью которой записанные материалы можно записать на DVD-диск с возможностью проигрывания на бытовых DVD-плеерах. Программа расчитана на любителя и имеет базовые настройки параметров: создание меню DVD, выбор пропорции видео (широкоэкранное или стандартное), изменение формата видео (PAL или NTSC), а также скорость записи DVD-диска. C помощью данной простой утилиты пользователь может записать диск за пару щелчков мыши.


dvdplay.exe

Местонахождение

%WINDIR%\System32

Описание

dvdplay placeholder Application

В ранних версиях Windows данная программа служила для воспроизведения мультимедийных DVD-дисков. В Windows 7 программа просто запускает Проигрыватель Windows Media.


dwm.exe

Местонахождение

%windir%\system32

Описание

Диспетчер рабочего стола

DWM – это новый интерфейс, управляющий объединением различных выполняющихся и визулизируемых окон с рабочим столом Windows Vista. Windows Presentation Foundation (WPF) обеспечивает слой верхнего уровня, управляющий визуализацией на уровень рабочего стола, а модель видеодрайверов Windows (Windows Display Driver Model, WDDM) обрабатывает фактическую низкоуровневую визуализацию на экран. Интерфейс DWM имеется во всех версиях Windows Vista, за исключением Windows Vista Home Basic.


dxdiag.exe

Местонахождение

%systemroot%\System32

Описание

Средство диагностики Microsoft DirectX

Удобная программа для проверки возможностей DirectX. Например, можно быстро узнать, какая версия DirectX установлена на компьютере и т.д.


edit.com

Местонахождение

%windir%\system32

Описание

edit.com

Редактор MS-DOS, который позволяет создавать и редактировать текстовые файлы в формате ASCII.

Синтаксис

edit [/B] [/H] [/R] [/S] [/?] [file(s)]

Параметры

[file(s)]
Задает местонахождение и имя текстового файла. Если файл не существует, редактор MS-DOS создаст его. Если файл существует, редактор MS-DOS откроет его и выведет содержимое на экран.
/B
Устанавливает монохромный режим работы редактора MS-DOS. Этот параметр следует выбирать в случае, когда редактор MS-DOS неправильно отображается на черно-белом мониторе.
/H
Задает режим вывода максимального количества строк для используемого монитора.
/R
Загружает файл(ы) в режиме только для чтения
/S
Использует короткие имена файлов (8.3)
/?
Отображение справки в командной строке.


ehshell.exe

ehshell.exe (Windows Vista)

Местонахождение

%systemroot%\ehome\

Описание

Windows Media Center

Под файлом ehshell.exe скрывается программа Windows Media Center, которая представляет собой очень красивую оболочку для всех мультимедийных функций операционной системы Windows, начиная с Windows Vista. При помощи данной программы можно быстро получить доступ к мультимедийному контенту.

Основные возможности

  • Запись мультимедийного контента на DVD-диск, а также синхронизация содержимого стандартных папок Windows (Изображения, Видео, Музыка) со съемным диском;
  • Просмотр содержимого папок Изображения и Видео в режиме слайд-шоу (с применением различных эффектов перехода при смене изображения);
  • Просмотр телепередач (если установлен TV-тюнер), а также возможность их записи на жесткий диск;
  • Поиск в музыкальной библиотеке, прослушивание музыки, а также работа с радиостанциями;
  • Доступ к Интернету и стандартным играм Windows.

Отключаем анимационную заставку при запуске

По умолчанию, при запуске программы пользователю показывается небольшая анимационная заставка с фирменным логотипом Windows Medial Center.

Заставка Windows Media Center

Существует параметр командной строки, позволяющий отключить данную анимацию. Открываем Пуск | Все программы и щелкаем правой кнопкой мыши на программе Windows Media Center. Перед вами откроется окно свойств файла. В разделе Объект нужно дописать к имеющейся строке %windir%\ehome\ehshell.exe параметр /nostartupanimation и щелкнуть кнопку ОК, чтобы изменения вступили в силу (потребуются права администратора).

Окно свойств Windows Media Center

Теперь при следующем запуске программмы вы не увидите заставку, а сразу рабочее окно Windows Media Center.

Существуют еще несколько недокументированных параметров

/mediamode – запуск в режиме “media only mode” без кнопок свернуть/закрыть, очень удобно, если вы используете компьютер в качестве домашнего медиа-центра.
/playfavmusic – воспроизведение избранной музыки при запуске.
/nostartupanimation – отключение анимации при запуске.
/noshutdownui – ключ удаляет опции выключения из меню "Задачи".
/widescreen – принудительно включить широкоэкранный режим.
/nochrome – Media Center будет запущен в оконном режиме.
/playallmusic – начать воспроизведение всей коллекции музыки при запуске.
/playfavslideshow – воспроизвести избранные слайд-шоу при запуске приложения.
/playfavslideshowwithmusic – воспроизвести избранные слайд-шоу с музыкой при запуске приложения.
/playslideshow – воспроизвести все слайд-шоу при запуске.
/playslideshowwithmusic – воспроизвести все слайд-шоу с музыкой при запуске
/screensaver – запустить Media Center в режиме экранной заставки.
/configuress – запустить Media Center в режиме меню настройки экранной заставки.

Дополнительные материалы

Работу программы Windows Media Center можно запретить при помощи групповой политики Не запускать Windows Media Center или при помощи параметра MediaCenter в реестре (более подробную информацию вы найдете в электронном Справочнике по реестру Windows).


eudcedit.exe

Местонахождение

%WINDIR%\System32

Описание

Редактор личных знаков

Редактор личных символов позволяет создавать собственные символы и вставлять их в документы с помощью таблицы символов. Редактор личных символов позволяет:

  • создавать новые символы;
  • редактировать существующие символы;
  • сохранять символы;
  • просматривать библиотеку символов и выполнять в ней поиск


eventvwr.exe (eventvwr.msc)

eventvwr.exe (Просмотр событий)

Местонахождение

Windows\system32

Описание

Модуль запуска оснастки просмотра событий

В окне просмотра событий ведутся журналы программных, системных событий, а также событий безопасности на компьютере. Окно просмотра событий используется для просмотра журналов событий и управления ими, получения сведений о неполадках аппаратного и программного обеспечения, а также для наблюдения за событиями безопасности Windows.

Например, вы можете измерить время загрузки операционной системы. Подсчитывается время, прошедшее с инициализации первого файла bootmgr.exe до полной загрузки всех служб и автоматически запускаемых программ. Для этого в левой части окна выберите Журналы приложений и служб | Microsof | Windows | Diagnostic Perfomance | Operational. Чтобы найти нужное событие, в правой части окна найдите панель Действия и выберите пункт Фильтр текущего журнала.... Во вкладке Фильтр в графе Дата выберите Последние 12 часов и в графе кода события введите 100. Далее нажмите ОК и вы увидите время загрузки в миллисекундах.

Примечание: В Windows XP оснастка запускалась из файла eventvwr.msc, которая осталась в Windowx Vista в целях совместимости.

Дополнительные материалы

Как очистить журнал Планировщика заданий?


expand.exe

Местонахождение

%WINDIR%\System32

Описание

Программа распаковки LZ

Программа expand.exe извлекает один или несколько сжатых файлов обновлений. Программа expand.exe поддерживает открытие обновлений Windows Vista и предыдущих версий Windows. С помощью Expand можно открывать и изучать обновления операционной системы Windows Vista в операционных системах Windows XP или Windows Server 2003.

При просмотре или извлечении содержимого пакета обновления для Windows Vista (например, обновления для системы безопасности, критического обновления или накопительного пакета обновления) показанные или извлеченные файлы могут не содержать всех файлов, которые должны обновляться пакетом.

Windows Vista использует технологию сжатия IPD (Intra-Package Delta), что уменьшает размер пакетов.

Синтаксис

expand [-r] источник [назначение] [-dисточник.cab [-f:файлы]] [источник.cab [-f:файлыназначение]

Параметры

/?
Выводит справочные сведения в командной строке.
[-r]
Переименовывает извлеченные файлы.
[назначение]
Указывает местоположение извлекаемых файлов. Если источником являются несколько файлов и аргумент -r не указан, назначение должно быть папкой. Назначение может состоять из буквы диска, двоеточия, имени папки, имени файла или комбинации этих составляющих.
[-dисточник.cab]
Выводит список файлов в местоположении источника. Не извлекает файлы.
[-f:файлы]
Указывает файлы в CAB-файле, которые необходимо извлечь. Используйте символы шаблона (* и ?).
источник.cab
Указывает извлекаемый файл. Источник может состоять из буквы диска, двоеточия, имени каталога, имени файла или комбинации этих составляющих. Используйте символы шаблона (* и ?).

Дополнительные материалы

Параметры командной строки Expand - описание программы на сайте Microsoft


explorer.exe

Местонахождение

Windows

Описание

Проводник

Одна из основных программ Windows для навигации по папкам и дискам

Ключи командной строки Проводника

  • /e - Вид Проводника по умолчанию (двухпанельное), иначе выводится как однопанельное (как Папка).
  • /e, object - Открывается Проводник с видом по умолчанию и с фокусом на заданной папке (Explorer /e,C:\Windows)
  • /n - Открытие однопанельного нового окна на диске, на котором установлена система (C:\). Иначе информация выводится в существующем окне Проводника, если оно открыто.
  • /root, object - Указывает на то, что корнем будет object - это дисковод (сетевой или локальный) или папка. Иначе корнем считается Рабочий стол. (Explorer /root, C:\Windows\Cursors)
  • /select, object - Указывает на необходимость открытия Родительской папки объекта object и выделит object (Explorer /select, C:\Windows\Cursors\banana.ani).

Советы

Windows.Народные советы - Совет: По умолчанию Проводник открывается на диске C:, но вы можете изменить это поведение...


fc.exe

Местонахождение

Windows\system32

Описание

Утилита сравнения файлов DOS 5

Утилита командной строки для сравнения двух файлов и вывода различий между ними

Синтаксис

fc [/a] [/b] [/c] [/l] [/lbn] [/n] [/t] [/u] [/w] [/nnnn] [диск1:][путь1]имяфайла1 [диск2:][путь2]имяфайла2

Параметры

/a
Задает сокращенный вывод ASCII сравнения. Вместо вывода всех различающихся строк, fc.exe выводит только начальную и конечную строки отличающихся участков.
/b
Сравнивает файлы в двоичном режиме. Команда fc.exe сравнивает два файла байт за байтом и не пытается сопоставить файлы после найденного отличия. Этот режим используется по умолчанию для сравнения файлов с расширениями: .exe, .com, .sys, .obj, .lib или .bin.
/c
Сравнивает без учета заглавных и строчных букв.
/l
Сравнивает файлы в текстовом (ASCII) режиме. Команда fc.exe сравнивает два файла строка за строкой и пытается сопоставить их, после того как найдено отличие. Этот режим используется по умолчанию для сравнения файлов, исключая файлы со следующими расширениями: .exe, .com, .sys, .obj, .lib или .bin.
/lbn
Задает количество строк nfc.exe прекращает сравнение.
/n
Задает вывод номеров строк при сравнении в текстовом режиме.
/t
Предотвращение fc.exe от преобразования меток табуляции в пробелы. По умолчанию табуляторы заменяются пробелами с остановкой в каждой восьмой позиции.
/u
Задает сравнение файлов в текстовом формате Юникод.
/w
Задает сжатие пробелов и табуляций при сравнении. Если в строке содержится несколько пробелов или табуляций подряд, при использовании ключа /w они будут рассматриваться как один. Когда используется ключ /w, программа fc.exe игнорирует (и не сравнивает) пробелы и табуляции в начале и в конце строки.
/nnn
Задает количество совпадающих строк, используемых программой fc.exe при новом сопоставлении файлов. Если количество совпадающих строк в файле меньше nnnn, программа fc.exe будет выводить совпадающие строки как отличающиеся. По умолчанию значение равно 2.
[диск1:][путь1]имяфайла1
Задает местоположение и имя первого файла для сравнения. Параметр имяфайла1 является обязательным.
[диск2:][путь2]имяфайла2
Задает местоположение и имя второго файла для сравнения. Параметр имяфайла2 является обязательным.
/?
Выводит справку о fc.exe в командной строке.

Вывод различий между файлами при текстовом сравнении в формате ASCII

При использовании программы fc для сравнения ASCII, fc отображает различия между двумя файлами в следующем порядке:

  • имя первого файла;
  • строки из параметра имяфайла1, которые отличаются в файлах;
  • первая строка, совпадающая в обоих файлах;
  • имя второго файла;
  • отличающиеся строки из параметра имяфайла2;
  • первая строка совпадения.

Использование /b для двоичного сравнения

/b отображает несоответствия, найденные в течение двоичного сравнения, как показано ниже.

xxxxxxxx: yy zz

Величина xxxxxxxx задает относительный шестнадцатеричный адрес пары различающихся байтов, отсчитываемый от начала файла. Адресация начинается с 00000000. Шестнадцатеричные величины yy и zz представляют различающиеся байты из имяфайла1 и имяфайла2 соответственно.

Использование подстановочных знаков

Можно использовать подстановочные знаки (* and ?) в параметрах имяфайла1 и имяфайла2. Если они использованы при задании первого файла имяфайла1, программа fc будет сравнивать все заданные файлы с файлом, указанным в параметре ИмяФайла. Если подстановочные знаки использованы при задании файла имяфайла2, fc при сравнении будет использовать соответствующие значения параметра имяфайла1.

Работа с памятью

При сравнении в текстовом режиме программа fc использует внутренний буфер (достаточный для размещения 100 строк). Если размер файлов больше размера буфера, программа fc будет сравнивать те части, которые поместились в буфер. Если fc не обнаруживает совпадения в загруженных частях файлов, программа остановится и будет выведено следующее сообщение:

Не удается выполнить синхронизацию строк. Слишком много различий между файлами.

Если же выполняется двоичное сравнение и размер файлов превосходит размер доступной памяти, fc выполняет сравнение полностью. При необходимости, файлы будут считываться с диска по частям. Вывод команды при этом не будет отличаться от вывода в случае полного размещения файлов в памяти.

Примеры

Создадим два текстовых файла test1.txt и test2.txt следующего содержания:

раз два
три четыре
пять
вышел зайчик
погулять
и
раз два
три четыре
шесть
вышел зайчик
погулять в лес

В результате выполнения команды

fc E:\test1.txt E:\TEST2.TXT
На экран будет выведено следующее:
Сравнение файлов E:\test1.txt и E:\TEST2.TXT
***** E:\test1.txt
три четыре
пять
вышел зайчик
погулять
***** E:\TEST2.TXT
три четыре
шесть
вышел зайчик
погулять в лес
*****

Чтобы сравнить два текстовых файла с именами monday.txt и sunday.txt и вывести результат в сокращенном формате, введите:

fc /a mondya.txt sunday.txt

Для сравнения каждого файла .bat в текущем каталоге с файлом test.bat введите:

fc *.bat test.bat

Для сравнения файла test.bat на диске C с файлом test.bat на диске D введите:

fc c:test.bat d:*.bat

Для сравнения каждого пакетного файла в корневом каталоге диска C с файлом с таким же именем в корневом каталоге на диске введите:

fc c:*.bat d:*.bat

Советы

Windows.Народные советы - статья Есть простой способ отследить изменения, которые происходят в реестре Windows


find.exe

Местонахождение

Windows\system32

Описание

Утилита поиска строк (GREP)

Поиск заданной строки текста в файле или нескольких файлах. После поиска в заданных файлах команда find выведет на экран все строки из этих файлов, содержащие заданный образец.

Синтаксис

find [/v] [/c] [/n] [/i] "строка" [[диск:][путь]ИмяФайла[...]]

Описание параметров есть в справке Windows


format.com

Местонахождение

%systemroot%\system32

Описание

Disk Format Utility

Утилита командной строки format.com позволяет форматировать диск для работы с Windows.

Синтаксис

FORMAT том [/FS:файловая_система] [/V:метка] [/Q] [/A:размер] [/C] [/X]
       [/P:проходы] [/S:состояние]
FORMAT том [/V:метка] [/Q] [/F:размер] [/P:проходы]
FORMAT том [/V:метка] [/Q] [/T:дорожки /N:секторы] [/P:проходы]
FORMAT том [/V:метка] [/Q] [/P:проходы]
FORMAT том [/Q]

Параметры

том
Определяет букву диска (с последующим двоеточием), точку подключения или имя тома.
/FS:файловая_система
Указывает тип файловой системы (FAT, FAT32, NTFS или UDF).
/V:метка
Метка тома
/Q
Быстрое форматирование. Перекрывает параметр /P.
/C
Только для NTFS: Установка режима сжатия по умолчанию для всех файлов, создаваемых на новом томе.
/X
Инициирует отключение тома, в качестве первого действия, если это необходимо. Все открытые дескрипторы тома будут неверны.
/R:редакция
только для UDF: Форматирование в указанной версии UDF (1.00, 1.02, 1.50, 2.00, 2.01, 2.50). По умолчанию используется редакция 2.01.
/D
Только UDF 2.50: Метаданные будут продублированы.
/A:размер
Заменяет размер кластера по умолчанию. В общих случаях рекомендуется использовать размеры кластера по умолчанию. NTFS поддерживает размеры 512, 1024, 2048, 4096, 8192, 16 КБ, 32 КБ, 64K.
FAT поддерживает размеры 512, 1024, 2048, 4096, 8192, 16 КБ, 32 КБ, 64 КБ, (128 КБ, 256 КБ для размера сектора > 512 байт).<br> FAT32 поддерживает размеры 512, 1024, 2048, 4096, 8192, 16 КБ, 32 КБ, 64 КБ, (128 КБ, 256 КБ для размера сектора > 512 байт).
exFAT поддерживает размеры 512, 1024, 2048, 4096, 8192, 16 КБ, 32 КБ, 64 КБ, 128 КБ, 256 КБ, 512 КБ, 1 МБ, 2 МБ, 4 МБ, 8 МБ, 16 МБ, 32 МБ.
Файловые системы FAT и FAT32 налагают следующие ограничения на число кластеров тома:
FAT: число кластеров <= 65 526<br> FAT32: 65 526 < число кластеров < 4 177 918
Выполнение команды FORMAT будет немедленно прервано, если будет обнаружено нарушение указанных выше ограничений, используя указанный размер кластеров.
Сжатие NTFS не поддерживается для кластеров размером более 4096.
/F:размер
Указывает размер форматируемых гибких дисков (1,44)
/T:дорожки
Число дорожек на каждой стороне диска.
/N:секторы
Число секторов на каждой дорожке.
/P:раз
Обнуляет каждый сектор тома указанное число раз. Этот параметр не действует с параметром /Q
/S:состояние
Где "состояние" может принимать значения "enable" или "disable". Короткие имена по умолчанию включены


fsutil.exe

Местонахождение

%systemroot%\system32

Описание

fsutil.exe

Fsutil является служебной программой командной строки, которая используется для выполнения связанных задач файловых систем FAT и NTFS, таких как управление точками повторной обработки, управление разреженными файлами, отключение тома или расширение тома. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с Microsoft Windows XP. Для использования программы fsutil необходимо войти в систему с помощью учетной записи администратор или члена группы администраторов.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду

fsutil подкоманда help

Применение

С помощью утилиты командной строки fsutil можно создать файл с заданным размером. Например, вам надо создать файл sample.txt размером 1 кб, не заботясь о его содержании. Делаем так:

fsutil file createnew FileName Size
где FileName - имя файла (sample.txt, или c:\folder\sample.txt), а Size - размер файла в байтах.

Чтобы задать короткое имя longfile.txt для файла longfilename.txt на диске C, введите:

fsutil file setshortname C:\longfilename.txt longfile.txt


ftp.exe

Местонахождение

Windows\system32

Описание

Программа передачи файлов (FTP)

Позволяет передавать файлы с компьютера и на компьютер с помощью программ, поддерживающих протокол FTP (File Transfer Protocol)

Синтаксис

ftp [-v] [-d] [-i] [-n] [-g] [-s:имя_файла] [-a] [-w:размер] [-A] [Ведомый компьютер]

Описание параметров есть в справке Windows.


FXSCOVER.exe

Местонахождение

%WINDIR%\System32

Описание

Microsoft Fax Cover Page Editor

Компонент «Факсы и сканирование Windows» содержит четыре готовые титульные страницы. При помощи программы FXSCOVER можно также создавать собственные титульные страницы.


getmac.exe

Местонахождение

Windows\system32

Описание файла

Отображение информации NIC MAC

Возвращает аппаратный MAC-адрес и список сетевых протоколов, связанных с каждым адресом для всех сетевых плат в любом компьютере - как локальном, так и доступном по сети. Команду getmac полезно использовать, если требуется ввести MAC-адрес в сетевой анализатор либо требуется определить, какие протоколы используются каждой сетевой платой компьютера.

Синтаксис

getmac[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u
/fo {TABLE|LIST|CSV}
Формат выходных данных запроса. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
/nh
Запрет на вывод заголовка столбца. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV
/v
Вывод подробных сведений
/?
Отображение справки в командной строке

Примеры

getmac /fo table /nh /v
getmac /s srvmain
getmac /s srvmain /u maindom\hiropln
getmac /s srvmain /u maindom\hiropln /p p@ssW23
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo list /v
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo table /nh


GettingStarted.exe

GettingStarted.exe (Приступая к работе)

Местонахождение

%WINDIR%\System32

Описание

Getting Started

Запускает компонент Панели управления Приступая к работе (Панель управления\Все элементы панели управления\Приступая к работе)


hdwwiz.exe

Местонахождение

WINDOWS\system32

Описание

Мастер установки оборудования

Данная программа вызывает окно Мастера установки оборудования.


hostname.exe

Местонахождение

Windows\system32

Описание

Программа Hostname

Утилита командной строки hostname выводит имя системы, на котором была запущена эта команда.

Синтаксис

hostname

Параметры

/?
Выводит справку в командной строке.

Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).


icacls.exe

icacls.exe (Windows Vista)

Местонахождение

Windows\system32

Описание

icacls.exe

Утилита командной строки icacls.exe показывает или изменяет явные и унаследованные разрешения на файл или папку.

Синтаксис

icacls  [/grant[:r] :[...]] [/deny :[...]] [/remove[:g|:d]] [...]] [/t] [/c] [/l] [/q] [/setintegritylevel :[...]]
icacls  [/substitute   [...]] [/restore  [/c] [/l] [/q]]

Параметры

<FileName>
Задает имя файла, для которого нужно показать DACLs
<Directory>
Задает папку, для которого нужно показать DACLs
/t
Performs the operation on all specified files in the current directory and its subdirectories.
/c
Continues the operation despite any file errors. Error messages will still be displayed.
/l
Performs the operation on a symbolic link versus its destination
/q
Suppresses success messages
[/save [/t] [/c] [/l] [/q]]
Stores DACLs for all matching files into ACLfile for later use with /restore
[/setowner [/t] [/c] [/l] [/q]]
Changes the owner of all matching files to the specified use
[/findSID [/t] [/c] [/l] [/q]]
Finds all matching files that contain a DACL explicitly mentioning the specified security identifier (SID)
[/verify [/t] [/c] [/l] [/q]]
Finds all files with ACLs that are not canonical or have lengths inconsistent with ACE (access control entry) counts
[/reset [/t] [/c] [/l] [/q]]
Replaces ACLs with default inherited ACLs for all matching files
[/grant[:r] <Sid>:<Perm>[...]]
Grants specified user access rights. Permissions replace previously granted explicit permissions. Without :r, permissions are added to any previously granted explicit permissions
[/deny <Sid>:<Perm>[...]]
Explicitly denies specified user access rights. An explicit deny ACE is added for the stated permissions and the same permissions in any explicit grant are removed.
[/remove[:g|:d]] <Sid>[...]] [/t] [/c] [/l] [/q]
Removes all occurrences of the specified SID from the DACL
:g removes all occurrences of granted rights to the specified SID.
:d removes all occurrences of denied rights to the specified SID
[/setintegritylevel [(CI)(OI)]<Level>:<Policy>[...]]
Explicitly adds an integrity ACE to all matching files. Level is specified as:
L[ow]
M[edium]
H[igh]
Inheritance options for the integrity ACE may precede the level and are applied only to directories
[/substitute <SidOld> <SidNew> [...]]
Replaces an existing SID (SidOld) with a new SID (SidNew). Requires the Directory parameter
/restore <ACLfile> [/c] [/l] [/q]
Applies stored DACLs from ACLfile to files in the specified directory. Requires the Directory parameter
/?
Отображение справки в командной строке.


iexplore.exe

Местонахождение

Program Files\Internet Explorer

Описание

Internet Explorer

Браузер от Microsoft

Параметры командной строки

Для Internet Explorer существуют несколько ключей. Для их использования необходимо запустить файл iexplore.exe из командной строки с указанием нужного параметра, либо прописать требуемый параметр в свойствах специально созданного ярлыка к браузеру (получится примерно следующее:
"C:\ Program Files\ Internet Explorer\iexplore.exe" -nohome).

Список ключей

  • iexplore.exe http://www.alexanderklimov.ru - запускает Internet Explorer и открывает заданный в качестве параметра сайт
  • -channelband - Internet Explorer будет запущен в качестве специальной панели каналов на Рабочем столе текущего пользователя. Данная опция работает только при выключенном активном Рабочем столе (Active Desktop)
  • -e - Internet Explorer будет запущен в двухпанельном режиме Проводника (дерево папок слева, содержание справа)
  • -extoff - Запускает IE8 без надстроек
  • -new - новое окно программы Internet Explorer будет запущено как отдельный процесс
  • -nohome - при запуске Internet Explorer не будет открывать никаких веб-страниц. При этом скорость загрузки программы гораздо быстрее, чем если даже стоит в стартовой странице about: blank
  • -nomerge - запуск новой сессии
  • -k - запуск браузера в полноэкранном режиме (Kiosk mode)
  • -slf - при запуске открывается домашняя страница пользователя
  • -embedding - Запускает Web browser control без показа странички
  • -private - запуск браузера в приватном режиме

Можно в командной строке указать и URL-адрес страницы, которую требуется открыть:
iexplore -k user.alexanderklimov.ru


iexpress.exe

Местонахождение

Windows\system32

Описание

Wizzard

В Windows есть простейший инсталлятор файлов IExpress. Удобный диалог, упаковывает файлы в exe-файлы, один минус: не руссифицирован. Причем, например, 2 десятка картинок сжимаются даже лучше чем в WinRAR 3.0


ipconfig.exe

Местонахождение

Windows\system32

Описание

Программа настройки IP

Утилита командной строки ipconfig служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера.

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Параметры

/all
Вывод полной конфигурации TCP/IP для всех адаптеров. Без этого параметра команда ipconfig выводит только IP-адреса, маску подсети и основной шлюз для каждого адаптера. Адаптеры могут представлять собой физические интерфейсы, такие как установленные сетевые адаптеры, или логические интерфейсы, такие как подключения удаленного доступа.
/renew [адаптер]
Обновление конфигурации DHCP для всех адаптеров (если адаптер не задан) или для заданного адаптера. Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/release [адаптер]
Отправка сообщения DHCPRELEASE серверу DHCP для освобождения текущей конфигурации DHCP и удаление конфигурации IP-адресов для всех адаптеров (если адаптер не задан) или для заданного адаптера. Этот адаптер отключает протокол TCP/IP для адаптеров, настроенных для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/flushdns
Сброс и очистка содержимого кэша сопоставления имен DNS клиента. Во время устранения неполадок DNS эту процедуру используют для удаления из кэша записей отрицательных попыток сопоставления и других динамически добавляемых записей.
/displaydns
Отображение содержимого кэша сопоставления имен DNS клиента, включающего записи, предварительно загруженные из локального файла Hosts, а также последние полученные записи ресурсов для запросов на сопоставление имен. Эта информация используется службой DNS клиента для быстрого сопоставления часто встречаемых имен без обращения к указанным в конфигурации DNS-серверам.
/registerdns
Динамическая регистрация вручную имен DNS и IP-адресов, настроенных на компьютере. Этот параметр полезен при устранении неполадок в случае отказа в регистрации имени DNS или при выяснении причин неполадок динамического обновления между клиентом и DNS-сервером без перезагрузки клиента. Имена, зарегистрированные в DNS, определяются параметрами DNS в дополнительных свойствах протокола TCP/IP.
/showclassid адаптер
Отображение кода класса DHCP для указанного адаптера. Чтобы просмотреть код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов.
/setclassid адаптер [код_класса]
Задание кода класса DHCP для указанного адаптера. Чтобы задать код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Если код класса DHCP не задан, текущий код класса удаляется.
/?
Отображение справки в командной строке.

Например, для очистки кэша разрешений DNS используется команда

ipconfig /flushdns

Чтобы обновить конфигурацию IP-адреса, назначенного DHCP-сервером, только для адаптера Подключение по локальной сети, введите:

ipconfig /renew "Подключение по локальной сети"

Чтобы вывести код класса DHCP для всех адаптеров с именами, начинающимися со слова Подключение, введите:

ipconfig /showclassid Подключение*

Чтобы задать код класса DHCP TEST для адаптера Подключение по локальной сети, введите:

ipconfig /setclassid "Подключение по локальной сети" TEST

Для постепенного вывода информации наберите ipconfig /all | more. Чтобы перейти к следующему фрагменту нажмите на пробел. Для вывода информации в текстовый файл ipconfi.txt наберите

ipconfig /all >> ipconfig.txt


iscsicli.exe

Местонахождение

%systemroot%\system32

Описание

Средство обнаружения iSCSI


iscsicpl.exe

Местонахождение

%systemroot%\system32

Описание

Microsoft iSCSI инициатор - средство настройки

iSCSI — это протокол для доступа и взаимодействия с системами хранения данных, серверами и клиентами, основанный на стеке TCP/IP. Работа протокола iSCSI построена на основе модели клиент/сервер. Клиент инициирует запросы на считывание данных с сервера, который представляет собой систему хранения данных. В рамках данной модели клиента iSCSI также называют инициатором.

Данный компонент отображает диалог Свойства: Инициатор iSCSI, с помощью которого можно более тонко настроить параметры работы клиента сетевых устройств, подключенного к серверу SCSI.


isoburn.exe

isoburn.exe (Windows 7)

Местонахождение

WINDOWS\System32

Описание

Средство записи образов дисков Windows

С помощью данной утилиты теперь можно записывать ISO-образы. Теперь нет необходимости устанавливать другие программы для прожига дисков.

Если вы попытаетесь запустить программу напрямую через поисковую строку кнопки Пуск, то получите диалоговое окно с сообщением, какие параметры нужно использовать для выполнения этой программы (нужно указать букву дисковода и имя файла образа диска). Но гораздо легче выполнить эту задачу обходным путем. Просто выберите в Проводнике файл образа диска с расширением ISO и в его контекстном меню выберите команду Записать образ диска. Теперь осталось только нажать на кнопку Записать - все остальное сделает Windows. В случае необходимости можете установить флажок Проверить диск после записи.


journal.exe

Местонахождение

%programfiles%\Windows Journal

Описание

Журнал Windows

Это программа представляет собой своеобразный Блокнот, в котором записи делаются при помощи мыши или пера.

Смотри также

Справочник по реестру Windows: Запрет на запуск программу Журнал Windows


klist.exe

isoburn.exe

Местонахождение

WINDOWS\System32

Описание

Средство управления кэшем билета Kerberos

Синтаксис

Klist.exe [-lh <LogonId.HighPart>] [-li <LogonId.LowPart>] tickets | tgt | purge


ksetup.exe

Местонахождение

WINDOWS\System32

Описание

Средство установки Kerberos

Дополнительные сведения

Ksetup Overview: Logon and Authentication


LocationNotifications.exe

Местонахождение

%WINDIR%\System32

Описание

Действия расположения

Информации о программе нет.


logoff.exe

Местонахождение

Windows\system32

Описание

Программа выхода из сеанса

Синтаксис

LOGOFF [<имя сеанса> | <ИД сеанса>] [/SERVER:<сервер>] [/V] [/VM]

Параметры

<имя сеанса>
Имя сеанса
<ID сеанса>
Идентификатор сеанса
/SERVER:<сервер>
Сервер удаленных рабочих столов, содержащий пользователя (по умолчанию - текущий)
/V
Отображение информации о выполненных действиях
/VM
Завершение сеанса на сервере или в виртуальной машине. Необходимо указать уникальный идентификатор сеанса


logonui.exe

Местонахождение

Windows\system32

Описание

Интерфейс входа в Windows

Программа, запускающая при входе в Windows. Именно в этом файле содержится внешний вид экрана приветствия. Существует ряд программ, позволяющих модифицировать внешний вид экрана приветствия путем изменения данного файла. Если вам хочется просто изменить внешний вид экрана приветствия без модификации файла, то можете воспользоваться более безопасным способом настройки экрана через реестр. (Смотри параметр UIHost в Справочнике по реестру).


lpksetup.exe

Местонахождение

Windows\System32

Описание

Установка пакета языковой поддержки

Программа Lpksetup используется для выполнения автоматических операций с языковым пакетом или операций в тихом режиме.

Синтаксис

lpksetup.exe {/i [{* | язык}] | /uязык} [/r] [/pпуть_к_языковому_пакету] [/s] [/f]

Параметры

/i
Устанавливает указанные языковые пакеты. Нельзя использовать с параметром /u. Если после параметра /i не указан подстановочный знак * или язык, программа будет запущена и установка будет осуществляться с помощью пользовательского интерфейса.
*
Указывает подстановочный знак, представляющий все языковые пакеты, находящиеся в путь_к_языковому_пакету или к каталогу, где расположен Lpksetup.exe.
язык-РЕГИОН
Указывает языковой пакет или несколько пакетов, которые следует установить или удалить. Используйте формат язык-РЕГИОН для каждого указанного языка, где язык - это код языка, написанный строчными буквами в формате ISO 639, а РЕГИОН - идентификатор страны или региона, написанный прописными буквами в формате ISO 3166-1.
/u
Удаляет указанные языковые пакеты. Нельзя использовать с параметром /i. Если после параметра /u не указан язык, программа будет запущена и удаление будет осуществляться с помощью пользовательского интерфейса.
/r
Устраняет необходимость перезагрузки компьютера после выполнения операции. Сообщение о необходимости перезагрузки будет зарегистрировано в журнале событий.
/pпуть_к_языковому_пакету
Указывает путь к языковым пакетам, которые следует установить.
путь
Может быть как путем к каталогу, так и путем к папке.
/s
Выполняет операцию в тихом режиме или автоматическую операцию, для которых не требуется участие пользователя. Пользовательский интерфейс недоступен.
/f
Если компьютер необходимо перезагрузить, принудительно выполняет перезагрузку, даже при наличии пользовательских подключений к компьютеру.

Смотри также документацию на Technet


Magnify.exe

Местонахождение

%windir%\System32

Описание

Экранная лупа Майкрософт

Экранная лупа увеличивает различные части экрана. Это особенно важно при просмотре объектов, которые плохо различимы, а также для облегчения просмотра всего экрана целиком.

Сочетания клавиш для работы с экранной лупой

Нажмите | Чтобы выполнить ...
Win+ знак плюса или знак минуса | Увеличение или уменьшение масштаба
CTRL+ALT+ПРОБЕЛ | Отображение указателя мыши
CTRL+ALT+F | Переключение в режим «Во весь экран»
CTRL+ALT+L | Переключение в режим «Увеличение»
CTRL+ALT+D | Переключение в режим «Закреплено»
CTRL+ALT+I | Инверсию цветов
CTRL + ALT + клавиши со стрелками | Панораму в направлении клавиш со стрелками
CTRL+ALT+R | Изменение размера увеличения
Win+ ESC | Отключение экранной лупы


makecab.exe

Местонахождение

WINDOWS\system32

Описание

Microsoft® Cabinet Maker

Утилита командной строки makecab.exe служит для создания cab-файлов

Для получения списка параметров используйте ключ makecab /?


mblctr.exe

Местонахождение

%windir%\System32

Описание

Центр мобильности Windows

Если вы установили операционную систему Windows 7 на ноутбук, тогда в Панели управления появится дополнительный значок, предназначенный для открытия диалога Центр мобильности Windows. Данный диалог является своеобразной оболочкой для объединения возможностей операционной системы, применяемых при работе с ноутбуком. Например, по умолчанию в данном диалоге объединены следующие возможности: изменение уровня громкости динамиков, изменение яркости экрана, кнопка подключения сетевого проектора и т.д.

Программа запускается только на мобильных компьютерах - лэптопах, ноутбуках, планшетных компьютерах и т.п. При попытке запустить на обычном компьютере выводится соответствующее сообщение.

Запуск программы на настольных компьютерах

Хотя по умолчанию, Центр мобильности Windows нельзя запустить на настольном компьютере, с помощью реестра можно исправить данное положение вещей. Для этого нужно воспользоваться ключом RunOnDesktop. Подробнее об этом можно узнать из Справочника по реестру Windows, доступного по адресу user.alexanderklimov.ru

mblctr.exe на настольном компьютере

Смотри также

Справочник по реестру Windows (Запрет на запуск Центра мобильности Windows)


MdSched.exe

Местонахождение

%windir%\system32\

Описание

Средство проверки памяти Windows

Причиной возникновения многих критических ошибок, зависаний, сбоев в работе является неисправная оперативная память. Самым простым способом для выявления неисправного модуля является использование стандартной утилиты Средство проверки памяти Windows (Windows Memory Diagnostic Tool), которая появилась в Windows Vista. При использовании "средства проверки памяти Windows" Вам не придётся создавать дополнительные загрузочные диски для записи утилиты, а потребуется лишь перезагрузить компьютер или загрузиться с уже существующего установочного диска Windows 7.

Дополнительную информацию о данной программе можно найте на сайте OSZONE


mem.exe

Местонахождение

WINDOWS\system32

Описание

mem.exe

Выводит информацию о распределении используемой и свободной памяти в системе.

Синтаксис

MEM [/PROGRAM | /DEBUG | /CLASSIFY]

Параметры

/PROGRAM или /P
Показывает статус программ, загруженных в память
/DEBUG или /D
Показывает статус программ, драйверов и другую информацию
/CLASSIFY или /C
Классифицирует программы по использованию памяти. Выводит список размеров программ, общий размер используемой памяти и список доступной памяти.
/?
Выводит справку


migwiz.exe

Местонахождение

%windir%\system32\migwiz\

Описание

Приложение переноса данных Windows

Очень удобная утилита для переноса файлов и параметров различных программ с одного компьютера на другой: файлы, фотографии, музыку, почтовые настройки. Поддерживается перенос по локальной сети, внешний диск, CD/DVD. Программу можно запустить через Пуск | Все программы | Стандартные | Служебные | Средство переноса файлов Windows.

Одна из самых больших проблем, возникающих при подготовке миграции с Windows XP в Windows 7, — перенос приложений, файлов и параметров настройки. Microsoft не предлагает способов автоматического обновления при таком переходе, как это было при миграции с Windows Vista в Windows 7.

Поэтому при переходе с Windows XP обычно приходится устанавливать Windows 7 с нуля, после чего переустанавливать все приложения, а затем копировать пользовательские документы, параметры настройки и другие нестандартные параметры. Microsoft предлагает инструмент, помогающий при выполнении последней операции.

Средство переноса данных для Windows 7 (Windows Easy Transfer for Windows 7) позволяет переносить файлы и параметры со старого компьютера пользователя под управлением Windows XP на новую машину с Windows 7. Помимо других типов файлов оно копирует учетные записи пользователей, документы, избранное браузера, электронную почту и параметры приложений.

Средство переноса данных Windows предлагается для 32- и 64-разрядных версий Windows XP (а также для 32- и 64-разрядных версий Windows Vista). Оно включено в состав Windows 7, поэтому нет необходимость устанавливать его на новой машине. Средство переноса данных Windows — не новый инструмент, но в последней версии появились несколько новых возможностей, существенно облегчающих миграцию.

На первой странице объясняется, какую информацию можно перенести. Далее надо решить, какие файлы и параметры нужно мигрировать, и выбрать один из трех вариантов.

Вы можете использовать для переноса данных кабель, непосредственно связывающий два компьютера, сеть, но при этом нужно, чтобы оба компьютера были доступны из этой сети (по обычному или беспроводному соединению), или внешний диск или USB-накопитель.Средство переноса данных Windows создает файл, который можно перенести на новый компьютер. После выбора одного из вариантов подтвердите, что файлы и параметры, которые нужно перенести, находятся на текущем компьютере.

Следующие шаги зависят выбранного варианта миграции. Если вы решили создать файл на внешнем диске, средство немедленно начинает поиск на компьютере файлов для копирования.

В случае переноса по кабелю нужно соединить компьютеры кабелем, открыть Средство переноса данных Windows на новом компьютере с Windows 7, после чего выбрать в средстве переноса вариант миграции по кабелю. Если Средство переноса данных Windows еще не открыто, при подключении кабеля оно откроется или появится окно с предложением отрыть его. Должна быстро установиться связь и начаться поиск файлов для копирования.

Если вы выбрали перенос по сети, при выполнении на компьютере с Windows XP средство переноса предоставит ключ. После этого надо запустить Средство переноса данных Windows на новой машине с Windows 7 и выбрать вариант миграции по сети. После ввода ключа переноса, средство найдет старый компьютер и сообщит, что два компьютера найдены и начнет сканирование.

При выполнении любого из трех вариантов миграции по завершении просмотра старого компьютера с Windows XP средство переноса покажет учетные записи пользователей, которые содержат файлы и параметры, включенные в процесс переноса. При переносе с применением внешнего диска нужно продолжить работу со средством на старом компьютере; если вы используете кабель или сеть, Средство переноса данных Windows надо запустить на новом компьютере.

Можно просмотреть и даже изменить перечень файлов, щелкнув ссылку «Настройка». Средство переноса данных Windows отобразит окно диспетчера файлов, где можно увидеть все папки и файлы, отобранные для переноса. Вы вправе выбрать или отменить выбор любых файлов и папок. Программа максимально тщательно отбирает материал для переноса, но вам все равно надо просмотреть выбранное в диспетчере файлов, чтобы четко проконтролировать, что будет перенесено.

Здесь процесс переноса снова меняется в зависимости от способа переноса. При использовании внешнего накопителя после выбора и проверки всех переносимых файлов, щелкните кнопку Далее, а затем задайте пароль для защиты файла с переносимыми данными. Средство переноса предложит задать имя и местоположение файла переноса. Хотя этот вариант применяется при использовании внешних накопителей, если вы не хотите подключать внешний диск с компьютеру, файл переноса можно сохранить в сети.

Далее примените файл Средства переноса данных Windows на новом компьютере с Windows 7. Для этого на новом компьютере откройте Средство переноса данных Windows и выберите вариант переноса с внешнего накопителя, затем задайте перенос на локальный компьютер. Ответьте утвердительно на вопрос, имеются ли уже сохраненные файлы, после чего укажите файл переноса на внешнем накопителе и в общей сетевой папке.

В вариантах переноса по кабелю и по сети после выбора файлов и параметров надо щелкнуть кнопку «Перенести», чтобы начать процесс переноса. По завершении процесса средство переноса предоставит сводку перенесенного на новый компьютер:перечень перенесенных файлов и приложений, приложений только для Windows XP, не перенесенных в Windows 7, а также список программ сторонних производителей, установленных на старом компьютере, но пока отсутствующих на новом. Эти отчеты средства переноса данных Windows можно просмотреть, щелкнув ссылку «Отчеты средства переноса данных Windows» (Windows Easy Transfer Reports) в папке Все программы/Стандартные/Служебные.

Средство переноса данных Windows должно выполняться как последняя операция в процессе миграции компьютера с Windows XP на Windows 7. Максимальная эффективность средства достигается, когда приложения на компьютере с Windows 7 дублируют такие же приложения на компьютере под управлением Windows XP. Средство переноса данных Windows позволит вам сэкономит массу времени и усилий, когда вы будете мигрировать своих пользователей в новый мир Windows 7.


mip.exe

mip.exe (Windows 7)

Местонахождение

%systemroot%\system32

Описание

Панель математического ввода

В Windows 7 появилась возможность рукописного ввода формул при помощи приложения «Панель математического ввода» (Math Input Panel).

Панель ввода математических выражений (MIP) создана для использования с электронным пером и планшетным ПК, но ею можно пользоваться на любом устройстве с сенсорным экраном, посредством планшета-дигитайзера и даже мыши. MIP выводит результаты распознавания через буфер обмена в формате MathML (стандартный язык математической разметки). Любое уравнение, введённое и распознанное с помощью MIP, попадает в соответствующее приложение в полностью редактируемом виде – его можно изменять, как любой другой текст, вставлять символы и т.д.

Использовать MIP несложно. Вы просто записываете правильно сформулированное математическое выражение (это значит, что 2+2= не будет распознано, в то время как 2+2=5 будет), как вы обычно это делаете на бумаге, и механизм распознавания сделает остальную работу. Распознанное выражение появляется в области предпросмотра. Поскольку механизм не идеален, великая мощь MIP заключается в том, что вам предоставляется возможность свободно редактировать результаты распознавания. (Будем честными, иногда мы сами не до конца уверены в том, что именно мы написали – достаточно посмотреть на мой почерк!).

Если записанное вами выражение распознано с ошибками, вы можете выбрать любую его часть (отдельные символы или целое подвыражение) и исправить его, выбрав альтернативу из выпадающего списка или полностью переписав часть уравнения. Обычно исправление одной части уравнения автоматически исправляет и другую, так что обычно достаточно одного шага.

Коррекция в MIP: Всё, что нужно сделать – щелкнуть по кнопке "Вставить" и всё – вы без всяких проблем создали уравнение в вашем текстовом редакторе или вычислительной программе.

У MIP есть множество других возможностей: история распознаваний, возможность перемещать написанное от руки, вставлять написанное от руки в MIP из других приложений рукописного ввода, таких, как OneNote, или тех, что у вас установлены.

Информация для разработчиков: MIP можно интегрировать в ваши программы. Пожалуйста, ознакомьтесь с соответствующей документацией на MSDN.


mmc.exe

Местонахождение

%windir%\system32

Описание

Консоль управления (MMC)

Синтаксис

mmc путь\имя_файла.msc [/a]  [/64] [/32]

Параметры

путь\имя_файла.msc
Запуск консоли MMC с открытием сохраненной консоли. Необходимо указать полный путь и имя файла сохраненной консоли. Если файл консоли не указан, будет открыта новая консоль MMC.
/a
Открытие сохраненной консоли в авторском режиме. Используется для внесения изменений в сохраненные консоли.
/64
Открытие 64-разрядной версии консоли MMC (MMC64). Этот параметр следует использовать только при работе в Windows XP 64-Bit Edition.
/32
Открытие 32-разрядной версии консоли MMC (MMC32). При работе в Windows XP 64-Bit Edition в окне консоли MMC, запущенной с этим параметром, можно открывать 32-разрядные оснастки.
/?
Отображение справки в командной строке.

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей. Впервые она появилась в Windows 2000. Чтобы запустить ее, проделайте следующее:

Пуск|Выполнить|mmc

Перед вами откроется окно программы. Дальше необходимо добавить групповую политику "Локальный компьютер", где и будут проводиться все настройки. Для этого выберите пункт меню Консоль | Добавить или удалить оснастку..., в появившемся окне нажмите кнопку "Добавить", и из появившегося диалога "Добавить изолированную оснастку" выберите "Групповая политика". Нажмите последовательно кнопки "Готово", "Закрыть", "ОК".

Давайте попробуем убрать пункт "Выполнить" из меню "Пуск" с помощью этого инструмента. В левой части окна консоли перед вами древовидная структура настраиваемых параметров операционной системы. Откройте пункт меню Конфигурация пользователя | Административные шаблоны | Панель задач и меню "Пуск". В расширенном варианте отображения данных вы сможете почитать описание настраиваемого пункта. Если вы знаете что именно вам надо настроить, то лучше переключиться в стандартный режим, чтобы не занимать лишнее место на экране монитора ненужной вам информацией. Итак, найдите строку Удалить команду "Выполнить" из меню "Пуск".

Дважды кликните по ней левой кнопкой мыши, отметьте пункт "Включен" и нажмите "ОК". Теперь если вы выберите Пуск|Выполнить, то увидите сообщение, что операция отменена вследствие действующих для компьютера ограничений. После перезагрузки этот пункт вообще пропадет из меню "Пуск". Аналогичным образом можно настроить и другие параметры меню "Пуск" и не только.

Значения "Включен" и "Отключен" показывают действует или нет данная политика, а значение "Не задан" возвращает настройку политики в значение по умолчанию, заложенное в операционной системе.

Вы наверняка уже обратили внимание на большое количество параметров, которые можно настроить с помощью оснастки MMC. Действительно, здесь можно настроить очень многие параметры операционной системы без использования дополнительных инструментальных средств. Описывать их все нет смысла, так что если вас заинтересовал этот способ твикинга, ознакомьтесь с ними самостоятельно, тем более описание настраиваемых параметров дает более чем исчерпывающую информацию. Ну, а для начального знакомства с оснасткой MMC приведенных сведений должно хватить.

Заметки

  • Использование параметра командной строки путь\имя_файла.msc

    Для создания командных строк и ярлыков, которые не зависят от явного расположения файлов консоли, можно использовать переменные среды. Например, если путь к файлу консоли включает системную папку (например, mmc c:\winnt\system32\console_name.msc), то для указания пути можно использовать переменную %systemroot%:

    mmc %systemroot%\system32\console_name.msc

    Это полезно при делегировании заданий пользователям, работающим на разных компьютерах.

  • Использование параметра командной строки /a

    Когда консоли открываются с этим параметром, они открываются в авторском режиме, независимо от режима, используемого по умолчанию. Используемый по умолчанию режим файла при этом не меняется. Без этого параметра файлы будут открываться в соответствии со своими параметрами.

  • После открытия консоли MMC или файла консоли любая существующая консоль открывается с помощью команды Открыть из меню Консоль.
  • С помощью командной строки можно создавать ярлыки для запуска консоли MMC и работы с сохраненными консолями. Команда для командной строки работает в окне команды Выполнить из меню , в любом окне командной строки, в ярлыках, в пакетных файлах и программах, вызывающих такие команды.

Оснастки

  • Диспетчер устройств
  • Локальные пользователи и группы - Local Users and Groups
  • Общие папки
  • Производительность
  • Просмотр событий
  • Служба индексирования
  • Службы
  • Съемные ЗУ
  • Управление дисками - Disk Management
  • Управление компьютером

Реестр

Справочник по реестру Windows: статья Запрет на запуск консоли управления в авторском режиме


mobsync.exe

mobsync.exe (Центр синхронизации)

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Центр синхронизации

Описание

Microsoft Sync Center

С помощью мастера, вызываемого при помощи данного значка, можно настроить параметры синхронизации компьютера с любым устройством, которое поддерживает синхронизацию, а также синхронизировать устройство с компьютером, просмотреть список синхронизированных в данный момент устройств или список конфликтов, из-за которых синхронизация устройства невозможна.

Способы запуска

Если используется вид По категориям, доступ к данному апплету можно получить при помощи одноименного элемента категории Сеть и Интернет.

Данный мастер используется при синхронизации компьютера с КПК или коммуникатором; синхронизации мультимедиа-содержимого компьютера и переносного устройства; синхронизации записей баз данных сервера SQL; синхронизации папок, доступных в автономном режиме.

Следует иметь в виду, что синхронизация компьютера и КПК/коммуникатора может выполняться только после установки отдельной программы, называемой Центр устройств Windows Mobile (Windows Modile Device Center), которую можно скачать с сайта Microsoft.


mplayer2.exe

Местонахождение

Program Files\Windows Media Player

Описание

Проигрыватель Windows Media - Windows Media Player

Оказывается вместе с навороченной версией Универсального проигрывателя Windows Media (wmplayer.exe) существует и более простая старая версия 6.4. Причем, данный проигрыватель менее требователен к ресурсам памяти и отлично справляется с проигрыванием звука и видео.


MRINFO.EXE

Местонахождение

%windir%\System32

Описание

Информация многоадресной рассылки

Утилита командной строки.

Синтаксис

mrinfo [-n] [-i address] [-t secs] [-r retries] destination

Параметры

-?
Вывод справки
-n
Disables name resolution on returned neighbors
-i
address Address of interface to which to submit query
-t
seconds Time to wait for IGMP query responses
-r
retries Number of retry attempts for SNMP queries
destination
Address or name of destination router

Дополнительно

Description of the Mrinfo.exe Tool for Command-Line Access to Multicast Routing


mrt.exe

Местонахождение

%systemroot%\system32

Описание

Средство удаления вредоносных программ Microsoft Windows

Данная программа не связана с Защитником Windows, но выполняет схожую работу - ищет различные вредоносные программы. Может работать в трех режимах: Быстрая проверка, Полная проверка, Выборочная проверка.

Параметры командной строки

Параметр | Назначение
/Q или /quiet | Тихий режим. Этот параметр отключает пользовательский интерфейс.
/? | Вывод списка параметров командной строки.
/N | Режим обнаружения. В этом режиме средство сообщает об обнаружении вредоносных программ, но не удаляет их.
/F Расширенная | Проверка компьютера без показа окон мастера.
/F:Y | Расширенная проверка компьютера и автоматическое удаление обнаруженных вредоносных программ.

Смотри также

Средство удаления вредоносных программ для Microsoft Windows удаляет наиболее распространенные виды вредоносных программ с компьютеров под управлением Windows Vista, Windows Server 2003, Windows XP и Windows 2000

Реестр Windows

В Справочнике по реестру Windows ищите также статьи:

Как проверить, что на клиентском компьютере запускалось средство удаления вредоносных программ?

Что предпринять, чтобы данное средство не отправляло отчеты в корпорацию Майкрософт?


MSASCui.exe

Местонахождение

%programfiles%\Windows Defender\

Описание

Windows Defender User Interface

Программа Защитник Windows предназначена для поиска вредоносных приложений на компьютере. Программа автоматически загружается при запуске системы. Кроме того, с ее помощью можно просматривать список автоматически запускаемых программ, список запущенных программ, которые пытаются подключиться к сети и другую информацию. Чтобы получить доступ к этим дополнительным возможностям, нужно перейти к разделу Программы и нажать ссылку Проводник программного обеспечения. Также можно воспользоваться командой с ключом для вывода этого диалогового окна:

MSASCui.exe -ShowSWE

После установки антивируса Microsoft Security Essentials данная программа у меня оказалась отключенной. Антивирус взял на себя функции Защитника Windows.


msconfig.exe

Местонахождение

%windir%\System32

Описание

Настройка системы

После загрузки появляется окно с пятью вкладками:
- Общие
- Загрузка - Здесь можно настроить запуск системы без вывода логотипа. Для этого нужно отметить галочкой пункт Без GUI
- Службы
- Автозагрузка - здесь перечислены все программы, которые запускаются при загрузке системы.
Очень удобно то, что все собрано в одном месте. Не надо лазить по реестру и файлам, чтобы посмотреть, что загружается на компьютере. Можно отключить загрузку любой программы или выполнение строки одного из перечисленных файлов, не правя ничего вручную. При этом комментарии будут расставлены автоматически, а программы, запускаемые из реестра, например, из раздела "Run", будут перенесены в раздел "Run-" (в конце соответствующего раздела добавляется символ "-").
- Сервис

Более подробное описание программы есть в справке самой программы

Вкладка Загрузка

На этой вкладке вы можете:

  • получить информацию о текущей и загружаемой по умолчанию системах;
  • отредактировать время (таймаут), по истечении которого будет загружена операционная система, определенная для загрузки по умолчанию без вмешательства пользователя;
  • изменить систему, загружаемую по умолчанию;
  • удалить ненужную запись из меню загрузки

В верхней части вкладки находится поле со списком операционных систем. Справа каждой записи добавлен комментарий об операционной системе, в которую выполнен вход, и системе, загружаемой по умолчанию.

Для изменения системы, загружаемой по умолчанию, выберите в поле списка запись о нужной операционной системе и нажмите кнопку «Загружать по умолчанию». В результате выполненной операции справа от названия появится соответствующий комментарий.

Для редактирования таймаута в нужном поле нужно установить желаемое количество секунд.

Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».

С помощью данной вкладки нельзя:

  • увидеть и выполнить операции с записями операционных систем, загружаемых с помощью других загрузчиков (например, Windows XP, загружаемой с помощью ntldr);
  • переименовать существующие записи;
  • изменить положение записи в меню загрузки

Один из способов, позволяющий игнорировать запись о несуществующей системе в меню загрузки: установите текущую систему загружаемой по умолчанию, а таймаут установите равным нулю.

Реестр Windows

В Справочнике по реестру Windows ищите также статьи:

Восстановление окна для перезагрузки компьютера
Удаление ненужных записей


msdt.exe

Местонахождение

%systemroot%\system32

Описание

Мастер диагностики и устранения неполадок

Статьи из Базы Знаний

Frequently asked questions about the Microsoft Support Diagnostic Tool (MSDT) when it is used with Windows 7

[SDP 3][06bb55c8-3207-406e-a3fc-f538867a399b] Machine Memory Dump Collector - Windows 7 and Windows Server 2008 R2


msg.exe

Местонахождение

WINDOWS\System32

Описание

Программа выдачи сообщений

Синтаксис

MSG {пользователь | имя сеанса | ID сеанса | @имя файла | *}
    [/SERVER:сервер] [/TIME:секунд] [/V] [/W] [сообщение]

Параметры

пользователь
Имя пользователя
имя сеанса
Имя сеанса
ID сеанса
Идентификатор сеанса
@имя файла
Файл, содержащий список имен пользователей, сеансов или идентификаторов сеансов, которым отправляется сообщение
*
Отправить сообщение всем сеансам на указанном сервере
/SERVER:сервер
Сервер (по умолчанию - текущий)
/TIME:секунд
Интервал ожидания подтверждения от получателя
/V
Отображение информации о выполненных действиях
/W
Ожидание ответа от пользователя, полезно вместе с /V
сообщение
Отправляемое сообщение. Если не указано, выдается запрос или принимается ввод из STDIN
/?
Показывает справку

В Windows Vista/Windows 7 эта программа заменила устаревшую команду net send, которая больше не поддерживается.


msiexec.exe

Местонахождение

Windows\System32

Описание

Установщик Windows® Installer

Чтобы узнать, какая версия Windows Installer у вас установлена, достаточно запустить в командной строке:

msiexec.exe /?


msinfo32.exe

Местонахождение

%windir%\System32

Описание

Сведения о системе

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Программа «Сведения о системе» позволяет быстро собрать необходимые данные.

Для хранения данных о системе предназначены файлы с расширением .nfo. Кроме того, программа «Сведения о системе» работает с файлами форматов .cab и .xml. Содержимое открытого файла .cab можно просматривать средствами меню Сервис.

Синтаксис

msinfo32 [/?] [/pch] [/nfo имя_файла] [/report имя_файла] [/computer имя_компьютера] [/showcategories] [/category код_категории] [/categories код_категории]

Описание программы есть в справке Windows


msoobe.exe

Местонахождение

WINDOWS\system32\oobe

Описание

MSOOBE EXE

Программа активации Windows. Если ваша Windows еще не активирована, то запустите ее
oobe/msoobe /a
Далее следуйте дальнейшим указаниям


mspaint.exe

Местонахождение

Windows\system32

Описание

Paint

В Windows 7 интерфейс программы был значительно переработан. Появилась лента (Ribbon) и дополнительные возможности.

Начиная с Windows Vista, у программы появилась новая команда Обрезать (меню Рисунок), которой мне так не хватало в предыдущих версиях.

Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.

А если удерживать нажатой клавишу Shift при рисовании фигур, то будет рисоваться квадраты и круги, вместо прямоугольников и эллипсов.


msra.exe

Местонахождение

%windir%\system32

Описание

Удаленный помощник Windows

Удаленный помощник Windows (msra.exe) предоставляет удаленному пользователю возможность подключения к вашему компьютеру или наоборот. После подключения пользователь может просматривать экран компьютера и обмениваться сведениями о происходящем на экране. Впервые появилась в Windows Vista и осталась в Windows 7

Синтаксис

msra.exe [/novice] [/expert] [/offerRA computer] [/email password] [/saveasfile path password]
 [/openfile path password] [/geteasyhelp] [/offereasyhelp address] [/getcontacthelp address] [/offercontacthelp address]

Параметры

/novice
Запускает удаленного помощника в режиме запроса помощи и предоставляет пользователю выбор - либо послать приглашение через почтовое приложение (например, Windows Mail), либо сохранить приглашение в файл. После того, как пользователь сделал выбор, удаленный помощник Windows запускается в режиме ожидания подключения.
/expert
Запускает удаленного помощника в режиме оказания помощи, будет предложено загрузить файл-приглашение или выбрать компьютер по имени или адресу. Подключение без файла приглашения требует предварительной настройки компьютера, к которому производится подключение.
/offerRA computer
Запускает удаленного помощника в режиме предложения оказания помощи и использует DCOM для того, чтобы открыть удаленного помощника на компьютере, к которому производится подключение, и после этого подключается к нему, чтобы установить сессию Удаленного Помощника. Имя компьютера может быть именем хоста в локальной сети, DNS-именем или IP4/6 адресом.
/email password
Запускает удаленного помощника в режиме запроса помощи и создает защищенное паролем приглашение, которое будет прикреплено к почтовому сообщению, открытому в почтовом клиенте по умолчанию. Пароль должен быть не менее 6 символов и должен быть сообщен лицу, оказывающему помощь. После запуска в данном режиме почтовый клиент отобразит окно с новым письмом, где пользователь должен вписать электронный адрес лица, оказывающего помощь и отправить письмо.
/saveasfile path password
Запускает удаленного помощника в режиме запроса помощи и создает защищенный паролем password файл-приглашение по пути, указанному в path. Пользователь должен обладать правами создания файла в указанной в папке path, которая может быть локальной или сетевой. Необходимо указать имя файла-приглашения, расширение .MsRcIncident будет добавлено автоматически. Пароль должен быть не менее 6 символов.
/openfile path password
Запускает удаленного помощника в режиме оказания помощи и открывает ранее созданный файл-приглашение, находящийся по пути path. Файл может находится на локальном компьютере или на сетевой папке; пользователь, оказывающий помощь, должен иметь права на открытие файла.
/geteasyhelp
Новый параметр в Windows 7: Запускает удаленного помощника в режиме запроса помощи и с выбранной опцией "Easy Connect".После того, как приглашение будет опубликовано в облаке PNRP, пользователю, запросившему помощь, будет предоставлен 12-символьный пароль, который должен использоваться для установки соединения с помогающим.
/offereasyhelp address
Новый параметр в Windows 7: Запускает удаленного помощника в режиме предложения помощи с выбранной опцией "Easy Connect". Будет отображено окно ввода 12-символьного пароля, который должен использоваться для установки соединения с пользователем, которому будет оказана помощь.
/getcontacthelp address
Новый параметр в Windows 7: Запускает удаленного помощника в режиме запроса помощи с выбранной опцией "Easy Connect" и с выбранным адресом из истории подключений. Адрес вы можете найти в файле RAContacthistory.xml file, находящегося в \Users\Имя пользователя\Appdata\Local folder, в ней адрес представлен 40-символьной 16-тиричной строкой с постфиксом .RAContact.
/offercontacthelp address
Новый параметр в Windows 7: Запускает удаленного помощника в режиме предложения помощи с выбранной опцией "Easy Connect" и с выбранным адресом из истории подключений. Адрес вы можете найти в файле RAContacthistory.xml file, находящегося в \Users\Имя пользователя\Appdata\Local folder, в ней адрес представлен 40-символьной 16-тиричной строкой с постфиксом .RAContact.

Источник: Параметры командной строки удаленного помощника Windows 7 и Windows Vista


mstsc.exe

Местонахождение

%windir%\system32

Описание

Подключение к удаленному рабочему столу

Программа обычно используется в офисах. Для домашнего пользователя интереса не представляет.


narrator.exe

Местонахождение

%systemroot%\system32

Описание

Narrator

Программа Экранный диктор для озвучивания действий, выполняемых при нажатии различных комбинаций клавиш.


nbtstat.exe

Местонахождение

%systemroot%\system32

Описание

Сведения о NetBios через TCP/IP

Назначение: Отображение статистики протокола и текущих подключений TCP/IP с помощью NBT (NetBIOS через TCP/IP). Программа nbtstat.exe является полезным средством при устранении проблем с разрешением имен NetBIOS. Команду nbtstat.exe можно использовать для удаления или исправления предварительно загруженных записей.

Синтаксис

NBTSTAT [-a Узел] [-A IP-адрес] [-c] [-n] [-r] [-R] [-RR] [-s] [-S] [интервал] ]

Параметры

-a (adapter status)
Вывод таблицы имен узла, указанного по имени
-A (Adapter status)
Вывод таблицы имен узла, указанного по IP-адресу
-c (cache)
Вывод буфера имен удаленных узлов, включая адреса IP
-n (names)
Вывод локальных имен NetBIOS
-r (resolved)
Вывод имен, определенных с помощью рассылки и WINS
-R (Reload)
Очистка и перезагрузка таблицы удаленного буфера имен
-S (Sessions)
Вывод таблицы сеансов с IP-адресами
-s (sessions)
Вывод таблицы сеансов с преобразованием IP-адресов в имена NETBIOS
-RR (ReleaseRefresh)
Отсылка пакетов освобождения имени (Name Release)на WINS-сервер, а затем запуск обновления (Refresh)
Узел
Имя удаленного компьютера
IP-адрес
IP-адрес удаленного компьютера
интервал
Повторный вывод статистических данных через указанный интервал в секундах. Для прекращения вывода нажмите клавиши CTRL+C.


net.exe

Местонахождение

Windows\system32

Описание

Net Command

В утилите net.exe реализовано множество команд для управления различными сетевыми компонентами, такими, как разделы, сессии, службы и учетные записи пользователей. Например, с помощью команды net User можно получить информацию о группах, к которым принадлежит пользователь. Пожалуй, это наиболее часто используемая утилита из арсенала любого системного администратора. Описание синтаксиса команды может занять больше десятка страниц.

Примеры

Отключение учетной записи

Например, для отключения учетной записи можно использовать команду

net user имя_пользователя /active :no

Можно посмотреть дату и время запуска рабочей станции при помощи команды

net statistics workstation

После слов «Статистика после» (Statistics since) можно увидеть нужную информацию.

Скрытие папок общего доступа

Папка, для которой установлен общий доступ, видна всем пользователям локальной сети через Сетевое окружение. Можно сделать открытую папку видимой только для некоторых пользователей при помощи утилиты net.

net config server /hidden:yes

После этого вы можете установить общий доступ к папке обычными средствами. Через некоторое время папка не будет видна в списке компьютеров. Чтобы сделать папку вновь видимой, введите команду:

net config server /hidden:no

Отключение и включение режима Aero

net stop uxsms

net start uxsms

Для более подробной информации наберите в командной строке:

net /?


netcfg.exe

Местонахождение

Windows\system32

Описание

WinPE network installer

Утилита командной строки netcfg.exe

Синтаксис

netcfg [-v] [-e] [-winpe] [-l <полный_путь_к_компоненту_INF>] -c <p|s|c> -i <ИД_компьютера>

Параметры

-winpe
устанавливает клиент TCP/IP, NetBIOS и Microsoft для среды предустановки Windows
-l
предоставляет путь к компоненту INF
-c
указывает класс устанавливаемого компонента (p == протокол, s == служба, c == клиент)
-i
указывает ИД компонента

Аргументы необходимо передавать в указанном порядке.

Примеры

Устанавливаем протокол "foo" с помощью c:\\oemdir\\foo.inf

netcfg -l c:\oemdir\foo.inf -c p -i foo

Устанавливаем службу 'MS_Server'

netcfg -c s -i MS_Server

Устанавливаем клиент TCP/IP, NetBIOS и Microsoft для среды предустановки Windows

netcfg [-v] -winpe

Проверяем, установлен ли компонент "MS_IPX"

netcfg -q MS_IPX

Удаляем компонент 'MS_IPX'

netcfg -u MS_IPX

Показываем все установленные компоненты сети

netcfg -s n

Показываем пути привязки, содержащие "MS_TCPIP"

netcfg -b ms_tcpip


netplwiz.exe

Местонахождение

Windows\system32

Описание

Панель управления "Учетная запись опытного пользователя"

Описание программы есть в справке Windows

C помощью данной программы можно настроить включение безопасного входа в систему по нажатию клавиш CTRL+ALT+DELETE. Использование безопасного входа в систему предоставляет еще один уровень безопасности, позволяющий удостовериться, что отображается подлинный экран входа в Windows. Когда безопасный вход в систему включен, другие программы (такие как вирусы или шпионские программы) не могут перехватить имя пользователя и пароль во время их ввода.

Запустите программу netplwiz.exe и на вкладке Дополнительно установите флажок Требовать нажатия Ctrl+Alt+Delete.


netsh.exe

Местонахождение

Windows\system32

Описание

Оболочка сетевых команд

Netsh представляет собой поддерживающую сценарий программу с командной строкой, позволяющую локально или удаленно отображать и изменять параметры сети текущего компьютера. Netsh также обеспечивает средства написания сценариев, которые позволяют запускать группу команд в пакетном режиме на определенном компьютере. Программа Netsh может также сохранять сценарии конфигурации в текстовом файле для помещения в архив или для настройки других серверов.

Описание параметров есть в справке Windows. После выхода Пакета обновлений 2 (SP2) в программу были добавлены новые параметры для брандмауэра Windows

  • netsh firewall
  • netsh firewall show allowedprogram
  • netsh firewall show config
  • netsh firewall show currentprofile
  • netsh firewall show icmpsetting
  • netsh firewall show logging
  • netsh firewall show multicastbroadcastresponse
  • netsh firewall show notifications
  • netsh firewall show opmode
  • netsh firewall show portopening
  • netsh firewall show service
  • netsh firewall show state

Чтобы узнать конкретно о параметре команд, введите этот параметр, затем пробел и знак вопроса. Например, netsh firewall show ?

Примеры

netsh int ip reset 1.txt - используется для сброса TCP/IP
netsh winsock reset - используется для сброса настроек WINSOCK
netsh firewall reset - используется для сброса настроек брандмауэра


netstat.exe

Местонахождение

Windows\system32

Описание

TCP/IP Netstat Command

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat [-a] [-e] [-n] [-o] [-p протокол] [-r] [-s] [интервал]

Описание программы есть в справке Windows

Чтобы вывести все активные подключения, отсортированные по возрастанию номера порта, необходимо набрать:

netstat -n

Чтобы получить список ожидающих портов, введите следующую команду и нажмите клавишу ВВОД:

netstat –ano > netstat.txt


nltest.exe

Местонахождение

%windir%\system32

Описание

Программа проверки сервера входа в Microsoft®

Средство Nltest.exe используется для проверки доверительных отношений между компьютером, являющимся членом домена, и контроллером домена, которому принадлежит учетная запись этого компьютера.

Синтаксис

nltest [/параметры]

Параметры

/SERVER:<имя_сервера>
указать <имя_сервера>
/QUERY
запросить службу входа в сеть <имя_сервера>
/REPL
принудительно выполнить частичную синхронизацию на BDC <имя_сервера>
/SYNC
принудительно выполнить полную синхронизацию на BDC <имя_сервера>
/PDC_REPL
принудительно выполнить сообщение смены UAS из PDC <имя_сервера>
/SC_QUERY:<имя_домена>
запросить безопасный канал для <домен> на <имя_сервера>
/SC_RESET:<имя_домена>[\<имя_DC>]
переустановить безопасный канал для <домен> на <имя_сервера> к <имя_DC>
/SC_VERIFY:<имя_домена>
проверить безопасный канал для <домен> на <имя_сервера>
/SC_CHANGE_PWD:<имя_домена>
сменить пароль безопасного канала для <домен> на <имя_сервера>
/DCLIST:<имя_домена>
получить список контроллеров домена для <имя_домена>
/DCNAME:<имя_домена>
получить имя PDC для <имя_домена>
/DSGETDC:<имя_домена>
вызвать DsGetDcName /PDC /DS /DSP /GC /KDC /TIMESERV /GTIMESERV /WS /NETBIOS /DNS /IP /FORCE /WRITABLE /AVOIDSELF /LDAPONLY /BACKG /DS_6 /TRY_NEXT_CLOSEST_SITE /SITE:<имя_сайта> /ACCOUNT:<имя_учетной_записи> /RET_DNS /RET_NETBIOS
/DNSGETDC:<имя_домена>
вызвать DsGetDcOpen/Next/Close /PDC /GC /KDC /WRITABLE /LDAPONLY /FORCE /SITESPEC
/DSGETFTI:<имя_домена>
вызвать DsGetForestTrustInformation /UPDATE_TDO
/DSGETSITE
вызвать DsGetSiteName
/DSGETSITECOV
вызвать DsGetDcSiteCoverage
/DSADDRESSTOSITE:[имя_компьютера]
вызвать DsAddressToSiteNamesEx /ADDRESSES:<адрес1,адрес2,...>
/PARENTDOMAIN
получить имя родительского домена этого компьютера
/WHOWILL:<домен>* <пользователь> [<итерация>]
определить, выполнит ли <домен> вход для <пользователь>
/FINDUSER:<пользователь>
посмотреть, какой доверенный домен выполнит вход для <пользователь>
/TRANSPORT_NOTIFY
уведомить службу входа в сеть о новом транспорте
/DBFLAG:<шестнадцатеричные флаги>
новый флаг отладки
/USER:<имя_пользователя>
запросить сведения о пользователе на <имя_сервера>
/TIME:<шестнадцатеричный LSL> <шестнадцатеричный MSL>
преобразовать время NT по Гринвичу в формат ASCII
/LOGON_QUERY
запросить количество совокупных попыток входа
/DOMAIN_TRUSTS
запросить доверия домена на <имя_сервера> /PRIMARY /FOREST /DIRECT_OUT /DIRECT_IN /ALL_TRUSTS /V
/DSREGDNS
принудительно выполнить регистрацию всех относящихся к контроллеру домена записей DNS
/DSDEREGDNS:<DNS_имя_узла>
отменить регистрацию относящихся к контроллеру домена записей DNS для указанного контроллера домена /DOM:<DNS_имя_домена> /DOMGUID:<GUID_домена> /DSAGUID:<GUID_DSA>
/DSQUERYDNS
запросить состояние последнего обновления для всех относящихся к контроллеру домена записей DNS
/BDC_QUERY:<имя_домена>
запросить состояние репликации BDC для <имя_домена>
/LIST_DELTAS:<имя_файла>
отобразить содержимое данного файла журнала изменений
/CDIGEST:<сообщение> /DOMAIN:<имя_домена>
получить дайджест клиента
/SDIGEST:<сообщение> /RID:<RID в шестнадцатеричном формате>
получить дайджест сервера
/SHUTDOWN:<причина> [<секунд>]
завершить работу <имя_сервера> вследствие <причина>
/SHUTDOWN_ABORT
прервать завершение работы системы
/?
Вызов справки


notepad.exe

Местонахождение

Windows\system32

Описание

Блокнот

Простейший текстовый редактор, известный как Блокнот. Используется для создания и просмотра простых текстовых документов. Многие веб-дизайнеры используют Блокнот в качестве инструмента для создания интернет-страничек, не доверяя более навороченным программам! В каждой новой версии Windows приобретал новые возможности. Начиная с Windows XP, текстовый редактор уже научился понимать некоторые кодировки. В Windows традиционно используется в качестве просмотра HTML-кода, log-файлов и т.п.

Советы

Блокнот можно очень удобно использовать для ежедневных заметок. Если в первой строке написать .LOG (буквы должны быть большими), то каждый раз при его открытии курсор будет устанавливаться на конец файла, а перед ним будет автоматически вводиться текущая дата и время.


nslookup.exe

Местонахождение

Windows\system32

Описание

nslookup APP

Предоставляет сведения, предназначенные для диагностики инфраструктуры DNS. Для использования этого средства необходимо быть знакомым с принципами работы системы DNS. Средство командной строки Nslookup доступно, только если установлен протокол TCP/IP. Позволяет просматривать записи ресурсов и пересылать запросы любому серверу имен, включая реализацию DNS для UNIX.

Синтаксис

nslookup [-подкоманда ...] [{искомый_компьютер| [-сервер]}]

У nslookup есть два режима работы: интерактивный и неинтерактивный.


ntbackup.exe

Местонахождение

Windows\system32

Описание

Архивация данных Windows

Программа архивации позволяет защитить данные от случайной утери в случае, если в системе возникнет сбой оборудования или носителя. Например, с помощью программы архивации можно создать резервную копию данных на жестком диске, а затем создать архив на другом устройстве хранения данных. При случайном удалении или замене исходных данных на жестком диске из-за его сбоя данные могут быть легко восстановлены из архивной копии. Программа архивации создает снимок состояния тома, представляющий собой точную копию содержимого жесткого диска на определенный момент времени. В справке Windows есть подробное описание работы программы.


ntoskrnl.exe

Местонахождение

Windows\system32

Описание

Системный модуль ядра NT

Данный файл интересен прежде всего тем, что содержит в себе загрузочную картинку (boot screen). Существуют программы, которые изменяют содержимое данного файла. Используется любителями украшений Windows под свой вкус.


odbcad32.exe

Местонахождение

%windir%\system32
или
%windir%\SysWOW64

Описание

Администратор ODBC

В 64-разрядной операционной системе Windows есть два файла odbcad32.exe:

  • %SystemRoot%\system32\odbcad32.exe is используется для создания и поддержки имен источников данных для 64-разрядных приложений
  • %SystemRoot%\SysWOW64\odbcad32.exe is используется для создания и поддержки имен источников данных для 32-разрядных приложений, в том числе и 32-разрядных приложений, работающих на 64-разрядной операционной системе

Дополнительные сведения

Статья из Базы Знаний Microsoft - The 32-bit version of the ODBC Administrator tool and the 64-bit version of the ODBC Administrator tool display both the 32-bit user DSNs and the 64-bit user DSNs in a 64-bit version of the Windows operating system


openfiles.exe

Местонахождение

Windows\system32

Описание

Отображение списка открытых файлов

Утилита командной строки, которая запрашивает или отображает открытые файлы. Также запрашивает, отображает или разъединяет файлы, открытые сетевыми пользователями.

Синтаксис

openfiles.exe /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Описание параметров есть в справке Windows.


OptionalFeatures.exe

Местонахождение

%windir%\system32

Описание

Компоненты Windows

Данную программу можно запустить через Панель управления → Все элементы панели управления → Программы и компоненты → ссылка Включение или отключения компонентов Windows.


osk.exe

Местонахождение

Windows\system32

Описание

Экранная клавиатура

Программа, позволяющая использовать экранную клавиатуру вместо обычной клавиатуры для печати и ввода данных.


p2phost.exe

Местонахождение

%windir%\System32

Описание

Соседние пользователи

Компонент «Соседние пользователи» - это служба, позволяющая использовать в сети определенные одноранговые программы. Чтобы использовать службу «Соседние пользователи», необходимо войти в нее.


pathping.exe

Местонахождение

Windows\system32

Описание

Команда PathPing TCP/IP

Утилита командной строки pathping.exe в течение некоторого периода времени отправляет многочисленные сообщения с эхо-запросом каждому маршрутизатору, находящемуся между исходным пунктом и пунктом назначения, а затем на основании пакетов, полученных от каждого из них, вычисляет результаты. Поскольку pathping показывает коэффициент потери пакетов для каждого маршрутизатора или связи, можно определить маршрутизаторы или субсети, имеющие проблемы с сетью. Команда Pathping выполняет эквивалентное команде tracert действие, идентифицируя маршрутизаторы, находящиеся на пути. Затем она периодически в течение заданного времени обменивается пакетами со всеми маршрутизаторами и на основании числа пакетов, полученных от каждого из них, обрабатывает статистику. Запущенная без параметров, команда pathping выводит справку.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду pathping без параметров в командной строке

pathping

Синтаксис

pathping [-n] [-h максимальное_число_переходов] [-g список_узлов] [-p период] [-q число_запросов [-w интервал] [-T] [-R] [имя_конечного_компьютера]

Параметры

-n
Предотвращает попытки команды pathping сопоставить IP-адреса промежуточных маршутизаторов с их именами. Это позволяет ускорить вывод результатов команды pathping.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного пункта назначения. Значение по умолчанию равно 30.
-g список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных мест назначения, указанным в списке_компьютеров. При свободной маршрутизации последовательные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке равно 9. Список_адресов представляет собой набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-p период
Задает время ожидания между последовательными проверками связи (в миллисекундах). Значение по умолчанию равно 250 миллисекунд.
-q число_запросов
Задает количество сообщений с эхо-запросом, отправленных каждому маршрутизатору пути. По умолчанию - 100.
-w интервал
Задает время ожидания каждого отклика (в миллисекундах). Значение по умолчанию равно 3000 миллисекунд.
-T
Присоединяет тег приоритета уровня 2 (например 802.1p) к сообщениям с эхо-запросом, отправляемым каждому сетевому устройству на маршруте. Это помогает обнаружить сетевые устройства, для которых не настроен приоритет уровня 2. Он предназначен для проверки соединений, использующих спецификации QoS.
-R
Проверяет, все ли сетевые устройства вдоль маршрута поддерживают протокол RSVP (Resource Reservation Setup Protocol, протокол настройки резервирования ресурсов), который позволяет главному компьютеру резервировать определенную часть пропускной способности для потока данных. Этот параметр предназначен для проверки соединений, использующих спецификации QoS.
имя_конечного_компьютера
Задает пунтк назначения, идентифицированный IP-адресом или именем узла.
/?
Отображает справку в командной строке

Примечания

Параметры команды Pathping вводятся с учетом регистра.

Во избежание перегрузки сети пакеты должны передаваться через довольно большие интервалы времени.

Чтобы минимизировать эффект потери пакетов, не нужно слишком часто выполнять проверку связи.

После запуска pathping сначала выводится путь. Это тот же путь, который выводится командой tracert. Далее в течение 90 секунд команда выдает сообщение о том, что она занята (это время варьируется в зависимости от числа переходов).В течение этого времени происходит сбор сведений со всех маршрутизаторов, перечисленных выше, и со всех соединений между ними. По завершении этого периода выводятся результаты проверки.


pause.exe

Местонахождение

?

Описание

Приостановка выполнения пакетного файла и вывод сообщения:

Для продолжения нажмите любую клавишу . . .

При разработке сценариев BAT или CMD вы можете вызвать программу pause.exe, чтобы в командной строке отобразилось приглашение Для продолжения нажмите любую клавишу . . .. При этом работа сценария не будет завершена до тех пор, пока пользователь не нажмет любую клавишу.

Пример

Создадим простой сценарий

echo "hello, bublik"
pause
echo "cool"
pause


PING.EXE

Местонахождение

Windows\system32

Описание

Команда Ping TCP/IP

Утилита командной строки Ping проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP, с помощью отправки сообщений с эхо-запросом по протоколу ICMP . После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping [-t] [-a] [-n счетчик] [-l размер] [-f] [-i TTL] [-v тип] [-r счетчик] [-s счетчик] [{-j список_узлов | -k список_узлов}] [-w интервал] [имя_конечного_компьютера]

Параметры

-t
Задает для команды ping отправку сообщений с эхо-запросом к точке назначения до тех пор, пока команда не будет прервана. Для прерывания команды и вывода статистики нажмите комбинацию клавиш CTRL+BREAK. Для прерывания команды ping и выхода из нее нажмите клавиши CTRL+C.
-a
Задает разрешение обратного имени по IP-адресу назначения. В случае успешного выполнения выводится имя соответствующего узла
-n счетчик
Задает число отправляемых сообщений с эхо-запросом. По умолчанию используется 4 сообщения
-l размер
Задает длину (в байтах) поля данных в отправленных сообщениях с эхо-запросом. По умолчанию - 32 байта. Максимальный размер - 65527
-f
Задает отправку сообщений с эхо-запросом с флагом Don't Fragment в IP-заголовке, установленном на 1. Сообщения с эхо-запросом не фрагментируются маршрутизаторами на пути к месту назначения. Этот параметр полезен для устранения проблем, возникающих с максимальным блоком данных для канала (Maximum Transmission Unit)
-i TTL
Задает значение поля TTL в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию берется значение TTL, заданное по умолчанию для узла. Для узлов Windows XP это значение обычно равно 128. Максимальное значение TTL - 255
-v тип
Задает значение поля типа службы (TOS) в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию это значение равно 0. тип - это десятичное значение от 0 до 255
-r счетчик
Задает параметр записи маршрута (Record Route) в IP-заголовке для записи пути, по которому проходит сообщение с эхо-запросом и соответствующее ему сообщение с эхо-ответом. Каждый переход в пути использует параметр записи маршрута. По возможности значение счетчика задается равным или большим, чем количество переходов между источником и местом назначения. Параметр счетчик имеет значение от 1 до 9
-s счетчик
Указывает вариант штампа времени Интернета (Internet Timestamp) в заголовке IP для записи времени прибытия сообщения с эхо-запросом и соответствующего ему сообщения с эхо-ответом для каждого перехода. Параметр счетчик имеет значение от 1 до 4
-j список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При свободной маршрутизации последовательные промежуточные точки назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке узлов - 9. Список узлов - это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами
-k список_узлов
Указывает для сообщений с эхо-запросом использование параметра строгой маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При строгой маршрутизации следующая промежуточная точка назначения должна быть доступной напрямую (она должна быть соседней в интерфейсе маршрутизатора). Максимальное число адресов или имен в списке узлов равно 9. Список узлов - это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами
-w интервал
Определяет в миллисекундах время ожидания получения сообщения с эхо-ответом, которое соответствует сообщению с эхо-запросом. Если сообщение с эхо-ответом не получено в пределах заданного интервала, то выдается сообщение об ошибке Request timed out. Интервал по умолчанию равен 4000 (4 секунды)
имя_конечного_компьютера
Задает компьютер по его IP-адресу или имени узла
/?
Выводит справку в командной строке

Примечание

Команды ping и ipconfig лежат в основе диагностики сетей TCP/IP.

  1. C помощью ipconfig проверьте, инициализирована ли конфигурация TCP/IP.
  2. Выполните команду ping с адресом возвратной петли (127.0.0.1), чтобы убедиться, что стек протоколов TCP/IP корректно установлен и привязан к сетевой плате:
    C:\>ping 127.0.0.1
  3. Выполните команду ping с IP-адресом локального компьютера, чтобы убедиться, что в сети отсутствует идентичный IP-адрес.
  4. Выполните команду ping с IP-адресом шлюза по умолчанию, чтобы убедиться в работе шлюза и компьютер может работать с локальной сетью.
  5. Выполните команду ping с IP-адресом удаленного узла, чтобы убедиться, что компьютер может устанавливать соединение через маршрутизатор.

Обычно, если пункт 5 выполнен успешно, то первые 4 пункта можно не проверять.

Команда ping позволяет проверить имя и IP-адрес компьютера. Если проверка IP-адреса успешная, и проверка имени - нет, то имеет место проблема разрешения имен. В этом случае с помощью запросов DNS (Domain Name System) или с помощью методов разрешения имен NetBIOS проверьте, чтобы имя задаваемого компьютера было разрешено в локальном файле Hosts.

Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Для отправки сообщения точке назначения 10.0.99.221 и сопоставления с ее узловым именем введите:

ping -a 10.0.99.221

Для отправки точке назначения 10.0.99.221 десяти собщений с эхо-запросом, каждое из которых имеет поле данных из 1000 байт, введите:

ping -n 10 -l 1000 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и записи маршрута для 4 переходов введите:

ping -r 4 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и задания свободной маршрутизации для точек назначения 10.12.0.1-10.29.3.1-10.1.44.1 введите:

ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221


PostMig.exe

Местонахождение

%systemroot%\System32\migwiz

Описание

Приложение после переноса средством переноса данных Windows


powercfg.exe

Местонахождение

%WINDIR%\system32

Описание

Программа командной строки для настройки электропитания

Эта команда позволяет администратору управлять параметрами электропитания системы. Получить более подробную информацию о программе и ее параметрах можно через команду

powercfg /?

Примеры

Отобразить текущую конфигурацию схемы электропитания

powercfg /Q

Включение функции гибернации

powercfg /hibernate on

Получения информации о поддерживаемых состояниях спящего режима

powercfg /a

Экспорт плана электропитания

Windows 7 поставляется с тремя планами электропитания, которые настроены в соответствии с представлениями создателей операционной системы. По мере работы мы изменяем настройки планов, приходя в итоге к их оптимальному сочетанию. Можно сохранять и восстанавливать параметры каждого плана, что удобно при переносе на другой компьютер, автоматической установке Windows или при переустановке системы.

Запустите утилиту с параметром -list

powercfg -list

Скопируйте GUID (набор букв и цифр) нужного плана. Для этого щелкните правой кнопкой мыши в командной строке, выберите из меню пункт Пометить, после чего выделите GUID и отпустите кнопку мыши.

Экспортируйте план командой (План будет сохранен на рабочем столе).

powercfg -export %userprofile%\desktop\plan.pow GUID

Вместо GUID подставьте значение вашего GUID.

Импорт плана электропитания

Чтобы импортировать план, выполните команду

powercfg -import %userprofile%\desktop\plan.pow

Можно сразу сделать импортируемый план активным, используя параметр -setactive или -s. тогда последовательность действий чуть изменится.

Создайте уникальный GUID, либо используйте приведенный ниже.

Импорт плана и назначение его активным

powercfg -import %userprofile%\desktop\plan.pow 681f8f49-29c7-40ad-bc7b-f08e543dc6f3
powercfg -setactive 681f8f49-29c7-40ad-bc7b-f08e543dc6f3


powershell.exe

Местонахождение

%SystemRoot%\system32\WindowsPowerShell\v1.0

Описание

Windows PowerShell

Windows PowerShell 1.0 — это новая оболочка командной строки на основе задач и язык сценариев. Она специально разработана для администрирования систем. Встроенная в .NET Framework, оболочка Windows PowerShell помогает ИТ-специалистам и опытным пользователям контролировать и автоматизировать процесс администрирования операционной системы Windows и приложений, работающих в системе Windows.

Используя оболочку Windows PowerShell, администраторы могут управлять системами с помощью отдельных команд или сценариев, автоматизирующих задачи управления. Exchange Server 2007, System Center Operations Manager 2007, System Center Data Protection Manager V2 и System Center Virtual Machine Manager используют оболочку Windows PowerShell для повышения эффективности и производительности.

Более подробную информацию о PowerShell можно узнать из справочника PowerShell на примерах

Дополнительная информация

Установочный пакет Windows PowerShell 1.0 для системы Windows Vista

Веб-узел Windows PowerShell (на английском языке): http://www.microsoft.com/powershell

Блог Windows PowerShell (на английском языке): http://blogs.msdn.com/powershell

Группа новостей Windows PowerShell (на английском языке): http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.windows.powershell

Комплект разработчика Windows PowerShell (на английском языке): http://msdn2.microsoft.com/en-us/library/aa830112.aspx


PowerShell_ISE.exe

Местонахождение

%SystemRoot%\system32\WindowsPowerShell\v1.0

Описание

Windows PowerShell ISE. Комментарий: Интегрированная среда сценариев Windows PowerShell. Выполнение операций с объектами (командная строка)

PowerShell_ISE.exe - это графическая консоль/редактор PowerShell ISE (Integrated Scripting Environment). C его помощью удобно создавать сценарии и отлаживать их.

Более подробную информацию о PowerShell можно узнать из справочника PowerShell на примерах


PresentationHost.exe

Местонахождение

%windir%\System32

Описание

Узел Windows Presentation Foundation

Приложение PresentationHost.exe позволяет размещать приложения WPF в совместимых браузерах (включая Internet Explorer 6 и более поздние версии).По умолчанию Windows Presentation Foundation (WPF) Host зарегистрирован в качестве оболочки и обработчика MIME для браузерного WPF содержимого, которое включает:

  • нескомпилированные файлы xaml
  • XBAP (XAML browser application — приложение обозревателя XAML) - файлы xbap.

Для файлов этих типов, Windows Presentation Foundation (WPF) Host:

Запускает зарегистрированный HTML обработчик для размещения Windows Presentation Foundation (WPF) содержимого

Загружает верные версии требуемых среда CLR (common language runtime) и Windows Presentation Foundation (WPF) сборок.

Обеспечивает установку соответствующих уровней разрешений для зоны развертывания.

Синтаксис

PresentationHost.exe [parameters] uri|filename

Параметры

имя_файла
Путь к активируемому файлу.Также может быть URI
-отладка
При активации приложения не фиксировать или не запускать его из хранилища.Это работает только тогда, когда активируется локальный файл
-debugSecurityZoneURL <url>
Используется со значением URL-адрес для обозначения PresentationHost.exe, что приложение должно быть отлажено, как если бы оно было развернуто из указанного URL-адрес.Это определяет зону развертывания и начальный веб-узел.
-embedding
Требуется при OLE.Если указан параметр -event или -debug, то указывать параметр -embedding необязательно, поскольку он устанавливается внутри.
-событие <имя_события>
Откройте событие с указанным именем и укажите его при инициализации и готовности PresentationHost.exe разместить WPF содержимое.PresentationHost.exe будет завершен, если произошла ошибка при открытии события, например, если оно еще не было создано.
-launchApplication <url>
Запускает автономное приложение ClickOnce с указанного URL-адреса.Применяется политика безопасности Internet Explorer и WinINet в отношении приложений .NET.

Пример

Создайте в текстовом редакторе следующий текст

<!--Пример XAML-файла -->
<Button xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    Foreground="LightSeaGreen"
    FontSize="24pt"
    Width="200"	Height="50">
    Hello, XAML
</Button>

Присвойте файлу расширение XAML, например, test.xaml и запустите его двойным щелчком в Проводнике. PresentationHost запустит данный файл, который отобразится в браузере Internet Explorer в виде кнопки с текстом Hello, XAML. Более подробно о технологии XAML также можно узнать на сайте для программистов (категория WPF)


PresentationSettings.exe

Местонахождение

%windir%\System32

Описание

Клиент адаптируемости презентаций для мобильных ПК (Microsoft)

Программа запускается только на мобильных компьютерах - лэптопах, ноутбуках, планшетных компьютерах и т.п. При попытке запустить на обычном компьютере выводится соответствующее сообщение.

У программы есть несколько недокументированных ключей

  • /stop - Завершает работу модуля презентации
  • /start - Запускает модуль презентации
  • /silent - Запускает модуль презентации в режиме без взаимодействия с пользователем

Запуск программы на настольных компьютерах

Хотя программу нельзя запустить на настольном компьютере, с помощью реестра можно исправить данное положение вещей. Для этого нужно воспользоваться ключом SkipBatteryCheck. Подробнее об этом можно узнать из Справочника по реестру Windows, доступного по адресу user.alexanderklimov.ru

Параметры презентации на настольном компьютере


PrintBrmUi.exe

Местонахождение

%windir%\System32

Описание

Приложение PrintBrm

Запускает мастер экспорта/импорта очереди принтера и драйверы.


psr.exe

psr.exe (Windows 7)

Местонахождение

%windir%\System32

Описание

Средство записи действий по воспроизведению неполадок (Problem Steps Recorder)

Раньше ИТ-специалисту приходилось мириться с тем, что у конечных пользователей не было возможности быстро и просто сделать запись последовательности своих действий, связанных с возникновением какой-то проблемы. В Windows 7 появилась новая утилита Problem Steps Recorder, которая представляет собой простой инструмент для захвата изображения с экрана монитора с возможностью аннотации изображений. После того, как вы нажмете "Record", приложение начинает отслеживать сигналы с вашей мыши и вашей клавиатуры и делать скриншоты, к которым вы можете прикреплять свои комментарии. Как только вы остановите запись, программа автоматически сохранит все полученные снимки в ZIP-файле, который содержит HTML-страницу в виде веб-архива (файла с расширением mht) с последовательностью ваших действий. Далее вам придется просто просмотреть в браузере файл для анализа ситуаций.

Эта утилита является, по сути, простым, но продвинутым инструментом для выполнения захвата экрана или снятия скриншотов. Это нечто вроде автоматизированного варианта "Print Screen", который при этом документирует все щелчки мыши, нажатия клавиш клавиатуры и собирает кое-какой технический материал, а затем сводит все это в отчет в формате MHTML. Отчет можно отправить прямиком в службу поддержки. А также можно поступить и наоборот, и отправить от службы поддержки подробную инструкцию, куда нажать и в какой последовательности, чтобы устранить эту проблему.

Составление отчета - это, пожалуй, сильное место утилиты. Утилита регистрирует каждое действие пользователя скриншотом, на котором подсвечены кнопки или объекты, с которыми взаимодействовал пользователь. Отчет можно просматривать и в виде веб-страницы, и в виде слайдшоу, а можно и в виде XML, чтобы определить, к примеру, координаты курсора мыши.


rasdial.exe

Местонахождение

%windir%\System32

Описание

Интерфейс связи из командной строки для службы удаленного доступа


rasphone.exe

Местонахождение

Windows\system32

Описание файла

Телефонная книга удаленного доступа

Синтаксис

rasphone.exe [-f файл] [[-e | -d | -h | -r] элемент]
rasphone.exe [-f файл] -a [элемент]
rasphone.exe [-f файл] -lx связь
rasphone.exe

Параметры

-a
Вывод диалогового окна создания элемента
-e
Вывод диалогового окна изменения элемента
-d
Вывод диалогового окна связи с помощью элемента
-h
Завершение связи без подтверждения
-r
Удаление элемента без подтверждения
-lx
Выполнение команды 'x' для ярлыков удаленного доступа. x - Любая из команд a, e, d, h или r
элемент
Имя элемента телефонной книги для выполнения операции
файл
Полный путь к файлу телефонной книги
связь
Полный путь к файлу ярлыков удаленного доступа
"элемент"
без команд выбирает элемент в диалоговом окне телефонной книги


recdisc.exe

recdisc.exe (Windows 7)

Местонахождение

%windir%\System32

Описание

Диска восстановления системы Microsoft® Windows (Microsoft Create system repair Disc)

В Windows 7 стало возможным создавать системный загрузочный CD-диск, представляющий собой загрузочную CD-версию Windows, которая включает в себя только командную строку и набор диагностических утилит. В случае непредвиденного краха операционки он позволит получить доступ к командной строке и предпринять попытки восстановить систему.


recover.exe

Местонахождение

%windir%\System32

Описание

Утилита восстановления файлов

Утилита командной строки служит для восстановления сохранившихся данных на поврежденном диске.

Синтаксис

RECOVER [диск:][путь]имя_файла


reg.exe

Местонахождение

Windows\system32

Описание

Утилита редактирования системного реестра из командной строки

Данная утилита позволяет просматривать, добавлять, удалять различные данные из реестра. Дополнительную информацию можно получить, запустив в командной строке

reg /?

Примеры

Для получения номера версии Internet Explorer из реестра введите в командной строке:

reg query "HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer" /v Version


regedit.exe

Местонахождение

%windir%

Описание

Редактор реестра

Редактор реестра позволяет модифицировать данные в реестре. Реестру посвящен отдельный Справочник по реестру Windows

Открыть вторую копию реестра

По умолчанию, редактор реестра открывается в одном экземпляре. Но, воспользовавшись ключом -m, можно открыть вторую копию редактора (Windows XP и выше):

regedit -m


regedt32.exe

Местонахождение

%windir%\system32

Описание

Registry Editor Utility

В Windows XP и выше это программа просто запускает редактор реестра regedit.exe. В Windows 2000 это была альтернативная программа для редактирования реестра.


regini.exe

Местонахождение

Windows\system32

Описание

Registry Initializer

Начиная с Windows Vista, эта программа входит в состав операционной системы. Подробнее о возможностях программы можно узнать, если запустить утилиту с ключом /?


regsvr32.exe

Местонахождение

Windows\system32

Описание

Сервер регистрации, (C) Microsoft

Программа регистрирует в реестре файлы .dll как компоненты команды. Данная утилита весьма активно используется программистами для регистрации и отмены регистрации различных собственных элементов управления OLE, например файлов управления DLL и файлов управления ActiveX (OCX). Часто бывает необходимо регистрировать тот или иной файлв для устранения некоторых неполадок в Windows, обозревателе Microsoft Internet Explorer и других программах.

Синтаксис

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] имя_dll

Параметры

/u
Отменяет регистрацию сервера
/s
Задает запуск regsvr32 без вывода сообщений на экран.
/n
Указывает не вызывать DllRegisterServer. Этот параметр можно использовать с параметром /i.
/i:cmdline
Вызывает DllInstall с помощью дополнительной передачи [cmdline]. При использовании с параметром /u вызывает удаление dll.
dllname
Задает имя файла dll для последующей регистрации.
/?
Вывод справки в командной строке.

Примеры

Для регистрации файла .dll для схемы Active Directory введите:

regsvr32 schmmgmt.dll

Для включения работы с zip-архивами как с папками

regsvr32 zipfldr.dll

Сообщения об ошибках Regsvr32.exe

Следующий список содержит сообщения об ошибках RegSvr32 и возможные причины.

Нераспознанный флаг: /неверный_параметр
Введено недопустимое сочетание параметров.
Не указано имя DLL
Не введено имя файла DLL
имя_Dll была загружена, но найти точку входа для DllRegisterServer или DllUnregisterServer не удалось
Имя_DLL не является файлом DLL или OCX. Например, это сообщение об ошибке будет отображено, если введена команда regsvr32 wjview.exe.
имя_Dll не является исполняемым файлом и ни одного модуля поддержки для этого типа файлов не зарегистрировано
Имя_DLL не является исполняемым файлом EXE, DLL или OCX. Например, это сообщение об ошибке будет отображено, если введена команда regsvr32 autoexec.bat
имя_Dll была загружена, но найти точку входа для DllRegisterServer или DllUnregisterServer не удалось
Возможно, файл Имя_DLL не экспортирован или в памяти находится поврежденная версия файла Имя_DLL. Для обнаружения файла и его удаления воспользуйтесь средством Pview
имя_Dll не поддерживает саморегистрацию, либо в памяти находится поврежденная версия
Например, при вводе команды regsvr32 icwdial.dll будет возвращено это сообщение об ошибке, так как файл Icwdial.dll не регистрируется автоматически. Если есть подозрение на то, что в памяти находится поврежденная версия Имя_DLL , попробуйте перезагрузить компьютер или извлеките исходную версию файла. При работе в Windows NT может потребоваться средство Kill or Pview из набора Microsoft Windows NT Server 4.0 Resource Kit.
Ошибка при вызове функции OleInitialize
В программе Regsvr32 должна проводиться инициализация библиотеки COM до вызова ее функций и отмена инициализации при завершении работы. Это сообщение об ошибке возникает, если попытка инициализации или ее отмена не были успешными. Например, файл Ole32.dll поврежден или имеет неправильный номер версии
Ошибка при вызове LoadLibrary("имя_Dll. GetlastError возвращает ошибку 0x00000485
Winerror.h, 0x00000485 = 1157 (ERROR_DLL_NOT_FOUND) означает, что не найден один из файлов библиотек, необходимый для запуска приложения. Например, при вводе команды regsvr32 missing.dll будет возвращено это сообщение об ошибке, если файл Missing.dll не найден
Ошибка при вызове LoadLibrary("имя_Dll. GetLastError возвращает ошибку 0x00000002
Winerror.h, 0x00000002 = 2 (ERROR_FILE_NOT_FOUND) означает, что не удается найти указанный файл. Т. е. не найден соответствующий файл DLL. Например, при вводе команды regsvr32 icwdial.dll будет возвращено это сообщение об ошибке, если файл Tapi32.dll не найден.
Ошибка при вызове LoadLibrary("dskmaint.dll"). GetLastError возвращает ошибку 0x000001f
Winerror.h, 0x000001f = 31 (ERROR_GEN_FAILURE) означает, что не функционирует подключенное к системе устройство. Это происходит при попытке регистрации файла Win16.dll. Например, это сообщение об ошибке будет отображено, если введена команда regsvr32 dskmaint.dll.
Ошибка при вызове DllRegisterServer (или DllUnregisterServer) в имя_Dll . Возвращенный код: строка
В файле Winerror.h найдите эту строку

Regsvr32.exe и зависимости

RegSvr32.exe связана с файлами Kernel32.dll, User32.dll и Ole32.dll (и файлами Msvcrt.dll и Advapi32.dll в Windows NT). В Regsvr32.exe загружается файл, который требуется регистрировать или отменить его регистрацию вместе с ее зависимостями. Процесс будет неуспешным, если необходимый файл отсутствует или поврежден.

Советы

Справочник Народные советы.Windows: Удаление папок Мои рисунки и других подпапок в папке Мои документы

Справочник Народные советы.Windows: Отключить работу с zip-файлами как с папками


rekeywiz.exe

Местонахождение

%windir%\system32

Описание

Мастер EFS REKEY

Программа rekeywiz.exe служит для создания сертификата шифрования пользователя и поместить его на жесткий диск компьютера, на смарт-карту, либо в центр сертификации домена Active Directory. Также можно вызвать программу через ссылку УПРАВЛЕНИЕ СЕРТИФИКАТАМИ ШИФРОВАНИЯ ФАЙЛОВ мастера УЧЕТНЫЕ ЗАПИСИ ПОЛЬЗОВАТЕЛЕЙ (Панель управления\Все элементы панели управления\Учетные записи пользователей).


resmon.exe

Местонахождение

%windir%\system32

Описание

Resource Monitor

Представленный в системах Windows® 7 и Windows Server® 2008 R2 монитор ресурсов Windows (resmon.exe) является мощным средством, дающим представление об использовании системных ресурсов процессами и службами. Наряду с наблюдением за использованием ресурсов в режиме реального времени монитор ресурсов дает возможность проанализировать неотвечающие процессы, определить приложения, использующие файлы, а также контролировать процессы и службы.

Монитор ресурсов имеет пять вкладок: Обзор, ЦП, Память, Диск и Сеть. На вкладке Обзор отображаются общие данные об использовании системных ресурсов, на других вкладках выводятся сведения о каждом конкретном ресурсе.

Определение процесса с наиболее высоким уровнем использования ЦП

  • Перейдите на вкладку ЦП
  • В разделе Процессы щелкните столбец ЦП, чтобы отсортировать процессы по текущему уровню потребления ресурса ЦП
  • На первом месте в разделе Образ находится процесс, использующий наибольший объем ЦП; он же имеет самое высокое значение в разделе ЦП.

Определение процесса, использующего файл

  • Откройте вкладку ЦП, а затем разверните таблицу Связанные дескрипторы, щелкнув строку ее заголовка.
  • Щелкните поле Поиск дескрипторов, введите имя искомого файла, а затем нажмите кнопку поиска. В строке поиска регистр не учитывается, а подстановочные знаки не поддерживаются. В поле поиска можно ввести все имя файла или его часть, а также весь путь или его часть. Например, при поиске c:\windows будут выведены все файлы, путь которых содержит c:\windows.
  • Просмотрите результаты, чтобы определить процесс, использующий файл.

Определение сетевого адреса, к которому подключен процесс

  • Откройте вкладку Сеть, а затем разверните таблицу Подключения TCP, щелкнув строку ее заголовка
  • Найдите процесс, сетевое подключение которого требуется определить. Если в таблице слишком много записей, щелкните элемент Образ, чтобы выполнить сортировку по имени исполняемого файла
  • В столбцах Удаленный адрес и Удаленный порт просмотрите, к какому сетевому адресу и порту подключен процесс.

Просмотр свободного места на всех устройствах хранения

Откройте вкладку Диск, а затем разверните таблицу Запоминающие устройства, щелкнув строку ее заголовка. В столбце Свободное место отображается объем свободного места в мегабайтах для каждого физического диска системы.

Просмотр объема памяти, доступного программам

  • Откройте вкладку Память
  • В разделе Физическая память просмотрите значение Доступно для программ. Доступная память — это сумма зарезервированной памяти и свободной памяти. В свободную память входят пустые страницы памяти

Устранение неполадок в неотвечающих приложениях

Переставшие отвечать приложения могут ожидать завершения других процессов или доступности системных ресурсов, после чего они возобновят свою работу. С помощью монитора ресурсов Windows можно просмотреть цепочки ожидания и завершить работу процессов, вызывающих неправильную работу программ. Неотвечающий процесс будет выделен красным цветом в таблице ЦП на вкладке Обзор и в таблице Процессы на вкладке ЦП.

Внимание: Монитор ресурсов используется для завершения процесса только в том случае, если пользователь не может закрыть программу обычным способом. Если с процессом связана какая-либо открытая программа, она будет немедленно закрыта, а все несохраненные данные будут утеряны. Завершение работы системного процесса может привести к нестабильности системы и потере данных.

  • В основной таблице на любой из вкладок монитора ресурсов в столбце Образ правой кнопкой мыши щелкните имя исполняемого файла процесса, который требуется проанализировать, а затем выберите пункт Анализ цепочки ожидания
  • Если процесс выполняется нормально и не ожидает другие процессы, данные о цепочке ожидания не выводятся. Если процесс ожидает другие процессы, отображается дерево, упорядоченное по принципу зависимости от других процессов.
  • Если отображается дерево цепочки ожидания, в нем можно завершить один или несколько процессов. Для этого следует выбрать нужные процессы и нажать кнопку Завершить процесс.

Примечание: Работа многих системных процессов находится в зависимости от других процессов и служб. Монитор ресурсов отобразит данные о цепочке ожидания для любого процесса. Если процесс в таблице не выделен красным цветом, состояние процесса имеет значение Выполняется, а программа работает нормально, то никаких действий пользователя не требуется.

Подробнее о работе с программой можно почитать на странице Руководство по устранению неполадок, связанных с доступностью ресурсов


robocopy.exe

Местонахождение

Windows\System32

Описание

robocopy

Начиная с Windows Vista, эта утилита командной строки входит в состав операционной системы. Можно использовать как надежное средство копирования папок и/или файлов с локальных или сетевых ресурсов. Главная особенность: запущенная с ключом /Z, реализует "докачку" с файловых шар (restartable mode), то есть если в процессе копирования разрывается соединение, и связь с сервером теряется, то после восстановления канала связи копирование файла продолжается с точки разрыва, а не начинается заново. Подробнее о возможностях программы можно узнать, если запустить утилиту с ключом /?

C помощью xcopy.exe можно сделать копию папки с подпапками, но нельзя сделать зеркало: то есть, если в оригинальной папке что-то удалить, эти файлы останутся в копии. А вот robocopy обладает по сравнению с ней более расширенным функционалом. У robocopy есть ключ /mir, который позволяет создавать зеркало папки или диска. И вы всегда можете быть уверены в том, что папки в архиве в точности соответствуют оригиналу. Например:

robocopy "D:\MyFiles" "F:\MyFiles" /mir

Вы можете сделать аналогичные команды для папок, которые требуется зеркалировать, записать команды в пакетный файл CMD и вызывать его с помощью планировщика Windows в нужное время. Кстати, подобное зеркалирование также крайне удобно проводить, например, с переносным диском, который используется для синхронизации файлов на разных компьютерах.


route.exe

Местонахождение

Windows\system32

Описание файла

Команда Route TCP/IP

Эта команда нужна для редактирования или просмотра таблицы маршрутов IP из командной строки. Ключ /? выводит все доступные ключи при работе с Route. Запущенная без параметров, команда route выводит справку.

Синтаксис

route [-f] [-p] [команда [конечная_точка] [mask маска_сети] [шлюз] [metric метрика]] [if интерфейс]]

Параметры

-f
Очищает таблицу маршрутизации от всех записей, которые не являются узловыми маршрутами (маршруты с маской подсети 255.255.255.255), сетевым маршрутом замыкания на себя (маршруты с конечной точкой 127.0.0.0 и маской подсети 255.0.0.0) или маршрутом многоадресной рассылки (маршруты с конечной точкой 224.0.0.0 и маской подсети 240.0.0.0). При использовании данного параметра совместно с одной из команд (таких, как add, change или delete) таблица очищается перед выполнением команды.
-p
При использовании данного параметра с командой add указанный маршрут добавляется в реестр и используется для инициализации таблицы IP-маршрутизации каждый раз при запуске протокола TCP/IP. По умолчанию добавленные маршруты не сохраняются при запуске протокола TCP/IP. При использовании параметра с командой print выводит на экран список постоянных маршрутов. Все другие команды игнорируют этот параметр. Постоянные маршруты хранятся в реестре по адресу HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes
команда
Указывает команду, которая будет запущена на удаленной системе. В следующей таблице представлен список допустимых параметров.
Команда | Назначение
add | Добавление маршрута
change | Изменение существующего маршрута
delete | Удаление маршрута или маршрутов
print | Печать маршрута или маршрутов
конечная_точка
Определяет конечную точку маршрута. Конечной точкой может быть сетевой IP-адрес (где разряды узла в сетевом адресе имеют значение 0), IP-адрес маршрута к узлу, или значение 0.0.0.0 для маршрута по умолчанию.
mask маска_сети
Указывает маску сети (также известной как маска подсети) в соответствии с точкой назначения. Маска сети может быть маской подсети соответствующей сетевому IP-адресу, например 255.255.255.255 для маршрута к узлу или 0.0.0.0. для маршрута по умолчанию. Если данный параметр пропущен, используется маска подсети 255.255.255.255. Конечная точка не может быть более точной, чем соответствующая маска подсети. Другими словами, значение разряда 1 в адресе конечной точки невозможно, если значение соответствующего разряда в маске подсети равно 0.
шлюз
Указывает IP-адрес пересылки или следующего перехода, по которому доступен набор адресов, определенный конечной точкой и маской подсети. Для локально подключенных маршрутов подсети, адрес шлюза — это IP-адрес, назначенный интерфейсу, который подключен к подсети. Для удаленных маршрутов, которые доступны через один или несколько маршрутизаторов, адрес шлюза — непосредственно доступный IP-адрес ближайшего маршрутизатора.
metric метрика
Задает целочисленную метрику стоимости маршрута (в пределах от 1 до 9999) для маршрута, которая используется при выборе в таблице маршрутизации одного из нескольких маршрутов, наиболее близко соответствующего адресу назначения пересылаемого пакета. Выбирается маршрут с наименьшей метрикой. Метрика отражает количество переходов, скорость прохождения пути, надежность пути, пропускную способность пути и средства администрирования.
if интерфейс
Указывает индекс интерфейса, через который доступна точка назначения. Для вывода списка интерфейсов и их соответствующих индексов используйте команду route print. Значения индексов интерфейсов могут быть как десятичные, так и шестнадцатеричные. Перед шестнадцатеричными номерами вводится 0х. В случае, когда параметр if пропущен, интерфейс определяется из адреса шлюза.
/?
Отображает справку в командной строке.

Примечания

  • Большие значения в столбце metric таблицы маршрутизации — результат возможности протокола TCP/IP автоматически определять метрики маршрутов таблицы маршрутизации на основании конфигурации IP-адреса, маски подсети и стандартного шлюза для каждого интерфейса ЛВС. Автоматическое определение метрики интерфейса, включенное по умолчанию, устанавливает скорость каждого интерфейса и метрики маршрутов для каждого интерфейса так, что самый быстрый интерфейс создает маршруты с наименьшей метрикой. Чтобы удалить большие метрики, отключите автоматическое определение метрики интерфейса в дополнительных свойствах протокола TCP/IP для каждого подключения по локальной сети.
  • Имена могут использоваться для параметра конечная_точка, если существует соответствующая запись в файле базы данных Networks, находящемся в папке системный_корневой_каталог\System32\Drivers\Etc. В параметре шлюз можно указывать имена до тех пор, пока они разрешаются в IP-адреса с помощью стандартных способов разрешения узлов, таких как запрос службы DNS, использование локального файла Hosts, находящегося в папке системный_корневой_каталог\system32\drivers\etc, или разрешение имен NetBIOS.
  • Если команда — print или delete, параметр шлюз опускается и используются подстановочные знаки для указания точки назначения и шлюза. Значение конечной_точки может быть подстановочным значением, которое указывается звездочкой (*). При наличии звездочки (*) или вопросительного знака (?) в описании конечной точки, они рассматриваются как подстановки, тогда печатаются или удаляются только маршруты, соответствующие точке назначения. Звездочка соответствует любой последовательности символов, а вопросительный знак — любому одному символу. 10.*.1, 192.168.*, 127.* и *224* являются допустимыми примерами использования звездочки в качестве подстановочного символа.
  • При использовании недопустимой комбинации значений конечной точки и маски подсети (маски сети) выводится следующее сообщение об ошибке : «Маршрут: неверная маска подсети адреса шлюза». Ошибка появляется, когда одно или несколько значений разрядов в адресе конечной точки равно 1, а значения соответствующих разрядов маски подсети — 1. Для проверки этого состояния выразите конечную точку и маску подсети в двоичном формате. Маска подсети в двоичном формате состоит из последовательности единичных битов, представляющей часть сетевого адреса конечной точки, и последовательности нулевых битов, обозначающей часть адреса узла конечной точки. Проверьте наличие единичных битов в части адреса точки назначения, которая является адресом узла (как определено маской подсети).
  • Параметр -p поддерживается в команде route только в операционных системах Windows NT 4.0, Windows 2000, Windows Millennium Edition и Windows XP. Этот параметр не поддерживается командой route в системах Windows 95 и Windows 98.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести на экран все содержимое таблицы IP-маршрутизации, введите команду:

route print

Чтобы вывести на экран маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route print 10.*

Чтобы добавить маршрут по умолчанию с адресом стандартного шлюза 192.168.12.1, введите команду:

route add 0.0.0.0 mask 0.0.0.0 192.168.12.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить постоянный маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route -p add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и метрикой стоимости 7, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 metric 7

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и использованием индекса интерфейса 0х3, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 if 0x3

Чтобы удалить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0, введите команду:

route delete 10.41.0.0 mask 255.255.0.0

Чтобы удалить все маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route delete 10.*

Чтобы изменить следующий адрес перехода для маршрута с конечной точкой 10.41.0.0 и маской подсети 255.255.0.0 с 10.27.0.1 на 10.27.0.25, введите команду:

route change 10.41.0.0 mask 255.255.0.0 10.27.0.25


RpcPing.exe

Местонахождение

%windir%\System32

Описание

Программа RPC Ping

Утилита командной строки RPCPing.exe проверяет связь с сервером по протоколу RPC

Синтаксис

rpcping [-t <последовательность протокола>] [-s <адрес сервера>]
        [-e <конечная точка>|-f <UUID интерфейса>[,основная версия]]
        [-O <UUID объекта интерфейса>] [-i <число итераций>]
        [-u <идентификатор пакета безопасности>]
        [-a <уровень проверки подлинности>] [-N <основное имя сервера>]
        [-I <удостоверение проверки подлинности>] [-C <возможности>]
        [-T <отслеживание удостоверения>] [-M <тип олицетворения>]
        [-S <sid сервера>] [-P <удостоверение проверки подлинности прокси>]
        [-F <флаги RPC/HTTP>] [-H <схемы проверки подлинности RPC/HTTP>]
        [-o <параметры привязки>] [-B <субъект сертификата сервера>]
        [-b] [-E] [-q] [-c]
        [-A <удостоверение проверки подлинности http-прокси>]
        [-U <схемы проверки подлинности HTTP-прокси>]
        [-r <промежуток между отчетами>] [-v <уровень подробности>] [-d]

Параметры

-t <последовательность протокола>
последовательность протокола, которую необходимо использовать. Можно указать одну из стандартных последовательностей протокола RPC - ncacn_ip_tcp, ncacn_np, ncacn_http и т. д. Если этот параметр не задан, то по умолчанию используется ncacn_ip_tcp.
-s <адрес сервера>
адрес сервера. Если этот параметр не задан, будет проверена связь с локальным компьютером. Примеры: server, server.com, 157.59.244.141
-e <конечная точка>
конечная точка для проверки связи. Если этот параметр не задан, проводится проверка связи с модулем сопоставления конечных точек на целевом компьютере. Этот параметр нельзя применять вместе с параметром, задающим интерфейс (-f).
-o <параметры привязки>
параметры привязки для проверки связи RPC. Дополнительные сведения можно найти в библиотеке MSDN (разделы "RpcStringBindingCompose" и "RPC over HTTP").
-f <UUID интерфейса>[,основная версия]
интерфейс для проверки связи. Этот параметр нельзя применять вместе с параметром, который задает конечную точку. Интерфейс указывается с помощью идентификатора UUID. Если параметр основной версии не задан, используется версия 1 интерфейса. Если интерфейс указан, то команда rpcping запрашивает модуль сопоставления конечных точек на целевом компьютере, чтобы получить конечную точку для указанного интерфейса. Запрос модуля сопоставления конечных точек производится в соответствии с параметрами, указанными в строке команды.
-O <Object UUID>
идентификатор Uuid объекта, если интерфейс зарегистрировал его.
-i <число итераций>
необходимое количество вызовов. Значение по умолчанию - 1. Этот параметр используется для определения задержки соединения, если указано несколько итераций.
-u <идентификатор пакета безопасности>
пакет безопасности (поставщик безопасности) RPC, который используется для вызова. Пакет безопасности задается числом или именем. Если указано число, то это должно быть то же число, что и в API RpcBindingSetAuthInfoEx. В таблице ниже приведены имена и числа. В именах не различаются заглавные и строчные буквы: Negotiate - 9 или одно из имен: nego, snego или negotiate NTLM - 10 или NTLM SChannel - 14 или SChannel Kerberos - 16 или Kerberos Kernel - 20 или Kernel Если этот параметр задан, то необходимо указать уровень проверки подлинности, отличный от "none". Значение по умолчанию для этого параметра отсутствует. Если этот параметр не задан, то в RPC не используется безопасность при проверке связи.
-a <уровень проверки подлинности>
уровень проверки подлинности, который следует использовать. Возможны следующие значения: connect, call, pkt, integrity и privacy. Если этот параметр задан, необходимо также указать идентификатор пакета безопасности (параметр -u). Значение по умолчанию для этого параметра отсутствует. Если этот параметр не задан, RPC не использует безопасность при проверке связи.
-N <основное имя сервера>
задает основное имя сервера. Такая же семантика, как у аргумента ServerPrincName в RpcBindingSetAuthInfoEx. Для получения дополнительных сведений о RpcBidningSetAuthInfoEx см. MSDN. Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-I <удостоверение проверки подлинности>
позволяет задать альтернативное удостоверение для подключения к серверу. Удостоверение задается в форме: пользователь,домен,пароль, где значение этих трех полей очевидно. Если имя пользователя, домен или пароль содержат специальные символы, которые могут интерпретироваться оболочкой, удостоверение следует заключить в двойные кавычки. Вместо пароля можно указать *, тогда RPC выведет запрос на ввод пароля, не показывая вводимые символы на экране. Если это поле не задано, используется удостоверение текущего пользователя. Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-C <возможности>
шестнадцатеричная битовая маска флагов. Этот параметр имеет то же значение,что и поле "Возможности" в структуре RPC_SECURITY_QOS, описанной в MSDN. Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-T <отслеживание удостоверения>
может принимать значения static или dynamic. Если не задано, то по умолчанию используется dynamic. Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-M <тип олицетворения>
может принимать значения anonymous, identify, impersonate или delegate. По умолчанию используется "Impersonate". Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-S <sid сервера>
ожидаемый идентификатор SID сервера. Дополнительные сведения см. для поля Sid в структуре RPC_SECURITY_QOS в MSDN. Использовать этот параметр можно только при работе с сервером Windows .NET Server 2003 или более поздней версии. Это поле можно использовать, только если выбраны уровень проверки подлинности и пакет безопасности.
-P <удостоверение проверки подлинности прокси>
задает удостоверение для проверки подлинности для RPC/HTTP-прокси. Формат тот же, что и для параметра -I. Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u), уровень проверки подлинности (-a) и схемы проверки подлинности (-H).
-F <флаги RPC/HTTP>
Флаги для прохождения проверки подлинности переднего плана RPC/HTTP. Эти флаги могут быть заданы числами или именами В настоящее время распознаются следующие флаги:
Use SSL - 1 или ssl или use_ssl
Use first auth scheme - 2 или first или use_first
См. поле "Флаги" в структуре RPC_HTTP_TRANSPORT_CREDENTIALS для получения дополнительных сведений. Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u)и уровень проверки подлинности (-a).
-H <схемы проверки подлинности RPC/HTTP>
схемы проверки подлинности, которые используются при проверке подлинности переднего плана RPC/HTTP. Этот параметр представляет собой список числовых значений или имен, разделенных запятой. Например: Basic,NTLM. Распознаются следующие значения (в именах не различаются заглавные и строчные буквы)
Basic - 1 или Basic
NTLM - 2 или NTLM
Certificate - 65536 или Cert
Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u) и уровень проверки подлинности (-a).
-B <субъект сертификата сервера>
субъект сертификата сервера. См. поле "Субъект сертификата сервера" в структуре RPC_HTTP_TRANSPORT_CREDENTIALS в MSDN для получения дополнительных сведений. Чтобы этот параметр работал, необходимо использовать SSL. Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u)и уровень проверки подлинности (-a).
-b
извлекает субъект сертификата сервера из сертификата, отправленного сервером, и выводит его на экран или в файл журнала. Этот параметр можно использовать, только если указан параметр "только эхо прокси" (-E) и параметры "use SSL". Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u) и уровень проверки подлинности (-a).
-R
задает HTTP-прокси. Если задано значение "none", HTTP-прокси не используется, вместо этого делается попытка прямого подключения к RPC-прокси. Если задано значение "default", используются настройки IE на клиентском компьютере. Любое другое значение обрабатывается как явно указанный HTTP-прокси. Если данный флаг не указан, принимается значение "default", а именно, проверяются настройки IE. Этот флаг можно использовать, только если указан флаг -E (только эхо прокси).
-E
проверка связи проводится только с RPC/HTTP-прокси. Пакеты не достигают сервера. Этот параметр используется, когда необходимо проверить доступность RPC/HTTP-прокси. Чтобы использовать этот параметр, необходимо также задать пакет безопасности (-u) и уровень проверки подлинности (-a). Чтобы указать HTTP-прокси, используйте флаг -R. Если HTTP-прокси задан с помощью флага -o, данный параметр игнорируется.
-q
тихий режим. Ничего не спрашивается, кроме паролей. Предполагается, что на все вопросы дан ответ "Y" ("Да"). Этот параметр следует использовать осторожно.
-c
использовать сертификат смарт-карты. Команда RPCPing просит пользователя выбрать смарт-карту.
-A <удостоверение проверки подлинности http-прокси>
задает удостоверение для проверки подлинности для HTTP-прокси. Формат тот же, что и для параметра -I. Чтобы использовать этот параметр, необходимо также задать схемы проверки подлинности (-U), пакет безопасности (-u) и уровень проверки подлинности (-a).
-U <схемы проверки подлинности HTTP-прокси>
схемы проверки подлинности, которые используются для проверки подлинности HTTP-прокси. Этот параметр представляет собой список числовых значений или имен, разделенных запятой. Например: Basic,NTLM. Распознаются следующие значения (в именах не различаются заглавные и строчные буквы):
Basic - 1 или Basic
NTLM - 2, или NTLM
Чтобы использовать этот параметр, необходимо задать пакет безопасности (-u) и уровень проверки подлинности (-a).
-r <промежуток между отчетами>
если указаны несколько итераций, при задании этого параметра rpcping выводит статистику текущего выполнения периодически, а не после последнего вызова. Интервал между выводами отчета задается в секундах. Значение по умолчанию равно 15.
-v <уровень подробности>
определяет, насколько подробными должны быть выходные данные команды rpcping. Значение по умолчанию равно 1. Значения 2 и 3 обеспечивают более подробные выходные данные команды rpcping.
-d
запуск пользовательского интерфейса сетевой диагностики RPC

Пример

Проверка доступности сервера Exchange, к которому производится подключение по RPC/HTTP:

rpcping -t ncacn_http -s exchange_server -o RpcProxy=front_end_proxy
        -P "имя пользователя,домен,*" -H Basic -u NTLM -a connect -F 3

После получения запроса следует ввести пароль. exchange_server - имя сервера Exchange, front_end_proxy - имя прокси, "имя пользователя" и "домен" - имя пользователя и домен, которые вы вводите в приглашении Outlook. Остальные параметры заданы так, что команда rpcping пытается связаться с сервером Exchange точно так же, как Outlook подключается к этому серверу для обычного профиля.

Дополнительные сведения

Использование программы RPC Ping для устранения неполадок, связанных с установкой подключений компонентом «Exchange через Интернет» в Outlook 2007 и Outlook 2003

Пример сценария для проверки конфигурации сертификатов


rstrui.exe

Местонахождение

%windir\system32\

Описание

Восстановление системы Microsoft® Windows

Программа Восстановление системы служит, как видно из названия, для восстановления системы. Программа позволяет вернуть настройки компьютера в более раннее состояние (контрольная точка). Обратите внимание, что восстановление конфигурации системы происходит без потерь текущих данных (документы, почтовые сообщения, ссылки). Об этой программе достаточно много говорится в справке Windows.

Управление восстановлением системы через сценарии

Для программы восстановления системы можно создавать различные сценарии, позволяющие создавать контрольные точки восстановления, перечислять имеющиеся точки, включать или выключать возможность восстановления системы для заданных дисков. При использовании данных скриптов задействованы WMI и файл srclient.dll, которая является клиентской DLL для программы восстановления системы и пользователь должен иметь права администратора системы

Создание контрольной точки

'Используем WMI и класс SystemRestore
set SRP = getobject("winmgmts:\\.\root\default:Systemrestore")
CSRP = SRP.createrestorepoint ("Создание тестовой контрольной точки", 0, 100)

Отключение или включение Восстановления системы для заданного диска

onoff = InputBox ("Вы хотите включить (вкл) или отключить (выкл) Восстановление системы? Введите слова вкл или выкл", "Восстановление системы")
Drive = InputBox ("Выберите нужный диск. Вы должны использовать формат 'c:\'", "Работа с диском")

set SRP = GetObject("winmgmts:\\.\root\default:SystemRestore")

If onoff = "вкл"  then
eSRP = SRP.enable(drive)
end if

If onoff = "выкл" then
eSRP = SRP.disable(drive)
end if

Перечисление контрольных точек восстановления системы

' Перечисление контрольных точек
set SRP = getobject("winmgmts:\\.\root\default").InstancesOf ("systemrestore")
for each Point in SRP
msgbox point.creationtime & vbcrlf & point.description & vbcrlf & "Порядковый номер= " & point.sequencenumber
next

Реестр

Смотри также в справочнике по реестру статью Восстановление системы.


rundll32.exe

Местонахождение

%WINDIR%\System32

Описание

Хост-процесс Windows (Rundll32)

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Данная утилита была разработана для внутреннего использования программистами Microsoft. Но богатые возможности этой программы широко используются и обычными пользователями.

Область применения данной утилиты довольно широка. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск | Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, C#, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

  • DEVMGR.DLL
  • IEAKENG.dll
  • INETCPL.CPL
  • KEYMGR.DLL
  • MSRATING.dll
  • PRINTUI.DLL
  • SHELL32.DLL
  • URL.DLL
  • USER.EXE
  • USER32.DLL
  • XWIZARDS.DLL

DEVMGR.DLL
  • RunDll32.exe devmgr.dll DeviceManager_Execute - Вызов окна Диспетчер устройств

IEAKENG.dll
  • rundll32.exe IEAKENG.dll ModifyRatings - окно Ограничения доступа

INETCPL.CPL
  • rundll32 inetcpl.cpl OpenFontsDialog - открывает окно Шрифты для настройки шрифта, размера шрифта, кодировки (в том числе кодировки по умолчанию.
  • rundll32 inetcpl.cpl OpenLanguageDialog - открывает окно Выбор языка для выбора языков, используемых при обзоре URL-адресов, в порядке предпочтения. Также он позволяет настроить префикс и суффикс, добавляемые к вводимым URL-адресам при нажатии комбинации клавиш Ctrl+Shift+Enter.
  • rundll32 inetcpl.cpl ShowLanguageDialog - открывает окно Выбор языка для выбора языков, используемых при обзоре URL-адресов, в порядке предпочтения. Также он позволяет настроить префикс и суффикс, добавляемые к вводимым URL-адресам при нажатии комбинации клавиш Ctrl+Shift+Enter (аналогично предыдущей команде).
  • rundll32 inetcpl.cpl DisplayPopupWindowManagementDialog - окно Параметры блокирования всплывающих окон
  • rundll32 inetcpl.cpl LaunchPopupWindowManagementDialog - окно Параметры блокирования всплывающих окон
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 8 - Удаление временных файлов интернета
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 2 - Удаление cookies
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 1 - Удаление истории просмотра
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 16 - Удаление данных из веб-форм
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 32 - Удаление запомненных паролей
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 255 - Удаление всех данных, перечисленных выше
  • RunDll32.exe InetCpl.cpl,ClearMyTracksByProcess 4351 - Удаление всех данных + удаление файлов и настроек для аддонов

KEYMGR.DLL
  • RunDll32.exe keymgr.dll,KRShowKeyMgr - окно Сохранение имен пользователей и паролей
  • RunDll32.exe keymgr.dll,PRShowSaveWizardExW - запуск Мастера забытых паролей

MSRATING.dll
  • rundll32.exe MSRATING.dll ClickedOnRAT - окно Система оценок в Internet Explorer
  • rundll32.exe MSRATING.dll RatingClickedOnRATInternal- окно Система оценок в Internet Explorer (запускается только с правами администратора)
  • rundll32.exe MSRATING.dll RatingSetupUI - окно Ограничения доступа

PRINTUI.DLL
  • Rundll32 Printui.dll,PrintUIEntry /? - окно Пользовательский интерфейс принтера

SHELL32.DLL
  • Rundll32 Shell32.dll,Control_RunDLL main.cpl @0,0 - вкладка Кнопки мыши окна Свойства мыши
  • Rundll32 Shell32.dll,Control_RunDLL main.cpl @0,1 - вкладка Указатели окна Свойства мыши
  • Rundll32 Shell32.dll,Control_RunDLL main.cpl @0,2 - вкладка Параметры указателя окна Свойства мыши
  • Rundll32 Shell32.dll,Control_RunDLL main.cpl @0,3 - вкладка Колесико окна Свойства мыши
  • Rundll32 Shell32.dll,Control_RunDLL main.cpl @0,4 - вкладка Оборудование окна Свойства мыши
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры". Вкладка Скорость.
  • rundll32 shell32,Control_RunDLL main.cpl @1,1 - открыть диалог "Свойства клавиатуры". Вкладка Оборудование.
  • RunDll32.exe Shell32.dll,Control_RunDLL powercfg.cpl - окно Электропитание (Панель управления | Оборудование и звук)
  • RunDll32.exe shell32.dll,Control_RunDLL nusrmgr.cpl - окно Учетные записи пользователей Панели управления
  • RunDll32.exe shell32.dll,Control_RunDLL wscui.cpl - окно Центр поддержки
  • runDll32.exe shell32.dll,Options_RunDLL 0 - Вкладка Общие окна Параметры папки
  • runDll32.exe shell32.dll,Options_RunDLL 1 - вкладка Панель задач окна Свойства панели задач и меню "Пуск"
  • runDll32.exe shell32.dll,Options_RunDLL 2 - вкладка Поиск окна Свойства папки
  • runDll32.exe shell32.dll,Options_RunDLL 3 - вкладка Меню "Пуск" окна Свойства панели задач и меню "Пуск"
  • runDll32.exe shell32.dll,Options_RunDLL 4 - окно Системные значки
  • runDll32.exe shell32.dll,Options_RunDLL 5 - окно Панель управления\Все элементы панели управления\Значки области уведомлений
  • runDll32.exe shell32.dll,Options_RunDLL 6 - вкладка Панели инструментов окна Свойства панели задач и меню "Пуск"
  • runDll32.exe shell32.dll,Options_RunDLL 7 - вкладка Вид окна Свойства папки
  • runDll32.exe shell32.dll,Control_RunDLL firewall.cpl - компонент Панель управления\Все элементы панели управления\Брандмауэр Windows
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0 - компонент Звук (вкладка Воспроизведение)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1 - компонент Звук (вкладка Запись)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2 - компонент Звук (вкладка Звуки)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3 - компонент Звук (вкладка Связь)
  • rundll32.exe shell32.dll,Control_RunDLL modem.cpl - окно Сведения о расположении при настройке модема
  • rundll32.exe shell32.dll,Control_RunDLL ncpa.cpl - компонет Панели управления Сетевые подключения
  • runDll32.exe shell32.dll,Control_RunDLL NetSetup.cpl,@0 - окно Настройка сети для настройки беспроводных маршрутизаторов и точек доступа
  • rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl - окно Администратор Microsoft ODBC
  • Windows XP: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0 - апплет Система (вкладка Общие) (от 1 до 6 - другие вкладки)
  • Windows Vista: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,1 - вкладка Имя компьютера в окне Свойства системы
  • Windows Vista: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,2 - вкладка Оборудование в окне Свойства системы
  • Windows Vista: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,3 - вкладка Дополнительно в окне Свойства системы
  • Windows Vista: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,4 - вкладка Защита системы в окне Свойства системы
  • Windows Vista: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,5 - вкладка Удаленное использование в окне Свойства системы
  • rundll32.exe shell32.dll,Control_RunDLL telephon.cpl - апплет Телефон и модем
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время"
  • rundll32 shell32,Control_RunDLL timedate.cpl,,/f - открыть вкладку Часовой пояс диалогового окна свойств времени Панели управления
  • rundll32 shell32,OpenAs_RunDLL - окно "Выбор программы"
  • Windows Vista: Rundll32 Shell32.dll,OpenAs_RunDLL yourfile.ext - окно "Выбор программы" с заданным именем файла
  • rundll32 shell32,ShellAboutA user.alexanderklimov.ru (или RunDll32.exe SHELL32.DLL,ShellAboutW) - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • Rundll32 Shell32.dll,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска
  • Rundll32 Shell32.dll,SHHelpShortcuts_RunDLL FontsFolder - папка Fonts
  • Rundll32 Shell32.dll,SHHelpShortcuts_RunDLL PrintersFolder - окно Принтеры Панели управления
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу

URL.DLL
  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 url.dll, NewsProtocolHandler %1 - произвести подключение к новостному серверу, где %1 - URL сервера.
  • rundll32 url.dll, TelnetProtocolHandler %1 - осуществить подключение telnet, где %1 - адрес сервера.

USER.EXE
  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать
  • rundll32 user,enableoemlayer - включить и загрузить OEM Layer, если есть возможность выполнить эту команду дистанционно
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows
  • rundll32 user,RepaintScreen - выполнить команду "Обновить"
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n
  • Windows XP: rundll32 user,SwapMouseButton - поменять местами кнопки мыши (обратная смена невозможна)
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска"
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска"

USER32.DLL
  • Rundll32.exe User32.dll,LockWorkStation или rundll32 user32.dll LockWorkStation - блокировка компьютера
  • Windows Vista: Rundll32 User32.dll,SwapMouseButton - поменять местами кнопки мыши (обратная смена невозможна)

XWIZARDS.DLL
  • rundll32.exe xwizards.dll RunWizard {7071ECE0-663B-4BC1-A1FA-B97F3B917C55} - диалоговое окно Установка подключения или сети с выделением блока Подключение к Интернету
  • rundll32.exe xwizards.dll RunWizard {7071ECE5-663B-4BC1-A1FA-B97F3B917C55} - диалоговое окно Connect to Network Page с выделением блока Подключение к Интернету
  • rundll32.exe xwizards.dll RunWizard {7071ECB6-663B-4BC1-A1FA-B97F3B917C55} - диалоговое окно VPN/Dialup Hook Page с выделением блока Использовать мое подключение к Интернету (VPN)
  • rundll32.exe xwizards.dll RunWizard {C03E8500-781E-49A1-8190-CE902D0B2CE7} - диалоговое окно VPN/Dialup Hook Page с выделением блока Использовать прямой набор номера
  • rundll32.exe xwizards.dll RunWizard {7071ECB0-663B-4BC1-A1FA-B97F3B917C55} - диалоговое окно Подключение к рабочему месту
  • rundll32.exe xwizards.dll RunWizard {7071ECB8-663B-4BC1-A1FA-B97F3B917C55} - диалоговое окно Connect to Work Hook Page (Non-UI)

Разное

  • Windows Vista: rundll32.exe dwmApi #104 - Отключает прозрачность Aero
  • Windows Vista: rundll32.exe dwmApi DwmEnableComposition или rundll32.exe dwmApi #102 - Включает прозрачность Aero
  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска"
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 sysdm.cpl, EditEnvironmentVariables - вызов диалогового окна Переменные среды
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.
  • rundll32 syncui.dll, Briefcase_Intro - вызов мастера по работе с "Портфелем"
  • rundll32 SYNCUI.DLL, Briefcase_Create - создать новую папку "Портфель", если эта функция установлена в системе.
  • rundll32 msgina,ShellShutdownDialog - вызов диалога "Завершение работы Windows".
  • rundll32.exe oobefldr.dll, ShowWelcomeCenter - вызов апплета Панели управления Центр начальной настройки
  • rundll32.exe powrprof.dll,SetSuspendState - ввести компьютер в режим Гибернация
  • rundll32.exe powrprof.dll,SetSuspendState Sleep - ввести компьютер в режим Сон
  • rundll32 shdocvw.dll,DoOrganizeFavDlg - вызов окна "Упорядочить избранное"
  • rundll32 shdocvw.dll,OpenURL filename - запуск .url файла с именем filename
  • rundll32 tcpmonui.dll, LocalAddPortUI - запуск мастера установки TCP-порта принтера.
  • rundll32 desk.cpl, InstallScreenSaver [filename.scr] - задать файл скринсейвера в диалоговом окне свойств дисплея.
  • rundll32 IEdkcs32.dll, Clear - сброс некоторых настроек Internet Explorer, полезно использовать при некоторых сбоях в работе обозревателя.


sc.exe

Местонахождение

%windir%/System32

Описание

Вспомогательное средство для разработки служб WindowsNT

sc.exe служит для управления службами: запуск, остановка, настройка.

Дополнительно

Статья из Базы Знаний Microsoft Создание службы Windows с помощью программы Sc.exe


sdclt.exe

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Архивация и восстановление

Описание

Программа архивации Microsoft® Windows

Программа sdclt.exe запускает компонент Панели управления Архивация и восстановление (Панель управления\Все элементы панели управления\Архивация и восстановление).

С помощью компонента Архивация и восстановление вы можете:

  • выполнять архивацию заданных папок по расписанию и восстанавливать их из резервной копии
  • создать полный образ системы
  • создать загрузочный диск для восстановления Windows 7

В этой статье речь пойдет о возможностях резервного копирования Windows 7 - создании файловых архивов и дисковых образов.

Возможности архивации в Windows 7

Windows 7 позволяет вам создавать как резервные копии папок, так и полный образ разделов жесткого диска.

Тип архивации Технология и возможности
Пользовательские файлы
  • Архивация производится на уровне файлов.
  • Сохранение резервных копий возможно на разделы NTFS и FAT32.
  • Добавления к первоначальному архиву происходят инкрементно (т. е. добавляются только изменившиеся файлы).
  • Для сжатия используется формат ZIP.
  • Имеется возможность восстановления отдельных папок и библиотек.
Образ раздела
  • Архивация производится на уровне блоков (в архив включаются только используемые блоки).
  • Сохранение резервных копий возможно только на разделы NTFS.
  • Полный образ сохраняется в формате VHD, при этом сжатия файлов не происходит. В дальнейшем образы создаются инкрементно, т. е. добавляются только изменившиеся блоки. Для этого используется функционал теневых копий. Последующее создание полных образов также возможно.
  • Образы разделов дают возможность быстрого восстановления ОС и файлов в случае выхода из строя жесткого диска.

Этот функционал в совокупности с возможностью загрузки в среду восстановления без установочного диска способен удовлетворить запросы большинства домашних пользователей. Теперь они вполне могут обходиться без сторонних программ резервного копирования.

Изменения в пользовательском интерфейсе

Изменения в возможностях архивации Windows 7 затронули не только технологии, но и пользовательский интерфейс. В частности:

  • переработан интерфейс главного окна элемента панели управления Архивация и восстановление
  • создан новый пользовательский интерфейс для управления пространством, занятым под резервные копии
  • упрощено восстановление файлов, выполняющееся с помощью мастера
  • реализована интеграция с центром поддержки для своевременного уведомления пользователей о необходимости создания резервной копии

Элементы пользовательского интерфейса архивации описаны в действии ниже.

Настройка параметров регулярного резервного копирования

По умолчанию резервное копирование не настроено. Щелкните ссылку Настроить резервное копирование в главном окне элемента панели управления, чтобы задать параметры архивации.

Варианты размещения резервной копии файлов приводятся в таблице.

Размещение | Комментарии
Внутренний жесткий диск Вы можете разместить архивные файлы на:
  • несистемном разделе того же физического диска, на котором установлена ОС
  • любом разделе другого физического диска
Рекомендуется второй вариант, ибо в случае выхода из строя системного диска вы потеряете как операционную систему, так и резервные копии.
Внешний жесткий диск Если настроена архивация по расписанию, внешний жесткий диск должен быть подключен на момент создания резервной копии.

Примечание. Windows 7 не поддерживает архивацию на USB диски с флэш памятью.
Локальная сеть | Поддерживается архивация только на компьютеры сети, работающие под управлением Windows 7. Безусловно, вам потребуются учетные данные для доступа к компьютеру, на котором размещается резервная копия.

Вы можете размещать архивы файлов на разделах, отформатированных как в файловую систему NTFS, так и в FAT32. При архивации на жесткий диск файлы размещаются в корне раздела. Вы не можете задать вложенную папку для архива, но ничто не мешает вам размещать на этом диске другие файлы и папки.

Далее в статье рассматривается сохранение резервной копии на раздел внутреннего жесткого диска. Определившись с размещением архива, вы должны задать параметры архивации. Можно предоставить это решение операционной системе, а можно выбрать папки самостоятельно.

При самостоятельном выборе вы можете создать резервные копии:

  • пользовательских файлов, включая библиотеки
  • папок локального диска
  • полного образа системы

В конце Windows 7 выводит сводку параметров резервного копирования.

Щелкните ссылку Изменить расписание, чтобы настроить резервное копирование по расписанию в удобное вам время.

Заданные вами параметры расписания сохраняются в планировщике заданий, который отвечает за своевременный запуск архивации.

По завершении настройки параметров архивации вы возвращаетесь в главное окно элемента панели управления.

Создание резервной копии файлов

Теперь в главном окне отображаются все параметры архивации. Нажмите кнопку Архивировать, чтобы начать процесс резервного копирования.

Ход архивации отображается с помощью полосы прогресса, но вы можете посмотреть подробности, нажав кнопку Просмотр сведений.

Завершив архивацию, вы можете посмотреть сведения об используемом дисковом пространстве и перейти к управлению архивами.

Создание образа системы

В отличие от файловых архивов, системный образ можно сохранить только на диске, отформатированном в файловую систему NTFS. Это обусловлено тем, что образы представляют собой файлы в формате VHD, размер которых может превышать 4 Гб (предельный размер файла для FAT32).

Первый системный образ представляет собой полный снимок раздела, а последующие являются инкрементными, т. е. включают в себя лишь изменения по сравнению с предыдущим образом. Эта возможность, позволяющая сэкономить дисковое пространство, реализована с помощью теневых копий. Такой принцип создания образов применяется при их сохранении на внутренних, внешних и оптических дисках. Для внутренних и внешних дисков этот принцип действует до тех пор, пока на диске имеется достаточно места. Когда место заканчивается, создается полный образ, а все предыдущие удаляются. Что же касается сетевых дисков, то на них всегда создается полный образ, а старый образ при этом перезаписывается новым.

Давайте рассмотрим создание первого образа. В левой панели элемента Архивация и восстановление нажмите ссылку Создание образа системы. Откроется окно с вариантами размещения образа.

На следующем шаге вы сможете выбрать разделы для архивации.

В образ автоматически включается служебный раздел со средой восстановления (Windows RE) и системный раздел. Исключить их из резервной копии нельзя. Если в системе имеются другие разделы, вы сможете выбрать их на этом шаге. Определившись с выбором разделов, нажмите кнопку Архивировать, чтобы начать процесс создания резервной копии.

Все следующие образы создаются точно так же. Как я уже сказал выше, они содержат только изменившиеся блоки. Для того чтобы снова создать полный образ системы, вам необходимо удалить существующие образы или перенести их на другой раздел. Вы также можете переместить их из корня диска во вложенные папки, однако примите к сведению, что в этом случае их не увидит программа восстановления системы из образа. О расположении и содержимом резервных копий и пойдет речь дальше.

Управление пространством

В главном окне элемента панели управления Архивация и восстановление щелкните ссылку Управление пространством. Откроется окно, в котором выводится информация о расположении архива, сводка об использовании дискового пространства, а также ссылки и кнопки для просмотра архивов и управления ими.

Расположение резервных копий

Помимо просмотра подробных сведений об используемом пространстве, вы можете открыть место хранения резервной копии - нажмите ссылку Обзор, и файлы откроются в проводнике.

Windows 7 распознает папку с архивом и предоставляет удобный доступ к параметрам восстановления, которые также можно открыть двойным щелчком по папке.

Интерес, конечно, представляют папки:

  • %COMPUTERNAME% (в данном случае ADMIN-PC) - архив файлов
  • WindowsImageBackup - папка с образом раздела

Содержимое файлового архива

Открыть папку с архивом можно с помощью контекстного меню. Содержимое архива прозрачно для пользователя - внутри ZIP-архивы, и при желании файлы можно оттуда извлечь непосредственно из проводника.

Однако из панели управления восстанавливать файлы удобнее, например, благодаря встроенному поиску.

Содержимое образа

Архивный образ системы создается в формате VHD и хранится в папке WindowsImageBackup наряду со вспомогательными файлами.

Увидеть его содержимое можно, воспользовавшись новой возможностью Windows 7 - подключением виртуальных жестким дисков в оснастке управления дисками (Пуск - Поиск - diskmgmt.msc - Действие - Присоединить виртуальный жесткий диск).

Возможно, вас заинтересует вопрос, можно ли добавить файлы на виртуальный жесткий диск. Технически это возможно, однако с точки зрения восстановления средствами Windows это ничего не даст. Лучше сделать новый образ - изменившиеся блоки добавляются инкрементно на основе теневых копий, что позволяет сэкономить дисковое пространство.

Просмотр и удаление резервных копий

Из окна управления пространством вы можете удалять файловые архивы и резервные образы.

Нажмите кнопку Просмотр архивов в окне управления пространством, чтобы увидеть список архивов.

Windows 7 находит все архивы и отображает период архивации и занимаемое дисковое пространство. В этом окне вы можете удалить ненужные архивы.

Чтобы удалить резервные образы, нажмите кнопку Изменить параметры в окне управления пространством. Откроются параметры хранения образов.

Система предлагает вам удалить абсолютно все образы, либо все образы кроме последнего.

Рекомендации по резервному копированию

Все знают, что нужно регулярно выполнять резервное копирование, но при этом далеко не все его делают. Учитывая широкие возможности резервного копирования в Windows 7, о потере важных данных вы будете сожалеть только в том случае, если не настроите регулярную архивацию.

Для хранения резервных копий идеально подойдет отдельный жесткий диск - внутренний или внешний, подключаемый по USB или FireWire. Если в вашем распоряжении есть сетевой диск, его также можно задействовать. Хранение резервных копий на другом разделе того же диска, где установлена ОС, не является хорошей идеей. В случае выхода из строя диска вы потеряете как систему, так и резервные копии.

Поскольку резервные копии занимают немало места, я могу дать только общие рекомендации, которые вам нужно скорректировать в зависимости от имеющегося у вас свободного дискового пространства.

Образы системного раздела

  • Первый образ. Установите Windows 7, затем все обновления и драйверы. Убедившись в нормальной работе ОС и устройств, создайте первый резервный образ. Если вы "убьете" систему в ходе дальнейшей настройки и установки ПО, вы сможете вернуться к исходному состоянию быстрее, чем при переустановке.
  • Второй образ. Установите все приложения и настройте систему по своему желанию. Поскольку более тонкая настройка ОС, как правило, производится по ходу ее использования, поработайте в Windows 7 пару недель. Убедившись в нормальной работе ОС, создайте второй резервный образ. Если перед этим вы удалите первый образ, у вас будет полный образ полностью обновленной и настроенной системы с любимым набором приложений.
  • Последующие образы. В зависимости от имеющегося у вас свободного дискового пространства, создавайте последующие образы ежемесячно / ежеквартально. Если возникнет проблема, требующая восстановления из образа, вы сможете вернуться к относительно недавнему состоянию системы.

Архивы пользовательских файлов

Частота архивации ваших файлов определяется тем, насколько они ценны для вас и как часто вы добавляете или создаете новые файлы. В общем случае я рекомендую выполнять архивацию еженедельно или два раза в месяц. В сочетании с ежемесячным созданием образов системы у вас будет отличный резервный набор, позволяющий не только вернуть с систему к недавнему рабочему состоянию, но и восстановить все ваши данные и файлы, нажитые непосильным трудом. Вы всегда сможете освободить дисковое пространство, удалив старые архивы, если место на диске потребуется для других нужд.

Источник: Резервное копирование в Windows 7


secedit.exe

Местонахождение

%windir%\system32

Описание

Команды редактора конфигураций безопасности Windows

Утилита командной строки secedit служит для управления политикой безопасности, применяющейся к компьютеру. Ее основными задачами являются:

  • анализ настроек безопасности системы;
  • применение шаблонов безопасности;
  • перезагрузка политики безопасности;
  • экспорт политики безопасности в файл шаблона

Синтаксис

secedit [/configure | /analyze | /import | /export | /validate | /generaterollback]

Параметры

/configure
Указывает, что Secedit.exe задает параметры безопасности системы
/analyze
/import
/export
/validate
/generaterollback

Пример

Сбросить настройки безопасности к настройкам по умолчанию

secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose


services.exe

Местонахождение

Windows\system32

Описание

Приложение служб и контроллеров

Приложение services.exe - это диспетчер управления службами, который запускается процессом winlogon.exe до запуска графического интерфейса и отвечает за запуск, остановку и взаимодействие с системными процессами. Этот процесс нельзя завершить из менеджера задач.


sfc.exe

Местонахождение

%windir%\system32

Описание

Проверка и восстановление целостности системы

Утилита командной строки sfc.exe предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения. Программа запускается только с правами администратора. Поэтому сначала в поисковой строке вводим cmd, а затем щелкаем правой кнопкой мыши на файле cmd.exe и выбираем пункт контекстного меню Запуск от имени администратора.

Синтаксис

SFC [/SCANNOW] [/VERIFYONLY] [/SCANFILE=<файл>] [/VERIFYFILE=<файл>]
    [/OFFWINDIR=<автономная папка Windows> /OFFBOOTDIR=<автономная папка загрузки>]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /SCANNOW - Проверка целостности всех защищенных системных файлов и восстановление, по возможности, проблемных файлов
  • /VERIFYONLY - Проверка целостности всех защищенных системных файлов. Восстановление файлов не выполняется
  • /SCANFILE - Проверка целостности указанного файла и его восстановление при обнаружении проблем. В параметре <файл> следует указать полный путь
  • /VERIFYFILE - Проверка целостности файла, полный путь к которому указан в параметре <файл>. Восстановление файлов не выполняется
  • /OFFBOOTDIR - Расположение автономного каталога загрузки для автономного восстановления
  • /OFFWINDIR - Расположение автономного каталога Windows для автономного восстановления
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.


shrpubw.exe

Местонахождение

%windir%\system32

Описание

Мастер создания общих ресурсов

Запускает мастер по созданию общих ресурсов.


shutdown.exe

Местонахождение

Windows\system32

Описание

Средство завершение работы и пометок Windows

Утилита Shutdown позволяет выключать или перегружать локальный или удаленный ПК, используя командную строку или специально созданный ярлык. Простой ее вызов без каких-либо параметров обеспечивает завершение сеанса текущего пользователя. Для использования всех возможностей этой утилиты необходимо задействовать параметры командной строки, синтаксис которых таков:

shutdown [{-l|-s|-r|-a}] [-f] [-m [\\Computer Name]] [-t xx] [-c "message"] [-d[u] [p]:xx:yy]

Параметры

-l
завершение сеанса текущего пользователя. При наличии параметра -m последний имеет приоритет, то есть завершение сеанса производится для удаленного ПК
-s
выключить локальный ПК
-r
перезагрузка
-a
отмена выключения ПК, игнорируются все параметры, кроме -l и ComputerName. Данный параметр может использоваться только в тот момент, когда длится так называемый период тайм-аута, то есть когда программа Shutdown выделяет пользователю время на отмену своих действий
-f
разрешить принудительное закрытие всех работающих приложений
-m [\\ComputerName]
задать удаленный компьютер, который необходимо выключить
-t xx
задает временную задержку до вызова процедуры выключения компьютера в секундах - xx. По умолчанию используются 20 секунд
-c "message"
эта команда позволяет задать любое сообщение, которое будет отображаться в окне программы Shutdown. Максимальная длина сообщения - 127 символов. Текст сообщения необходимо заключать в кавычки
-d [u][p]:xx:yy
активирует некий специальный код выключения:
u - отображение пользовательского кода, p - отображение запланированного кода, xx - задает основной код (0-255), yy - задает дополнительный код (0-65536)
/?
отображает справочную информацию по программе


sigverif.exe

Местонахождение

%windir%\system32

Описание

Проверка подписи файла

Все входящие в состав Windows драйверы имеют цифровую подпись, свидетельствующую, что эти драйверы протестированы в лаборатории WHQL (Windows Hardware Quality Labs). Многие приложения сторонних разработчиков, предназначенные для Windows, устанавливают дополнительные драйверы, не протестированные лабораториями WHQL и, как следствие, не имеющие цифровой подписи.

Утилита «Проверка подписи файла» (sigverif.exe) служит для поиска файлов, не имеющих цифровой подписи. Список подписанных и неподписанных драйверов, обнаруженных программой Sigverif.exe, содержится в файле Sigverif.txt. Как правило, данный файл находится в папке Windows. Все неподписанные драйверы помечены как «Не подписано».


sndvol.exe

Местонахождение

%windir%\system32

Описание

Громкость

Данная программа позволяет управлять регулятором громкости звука. Эта программа заменила приложение sndvol32.exe, которая была в Windows XP.


SnippingTool.exe

Местонахождение

%systemroot%\system32

Описание

Ножницы

Программа Ножницы впервые появилась в Windows Vista и осталась в Windows 7 (версии Домашняя Расширенная (Home Premium), Профессиональная (Professional) и Максимальная (Ultimate)). Позволяет делать снимки экрана или его фрагмент, а затем снабжать его примечаниями, сохранять или использовать совместно с другими пользователями. С ее помощью можно выделить произвольную форму, окно, весь экран.

По умолчанию программа запускается в режиме создания снимка экрана. Если запустить с ключом /p, то программа будет запущена в режиме, когда сначала нужно нажать на кнопку Создать для определения типа создаваемого снимка.

Советы

Сохранить скриншот меню кнопки Пуск или контекстного меню

С помощью программы Ножницы можно сделать скриншот части экрана. Но, если вы попытаетесь сделать скриншот меню кнопки Пуск или любого контекстного меню, то меню закроется и сделать скриншот не получится. Чтобы обойти эту проблему, сделайте следующее.

  • Запустите программу Ножницы
  • Нажмите на кнопку Отмена
  • Откройте меню кнопки Пуск или контекстное меню
  • Нажмите комбинацию клавиш Ctrl + PrtScn, чтобы скопировать окно экрана в буфер обмена. Если у программмы Ножницы установлен режим Прямоугольник, то вы можете выбрать нужную часть экрана.

Запрет на запуск Ножниц

В справочнике по реестру Windows ищите совет Запрет на запуск Ножниц


solitaire.exe

Местонахождение

%ProgramFiles%\Microsoft Games\Solitaire

Описание

Исполняемый файл для игры "Косынка"

Одна из встроенных игр Windows, представляющих собой карточную игру. В Windows XP игра запускалась через sol.exe из папки Windows\system32

Начиная с Windows Vista, в пасьянсе Косынка теперь есть отмена нескольких последних операций (multiple undo). Наличие multiple undo сильно повышает вероятность успешной игры даже в самых сложных партиях. Таким образом, сотрудники в офисах будут меньше играть и больше работать :-)

Пасьянс Косынка наносит мировой экономике ущерб в размере примерно $800трлн. ежегодно, за счет потери рабочего времени.

Удаление сохраненной игры

Если вы однажды сохраните игру Косынка, то при каждом новом запуске вас постоянно будут спрашивать, не хотите ли вы продолжить сохраненную игру? Избавиться от этого сообщения встроенными средствами не получится. Чтобы решить проблему, просто удалите файл сохраненной игры в папке C:\Users\<ИмяПользователя>\Saves Game\Solitaire (Сохраненные игры | Косынка).

Кстати, о Косынке и других карточных пасьянсах. Если кто-то хочет иметь у себя 100% победную статистику по этим играм, то может воспользоваться этим же способом. То есть, если игра не сходится, ее надо сохранить и закрыть. А потом удалить вышеупомянутый файл. Тогда в статистике эта игра не будет засчитана.


soundrecorder.exe

Местонахождение

%SystemRoot%\system32

Описание

Звукозапись Windows

С помощью программы «Звукозапись» можно записать звук в звуковой файл и сохранить его на компьютере. Звук можно записывать с различных звуковых устройств (например, с микрофона), подключенных к звуковой плате компьютера. Виды источников ввода звука, с которых можно записать звук, зависят от имеющихся звуковых устройств и источников входа на звуковой плате.

В статье http://windows.microsoft.com/en-US/windows-vista/Troubleshoot-audio-recording-problems также рассказывается, как установить продолжительность записи менее чем 1 минута, а также, как записать звук не только с микрофона.


SpeechUXWiz.exe

Местонахождение

%systemroot%\System32\Speech\SpeechUX

Описание

Speech UX Configuration

Настройка распознавания речи. В русской версии Windows является бесполезной программой, так как распознавание русской речи не поддерживается, о чем и предупреждает диалоговое окно при попытке запустить программу.


StikyNot.exe

Местонахождение

%systemroot%\system32

Описание

Записки

С помощью приложения «Записки» можно создавать списки дел, записывать номера телефонов и выполнять другие действия, для которых в обычной жизни используется блокнот. Поддерживается работа как с планшетным ПК и планшетным пером, так и со стандартной клавиатурой. Более подробно о работе с программой читайте в справке.

Работа с записками

Чтобы изменить цвет записки, щелкните правой кнопкой мыши и выберите цвет.

Для создания новой записки щелкните на +? чтобы удалить - на x.

Форматирование текста

Можно выполнить форматирование текста записки. Для этого выделите изменяемый текст и выполните следующие действия

Ctrl+R | Выравнивает по правому краю
Ctrl+E | Выравнивает по центру
Ctrl+L | Выравнивает по левому краю
Ctrl+1 | Single line space
Ctrl+2 | Double line space
Ctrl+5 | 1.5 line space
Ctrl+B | Выделение полужирным шрифтом
Ctrl+I | Выделение курсивом
Ctrl+U | Подчеркивание текста
Ctrl+T | Перечеркивание текста
Ctrl+Shif+A | Переводит в верхний/нижний регистр
Ctrl+Shift+L | Создание маркированного списка (Повторное нажатие эти клавиш переключает в другие виды списков)
Ctrl+Shift+> | Увеличение размера текста
Ctrl+Shift+< | Уменьшение размера текста

Стандартные комбинации Ctrl+A, Ctrl+C, Ctrl+V также работают.

Советы

В справочнике по реестру Windows ищите совет Запрет на запуск программы Записки


svchost.exe

Местонахождение

Windows\system32

Описание

Хост-процесс для служб Windows

Это приложение, которое подгружает службы Windows, выполненые в виде библиотек DLL.

Раньше, чтобы узнать, какие службы задействованы программой Svchost.exe, нужно было использовать различные программы (например, Process Explorer). В Windows 7 это можно сделать при помощи Диспетчера задач (taskmgr.exe).

Откройте Диспетчер задач и выберите вкладку Процессы. Далее нажмите кнопку Отображать процессы всех пользователей. Теперь щелкните правой кнопкой мыши на нужном процессе svchost.exe и выберите команду Перейти к службам. Все службы, которые запущены программой svchost.exe, будут выделены.

Дополнительные материалы

Утилита Svchost Process Analyzer анализирует вашу систему, после чего выдает список запущенных копий Svchost.exe. Вы можете узнать список служб, которые используются выбранной копией Svchost.exe: имя и описание службы, ее статус, имя файла, из которого запускается служба. Кроме того, программа отмечает зеленой галочкой службы, которые не вызывают подозрений. Если вы увидите красный восклицательный знак, то следует обратить внимание на данный файл - возможно это вирус. Сама программа не требует установки.
Адрес: www.neuber.com


syskey.exe

Местонахождение

%windir%\system32

Описание

Программа запирания SAM

Утилита syskey.exe предназначена для шифровки базы данных учетных записей


sysprep.exe

Местонахождение

%systemroot%\System32\sysprep

Описание

Программа подготовки системы

Средство подготовки системы (Sysprep) - это технология, которая используется с другими средствами развертывания для установки операционных систем Windows на новое оборудование. Программа Sysprep подготавливает компьютер к созданию образа диска или к доставке компьютера заказчику, создавая новый идентификатор безопасности (SID) при перезапуске компьютера. Кроме того программа Sysprep очищает параметры пользователя и системы, а также данные, которые не должны быть записаны на конечный компьютер.

Синтаксис

sysprep.exe [/oobe | /audit] [/generalize] [/reboot | /shutdown | /quit] [/quiet] [/unattend:файл_ответов]

Параметры

/audit
Запускает компьютер в режиме аудита. Режим аудита позволяет добавлять дополнительные драйверы устройств и приложения. Можно также проверить установку Windows перед доставкой ее конечному пользователю. Если была указана автоматическая установка Windows, режим аудита запускает этап настройки auditSystem и auditUser.
/generalize
Подготавливает установку Windows перед созданием образа. Если этот параметр указан, все уникальные системные сведения удаляются из установки Windows. Идентификатор безопасности (SID) обнуляется, точки восстановления системы сбрасываются, журналы событий удаляются. Во время следующего запуска компьютера начинает работать специализированный этап настройки. Создается новый идентификатор безопасности (SID) и сбрасываются часы активации Windows, если они еще не были сброшены трижды.
/oobe
Запускает компьютер в режиме экрана приветствия. Экран приветствия Windows позволяет конечным пользователям настраивать операционную систему Windows, создавать новые учетные записи, переименовывать компьютер и выполнять другие задачи. Любые задачи этапа настройки oobeSystem в файле ответов обрабатываются незамедлительно, еще до запуска экрана приветствия.
/reboot
Перезагружает компьютер. Используйте этот параметр для аудита компьютера и проверки работоспособности первого запуска системы
/shutdown
Завершает работу компьютера после завершения работы программы Sysprep
/quiet
Отключает отображение запросов на подтверждение во время работы программы Sysprep. Используйте этот параметр при автоматической работе Sysprep
/quit
Закрывает Sysprep после выполнения указанных команд
/unattend: файл_ответов
Применяет настройки файла ответов к Windows во время автоматической установки
файл_ответов
Указывает имя и путь к используемому файлу ответов

Дополнительные сведения

Что такое Sysprep?

Как работает программа Sysprep

Поддержка Sysprep для ролей сервера

Настройка профилей пользователей по умолчанию в Windows 7 и Windows Server 2008 R2


systeminfo.exe

Местонахождение

Windows\system32

Описание

Сведения о системе/System Information

Выводит на экран подробные сведения о конфигурации компьютера и операционной системы, сведения о безопасности, код продукта и параметры оборудования, такие как ОЗУ, дисковое пространство и сетевые карты.

Синтаксис

systeminfo[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh]

Описание параметров есть в справке Windows.

Пример

Чтобы узнать время непрерывной работы Windows7, запустите команду (для русской версии):

systeminfo | find "Время загрузки системы"

После нажатия на клавишу Enter на экране появится информация о времени последней загрузки Windows. Для английской версии используйте "System Boot Time".


SystemPropertiesAdvanced.exe

Местонахождение

%windir%\system32

Описание

Дополнительные параметры системы

Выводит на экран диалоговое окно Свойства системы на вкладке Дополнительно. Может использоваться программистами в своих целях.

Смотри также

SystemPropertiesComputerName.exe, SystemPropertiesHardware.exe


SystemPropertiesComputerName.exe

Местонахождение

%windir%\system32

Описание

Изменение параметров компьютера

Выводит на экран диалоговое окно Свойства системы на вкладке Имя компьютера. Может использоваться программистами в своих целях.

Смотри также

SystemPropertiesAdvanced.exe, SystemPropertiesHardware.exe


SystemPropertiesDataExecutionPrevention.exe

Местонахождение

%windir%\system32

Описание

Изменение параметров предотвращения выполнения данных (DEP)

Выводит на экран диалоговое окно Параметры быстродействия.


SystemPropertiesHardware.exe

Местонахождение

%windir%\system32

Описание

Параметры настройки оборудования

Выводит на экран диалоговое окно Свойства системы на вкладке Оборудование. Может использоваться программистами в своих целях.

Смотри также

SystemPropertiesAdvanced.exe, SystemPropertiesComputerName.exe


SystemPropertiesPerformance.exe

Местонахождение

%windir%\system32

Описание

Изменение параметров производительности компьютера

Выводит на экран диалоговое окно Параметры быстродействия на вкладке Визуальные эффекты.


SystemPropertiesProtection.exe

Местонахождение

%windir%\system32

Описание

Параметры защиты системы

Выводит на экран диалоговое окно Свойства системы на вкладке Защита системы. Может использоваться программистами в своих целях.

Смотри также

SystemPropertiesAdvanced.exe, SystemPropertiesComputerName.exe, SystemPropertiesHardware.exe


SystemPropertiesRemote.exe

Местонахождение

%windir%\system32

Описание

Параметры удаленного доступа к системе

Выводит на экран диалоговое окно Свойства системы на вкладке Удаленный доступ. Может использоваться программистами в своих целях.

Смотри также

SystemPropertiesAdvanced.exe, SystemPropertiesComputerName.exe, SystemPropertiesHardware.exe, SystemPropertiesProtection.exe


tabcal.exe

Местонахождение

%windir%\System32

Описание

Средство калибровки дигитайзера

С помощью данной утилиты можно настроить калибровку дигитайзера. Несмотря на наличие этой программы в составе Windows 7, она запустится только в том случае, если у вас есть дигитайзер. В противном случае выводится соответствующее диалоговое окно с предупреждением.


takeown.exe

Местонахождение

%windir%\System32

Описание

Назначение владельца файла

Утилита командной строки, позволяющая администратору восстанавливать доступ к файлу, если он ранее был запрещен, путем назначения администратора владельцем файла. Команда обычно используется в пакетных файлах.

Синтаксис

takeown [/s компьютер [/u [домен\пользователь [/p [пароль]]]] /f имя_файла [/a] [/r] [/d {Y | N}]

Параметры

/s компьютер
Указывает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер. Данный параметр применяется для всех файлов и папок, указанных в этой команде.
/u домен\пользователь
Выполняет сценарий с разрешениями указанной учетной записи пользователя. По умолчанию используются системные разрешения
/p [пароль]
Пароль учетной записи пользователя, заданный в параметре /u
/f имя_файла
Указывает имя файла или имя шаблона папки. Для указания шаблона можно использовать подстановочный знак «*». Также можно использовать параметр сетевое_имя\имя_файла
/a
Делает владельцем группу администратора вместо текущего пользователя
/r
Выполняет рекурсивную операцию со всеми файлами в указанной папке или подпапке
/d {Y | N}
Запрос по умолчанию используется, если текущий пользователь не имеет разрешения для просмотра папок в каталоге. Используйте команду Y для получения прав владения и команду N для запрета выдачи запроса на подтверждение

Примечания

Для выполнения данной процедуры необходимо входить в группу "Администраторы" на локальном компьютере или получить соответствующие полномочия путем делегирования. Если компьютер присоединен к домену, эту процедуру могут выполнять члены группы "Администраторы домена". При этом по соображениям безопасности рекомендуется использовать команду Запуск от имени.

Параметры командной строки /u и /p доступны только при использовании параметра /s. Для ввода пароля пользователя необходимо использовать параметры /p и /u.

Если параметр /a неопределен, текущий пользователь системы становится владельцем файла.

Смешанные шаблоны, использующие вопросительный (?) и подстановочный (*) знаки, не поддерживаются.

После удаления блокировки с помощью команды takeown можно использовать Windows Explorer или команду cacls для получения полного разрешения доступа к файлам и папкам перед их удалением.

Примеры

Для получения прав владения файлом, использующим имя шаблона Lostfile, введите:

takeown /f lostfile

Дополнительную информацию о программе ищите на сайте Technet. А также вы можете прочитать в блоге Техноблог случаи применения этой утилиты.


taskkill.exe

Местонахождение

%windir%\system32

Описание

Принудительное завершение процесса

Завершает одно или несколько заданий или процессов. Процессы могут быть уничтожены кодом процесса или именем образа.

Синтаксис

taskkill [/s компьютер] [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/pid код_процесса]|[/im имя_образа] [/f][/t]

Описание параметров есть в справке Windows


tasklist.exe

Местонахождение

%windir%\system32

Описание

Задачи

Отображает список приложений и служб с кодом процесса (PID) для всех задач, выполняющихся на локальном или удаленном компьютере.

Синтаксис

tasklist[.exe] [/s компьютер] [/u домен\пользователь [/p пароль]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi фильтр [/fi фильтр2 [ ... ]]] [/m [модуль] | /svc | /v]

Описание параметров есть в справке Windows

Чтобы получить список идентификаторов запущенных процессов, введите следующую команду:

tasklist > d:\tasklist.txt

Добавьте в команду параметр /svc, чтобы составить перечень служб, которые загружаются каждым процессом:

tasklist /svc > d:\tasklist.txt

Этот способ может понадобиться, если, например, Диспетчер задач будет недоступен и вы не сможете посмотреть список запущенных процессов.


taskmgr.exe

Местонахождение

%windir%\system32

Описание

Диспетчер задач Windows

Описание программы есть в справке Windows.

Советы

Четыре способа запуска программы

Запустить программу можно разными способами:

  • В строке поиска кнопки [image] набрать имя файла taskmgr.exe
  • Одновременно нажать комбинацию из трех клавиш Ctrl+Alt+Del и выбрать пункт Запустить диспетчер задач
  • Нажать комбинацию клавиш Ctrl+Shift+Esc
  • Щелкнуть правой кнопкой мыши на панели задач и выбрать команду Запустить диспетчер задач

Вывод полного пути запущенных процессов

По умолчанию, диспетчер задач не показывает полные пути и аргументы командной строки запущенных процессов. Запустите Диспетчер задач и выберите в меню Вид | Выбрать столбцы... Отметьте галочкой пункты:

  • Путь к образу
  • Командная строка

Также вы можете выбрать и другие нужные вам команды.

Открыть во все окно

Откройте Диспетчер задач, дважды шелкните левой кнопкой мыши по серой области окна чуть ниже меню и она развернется на все окно. Чтобы вернуть все назад, кликните еще два раза по бортику окна.

Реестр

Запрет на запуск Диспетчера задач


timeout.exe

Местонахождение

Windows\System32

Описание

Таймаут - приостановка обработки команд

Принимает значение таймаута, задающего фиксированный период времени ожидания (в секундах), или ожидание до нажатия клавиши. Имеется также параметр, зaдающий игнорирование нажатий клавиш.

Вы можете воспользоваться программой timeout.exe, чтобы установить автоматическое завершение сценария только через указанный промежуток времени. Например, команда вида timeout /T 5 отобразит в командной строке строку обратного отсчета. После окончания количества указанных в команде секунд (или после нажатия пользователем любой клавиши) работа программы timeout.exe будет завершена (а вместе с ней и работа сценария, если это последняя команда в сценарии).

Синтаксис

timeout [/T] <таймаут> [/NOBREAK]

Параметры

/T <таймаут>
Время ожидания в секундах. Допустимый интервал: от -1 до 99999 секунд. Значение таймаута, равное -1 задает неограниченное время ожидания до нажатия клавиши.
/NOBREAK
Игнорировать нажатия клавиш, ждать указанное время.
/?
Вывод справки

Примеры

timeout /T 10
timeout /T 300 /NOBREAK


tracert.exe

Местонахождение

Windows\system32

Описание

Команда трассировки маршрутов TCP/IP

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Например, чтобы вывести трассу маршрута к http://www.microsoft.com, нужно набрать:

C:\>tracert www.microsoft.com

Запущенная без параметров, команда tracert выводит справку

Синтаксис

tracert [-d] [-h максимальное_число_переходов] [-j список_узлов] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows


tzutil.exe

tzutil.exe (Windows 7)

Местонахождение

Windows\System32

Описание

Программа Windows Time Zone

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.

Синтаксис

TZUTIL <? : /y : /s TimeZoneID[_dstoff] : /l>

Параметры

/?
Выводит справочную информацию
/g
Выводит текущие установки временной зоны
/s TimeZoneID[_dstoff]
Устанавливает временную зону, используя заданный идентификатор временной зоны. Суффик _dstoff позволяет не использовать переход на летнее время
/l
Выводит список всех возможных временных зон

Примеры

tzutil /g
tzutil /s "Pacific Standard Time"
tzutil /s "Pacific Standart Time_dstoff"

Если код выхода равен 0, то команда отработала успешно.


utilman.exe (Центр специальных возможностей)

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Центр специальных возможностей

Описание

Диспетчер служебных программ

utilman.exe запускает компонент Панели управления Центр специальных возможностей


UserAccountControlSettings.exe

Местонахождение

%windir%\System32

Описание

UserAccountControlSettings

Программа выводит окна Параметры управления учетными записями пользователей


verifier.exe

Местонахождение

Windows\system32

Описание

Диспетчер проверки драйверов

Для проверки того, насколько корректно работают драйверы в Windows XP, существует специальная утилита verifier.exe. Запустив ее, вы увидите специальный мастер. В первом окне оставьте выделенный по умолчанию пункт Создать стандартные параметры (Create Standard Settings), далее можно выбрать проверку неподписанных драйверов. После того как система выявит такие драйверы, вам необходимо лишь нажать Finish и перезагрузить ПК. Если в процессе загрузки какой-то из этих драйверов начнет сбоить, то вы увидите синий экран с упоминанием файла, вызвавшего проблему. После теста отключите эту утилиту, используя команду

verifier /reset

Кстати, вывести весь список установленных драйверов в виде файла, пригодного для отображения в Excel, можно такой командой:

Driverquery /v /fo csv > drivers.csv.

Параметры командной строки

Средство Verifier.exe можно запускать из командной строки (чтобы получить дополнительные сведения, введите в командной строке

verifier.exe /?

Ниже перечислены основные параметры командной строки, поддерживаемые данным средством

verifier.exe /flags флаг [/iolevel 2]
Задает в десятичном виде значение флагов проверки драйверов, позволяет указывать уровень проверки ввода-вывода (чтобы ознакомиться со списком доступных флагов, выполните в командной строке команду verifier.exe /?
verifier.exe /all
Проверять все драйверы в системе
verifier.exe /volatile /flags флаг
Изменить флаги немедленно.
verifier.exe /reset
Сбросить все параметры проверки драйверов
verifier /query
Вывести текущее состояние проверки драйверов и значения счетчиков на стандартное устройство вывода
verifier.exe /log ИМЯ_ФАЙЛА_ЖУРНАЛА [/intervalколичество_секунд]
Сохранить состояние и значения счетчиков проверки драйверов в файле журнала (где количество_секунд – заданный интервал времени).

Дополнительные материалы

Использование средства проверки драйверов для устранения неполадок в работе драйверов Windows (23 августа 2005, версия 5.1)

How to Use Driver Verifier to Troubleshoot Windows Drivers (1 марта 2007, версия 5.3)


vssadmin.exe

Местонахождение

Windows\system32

Описание

Интерфейс командной строки для Microsoft® Volume Shadow Copy Service

Утилита командной строки для теневого копирования тома.

Синтаксис

vssadmin [List Providers] [List Shadows] [List ShadowStorage] [List Volumes] [List Writers] [Resize ShadowStorage]

Параметры

List Providers
List Shadows
List ShadowStorage
Просмотр сведений об используемом и доступном дисковом пространстве
List Volumes
List Writers
Resize ShadowStorage
Для изменения максимального дискового пространства, которое будет использоваться для создания теневых копий и точек восстановления используйте vssadmin Resize Shadowstorage /on=[диск]: /for=[диск]: /maxsize=[значение]. Параметры [диск] и [значение] нужно заменить на соответствующие значения - букву диска и объем.Значение параметра MaxSizeSpec должно быть не меньше 300MB. Значение этого параметра поддерживает такие суффиксы: KB, MB, GB, TB, PB и EB. Если суффикс не будет определен, то автоматически он определяется в байтах

Примеры

Определить доступное дисковое пространство для теневых копий на диске С: в размере 2 ГБ

vssadmin resize shadowstorage /for=c: /on=c: /maxsize=2GB

Определить доступное дисковое пространство для теневых копий на диске С: в размере 700 МБ

vssadmin resize shadowstorage /for=c: /on=c: /maxsize=700MB


w32tm.exe

Местонахождение

WINDOWS\System32

Описание

Диагностика службы времени Windows

Используется для определения причины неполадок, связанных со службой времени Windows. Средство предназначено для системных администраторов для определения причин неполадок, связанных со временем системы Windows.

Синтаксис

{/config [/computer:имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков] ]|/monitor|/ntte|/ntpte|/register|/resync [{:имя_компьютера] [/nowait]|[/rediscover}]|/tz|/unregister}

Параметры

/config [/computer: имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков]
Выполняет согласование настроек времени на локальном и конечном компьютере. Одинаковое время синхронизации можно задать с помощью ключа /manualpeerlist. Изменения конфигурации не учитываются, пока не перезапустится служба времени Windows или не будет использован ключ /update. Ключ /syncfromflags применяется, чтобы задать типы источников синхронизации, и может быть установлен либо MANUAL для использования списка узлов, заданного вручную, или DOMHIER для синхронизации с контроллера домена.
/monitor
Осуществляет наблюдение за конечным компьютером или списком компьютеров.
/ntte
Преобразует системное время NT в читаемый формат.
/ntpte
Преобразует время NTP в читаемый формат.
/register
Регистрирует запуск службы и добавляет стандартную конфигурацию в реестр.
/resync [{:имя_компьютера] [/nowait]|[/rediscover}]
Ресинхронизирует часы по мере возможности, не обращая внимания статистику накопленных ошибок. Если не указан компьютера, ресинхронизирован будет локальный компьютер. Ресинхронизация не выполняется без использования ключа /nowait. Текущие источники времени используются до тех пор, пока не введен ключ /rediscover, который выполняет принудительное повторное обнаружение сетевых ресурсов перед ресинхронизацией.
/tz
Отображает текущую настройку часового пояса
/unregister
Отменяет регистрацию службы и удаляет сведения о конфигурации из реестра.
/?
Отображает справку в командной строке.

Чтобы служба времени Windows использовала изменения, выполненные с помощью команды W32tm, необходимо оповестить службу. Чтобы оповестить службу времени Windows, в командной строке введите: w32tm /config /update

Примеры

Чтобы отобразить текущую настройку часового пояса, введите команду:

w32tm /tz


wab.exe

Местонахождение

Program Files\Windows Mail

Описание

Windows Contacts


WFS.exe

Местонахождение

%windir%\system32

Описание

Microsoft Windows Fax and Scan

Запускает программу Факсы и сканирование Windows.


wbadmin.exe

Местонахождение

Windows\System32

Описание

Интерфейс командной строки для Microsoft® BLB Backup

С помощью программы командной строки wbadmon.exe можно выполнять множество задач по архивированию и восстановлению файлов как локального, так и удаленного компьютера.

Поддерживаемые команды

START BACKUP
запускает выполнение однократной архивации.
STOP JOB
останавливает текущую операцию архивации или восстановления.
GET VERSIONS
просмотр сведений об архивах, доступных в заданном расположении, которые можно использовать при выполнении операций восстановления.
GET ITEMS
отображение списка элементов, содержащихся в архиве.
GET STATUS
отображение состояния текущей операции.


wbemtest.exe

Местонахождение

%systemroot%\System32\wbem

Описание

Средство проверки WMI

Тестер WMI (wbemtest.exe) — это графическая утилита, с помощью которой можно взаимодействовать с инфраструктурой WMI на локальном или удаленном компьютере. С помощью тестера WMI можно решать следующие задачи:

  • подсоединяться к определенному пространству имен CIM;
  • создавать и удалять классы и экземпляры классов;
  • получать список имеющихся классов и экземпляров классов CIM;
  • просматривать и изменять свойства и квалификаторы классов или экземпляров классов;
  • выполнять методы классов и экземпляров классов;
  • составлять и выполнять запросы на языке WQL;
  • выводить код MOF для классов и экземпляров управляемых ресурсов

Дополнительные сведения

Scripting Eye for the GUI Guy: WBEMTEST (на англ.)

Структура классов WMI (на рус.)


wercon.exe

Местонахождение

Windows\system32

Описание

Отчеты о проблемах и их решениях (Windows Vista)

Программа для решения различных проблем. Например, в ней можно отключить посылку отчетов при возникновении проблем с зависшей программой. В открывшемся окне утилиты нажмите на ссылке Изменить параметры - Дополнительные параметры и, используя верхний блок настроек, деактивировать отправку отчётов о программных ошибках. Здесь же, в поле "Список блокировок" пользователю предоставляется возможность скорректировать появление уведомлений об ошибках для определенной группы приложений.


whoami.exe

Местонахождение

Windows\system32

Описание

whoami - Отображение информации о вошедшем в систему пользователе

Эту программу командной строки можно использовать для получения сведений об имени пользователя и группе, а также о соответствующих идентификаторах безопасности (SID), привилегиях, идентификаторах входа (ID) текущего пользователя (маркере доступа) на локальном компьютере, т.е. для определения текущего пользователя. Если параметр не указан, имя пользователя отображается в формате NTLM (домен\пользователь). Раньше эта утилита распространялась отдельно от операционной системы.

Синтаксис

Синтаксис 1:
    WHOAMI [/UPN | /FQDN | /LOGONID]
Синтаксис 2:
    WHOAMI { [/USER] [/GROUPS] [/PRIV] } [/FO <формат>] [/NH]
Синтаксис 3:
    WHOAMI /ALL [/FO <формат>] [/NH]

Параметры:

/UPN
Отображение имени пользователя в формате имени участника-пользователя (UPN).
/FQDN
Отображение имени пользователя в формате полного доменного имени (FQDN).
/USER
Отображение сведений о текущем пользователе вместе с идентификатором безопасности (SID).
/GROUPS
Отображение для текущего пользователя членства в группах, типа учетной записи, идентификаторов безопасности (SID) и атрибутов.
/PRIV
Отображение привилегий безопасности текущего пользователя.
/LOGONID
Отображение идентификатора текущего пользователя.
/ALL
Отображение имени пользователя, членства в группах, идентификаторов безопасности (SID) и привилегий для маркера доступа текущего пользователя.
/FO <формат>
Формат вывода. Допустимые значения TABLE, LIST, CSV. Заголовки столбцов в формате CSV не отображаются. Формат по умолчанию: TABLE.
/NH
Указывает, что строка заголовков столбцов не отображается при выводе. Допускается только для форматов TABLE и CSV.
/?
Вывод справки по использованию.

Примеры

Получить информацию о маркере процесса

whoami /fo list /all

Как работает утилита

Источник: http://www.osp.ru/win2000/2007/06/4365454/

Чтобы увидеть Whoami в действии, нужно войти в Vista с учетной записью администратора, открыть командную строку и набрать команду:

whoami /all

Эта команда обеспечит отображение пользовательского имени, SID, групп, к которым принадлежит зарегистрировавшийся пользователь (с указанием их SID), и привилегий его учетной записи. Однако при регистрации в системе Vista в качестве администратора приложение UAC генерирует не один, а два маркера: административный — administrative token (AT), с данными об административной групповой принадлежности пользователя и привилегиях, и стандартный — standard user token (SUT), без каких-либо административных прав.

При запуске программы Vista, используя набор критериев, решает, следует ли снабдить эту программу «всемогущим» маркером AT или «бесправным» SUT. Если система не докучает вам диалоговыми окнами Continue/Cancel, это означает, что программе, вероятно, назначен маркер SUT. И, поскольку в данном случае диалоговое окно Continue/Cancel не отображается, командная строка имеет маркер SUT. Для проверки можно удостовериться, что ваша административная групповая принадлежность не указана, а есть лишь комментарий, согласно которому ваше членство в группе «Администраторы» запрещено — Group used for deny only.

Если открыть другое командное окно, но сначала щелкнуть правой клавишей мыши на пиктограмме Command Prompt и выбрать Run as administrator, чтобы выполнить ту же команду от имени администратора, система выдаст информацию о вашей полной групповой принадлежности со значительно большими привилегиями, чем в «бесправном» командном окне с маркером SUT. Кстати, если вас утомляет просмотр длинных разорванных строк, выводимых в стандартном командном окне, попробуйте использовать более удобный для чтения вариант при помощи команды:

whoami /all /fo list

Можете также после /fo набрать table (что дает наблюдаемый ранее вывод рваных строк) или csv (вывод готовых к импорту значений, разделенных запятыми (CSV)). Чтобы сократить объем выводимой информации, нужно заменить /all на /user, дабы вывести только пользовательское имя и SID, на /groups — только групповую принадлежность или на /priv — только пользовательские привилегии.

Когда у вас есть два открытых командных окна — одно с маркером AT (в названии этого окна есть слово «administrator»), а другое с маркером SUT — наберите команду

whoami /groups /fo list

для вывода вашей групповой принадлежности. При этом следует отметить в административном окне принадлежность к странной группе: Whoami выдает SID неизвестного типа S-1-16-12288 и имя группы Mandatory Label\High Mandatory Level. Именно здесь обнаруживает свое действие механизм WIC (прежнее название — Mandatory Integrity Control (MIC)).

Vista распределяет пользовательские учетные записи, процессы и объекты (например, файлы и папки) по нескольким уровням, которые можно было бы назвать «уровнями доверия», но в Vista используется название integrity (целостность). Предусмотрены уровни untrusted, low, medium, high, system и trusted installer. Эта тема слишком о бширна для данной статьи, поэтому скажу лишь, что любая попытка процесса изменить объект, имеющий более высокий уровень целостности, оказывается неудачной, даже если маркер процесса предполагает уровень доступа Full Control к объекту. По умолчанию Vista присваивает стандартным пользователям уровень целостности medium, а администраторам — уровень high. Упомянутый ранее уровень High Mandatory Level указывает на то, что маркер административного командного окна имеет уровень целостности high. В другом командном окне в списке Whoami /groups /fo обнаруживается уровень целостности medium.


wiaacmgr.exe

Местонахождение

%windir%\system32

Описание

Мастер загрузки изображений Windows

Если у вас не установлен сканер, то программа не запустится, а выведет предупреждающее окно.


WindowsPhotoGallery.exe

Местонахождение

%programfiles%\Windows Photo Gallery\

Описание

Фотоальбом Windows

Эта программа заменила бывшую Программу просмотра изображений и факсов. Новая программа имеет дополнительные возможности: просмотр изображений и видеофайлы в папке Изображения и Видео, а также применять некоторые эффекты. Также возможен просмотр в виде слайд-шоу.


winlogon.exe

Местонахождение

Windows\System32

Описание

Программа входа в систему Window

WINLOGON.EXE - процесс, ответственный за начало (logon) сеанса и завершение сеанса (logoff) пользователя. Процесс активируется только после нажатия кнопок CTRL+ALT+DEL и демонстрирует окно для ввода пароля.


winmsd.exe

Местонахождение

WINDOWS\system32

Описание

Сведения о системе

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Данная программа позволяет быстро собрать необходимые данные.

К программе прилагается справка, в которой вы найдете дополнительную информацию.


wmic.exe

Местонахождение

WINDOWS\system32\wbem

Описание

WMI Commandline Utility

Утилита командной строки wmic.exe собирает информацию из Инструментария управления Windows WMI (Windows Management Instrumentation) для локального администратора

Описание параметров есть в справке Windows. Вот небольшой скрипт для определения имени компьютера, версии операционной системы и номера сервис-пака:

@echo off
setlocal
for /f %%v in ('wmic os get version /value^|find "Version"') do set %%v
if "%Version:~0,4%" NEQ "5.1." goto finish
for /f %%v in ('wmic os get servicepackmajorversion /value^|find "ServicePackMajorVersion"') do set %%v
if "%ServicePackMajorVersion%" LSS "2" goto finish
@echo %computername% %Version% %ServicePackMajorVersion%
:finish
endlocal

Примеры

Запустите командную строку и введите для получения названия модели компьютера или его серийного номера:
wmic csproduct get name

Или его серийного номера, получаемого из BIOS
wmic bios get serialnumber

Как убедиться, что аппаратная функция DEP работает в Windows

Чтобы убедиться, что аппаратная функция DEP работает в Windows, введите следующую команду

wmic OS Get DataExecutionPrevention_Available

Если в результате будет получено значение TRUE, аппаратная функция DEP включена.

Определить текущую политику поддержки DEP

В командной строке введите следующую команду:

wmic OS Get DataExecutionPrevention_SupportPolicy

В результате выполнения команды будет возвращено значение 0, 1, 2 или 3. Эти значения соответствуют политикам поддержки DEP, описанным в приведенной ниже таблице.

Значение свойства DataExecutionPrevention_SupportPolicy | Уровень политики | Описание
2 | OptIn (конфигурация по умолчанию) | Функция DEP включена только для системных компонентов и служб Windows
3 | OptOut | Функция DEP включена для всех процессов. Администратор может вручную создать список приложений, для которых функция DEP отключена
1 | AlwaysOn | Функция DEP включена для всех процессов
0 | AlwaysOff | Функция DEP отключена для всех процессов

В справке Windows есть несколько статей о данной программе.


wmplayer.exe

Местонахождение

Program Files\Windows Media Player

Описание

Проигрыватель Windows Media


wordpad.exe

Местонахождение

%ProgramFiles%\Windows NT\Accessories\wordpad.exe

Описание

Текстовый редактор Wordpad Windows

В Windows 7 интерфейс и функционал редактора был значительно изменен и переработан. Текстовый редактор WordPad позволяет сохранять документы в следующих форматах:

Тип файла | Расширение Описание
Файл *.rtf | Сохранение документа в формате RTF
Файл *.docx | Сохранение документа в формате Office Open XML (формат Microsoft Word 2007)
Файл *.odt | Сохранение документа в формате Open Document (формат Open Office)
Файл *.txt | Сохранение документа в виде обычного текста. Можно сохранять текст в DOS-кодировке и Юникод


write.exe

Местонахождение

%ProgramFiles%\Windows NT\Accessories\wordpad.exe

Описание

Текстовый редактор Wordpad Windows

Данная программа является псевдонимом для текстового редактора Wordpad. На самом деле файла write.exe на диске даже не существует, хотя поиск и показывает наличие такого файла.


wscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Windows Based Script Host

Сервер сценариев wscript.exe является GUI-вариантом, предназначенный для взаимодействия с пользователем через диалоговые окна Windows (в отличии от консольного приложения cscript.exe). С помощью сервера сценариев можно изменять реестр без вывода диалоговых окон, удалять и создавать файлы, многое другое.

Уникальная возможность - можно удалить файл скрипта до завершения его работы. То есть, скрипт сидит в памяти, а самого файла уже давно нет. Используя эту возможность можно создать так называемый скрипт-призрак.

Чтобы запустить написанный скрипт, можно просто дважды щелкнуть левой кнопкой мыши по нему в окне проводника. При этом сценарий запустится с настройками по умолчанию. Чтобы сценарий работал с другими параметрами, нужно в командной строке указать имя сервера сценариев, имя самого сценария и параметры запуска.

Синтаксис

wscript имя_сценария.расширение [параметры...] [аргументы...]

Чтобы получить полный список параметров, используйте wscript /?

Однако, такой вариант запуска изменит параметры по умолчанию для всех запускаемых впоследствии сценариев. Если в этом нет необходимости, есть возможность задать свои параметры для каждого отдельного файла сценария, более того, можно задать несколько вариантов запуска одного и того же сценария. Для этих целей служит файл с расширением wsh. Он представляет собой обычный текстовый файл и по своей структуре очень похож на inf или ini файл. Чтобы создать простейший *.wsh файл откройте свойства любого скрипта и на вкладке "Сценарий" измените любой параметр. После нажатия на "OK" в том же каталоге появится файл с аналогичным именем и расширением wsh. Вот пример одного из таких файлов:

[ScriptFile]
Path=G:\files\p010.js
[Options]
Timeout=0
DisplayLogo=1

В секции [ScriptFile] есть только один параметр - Path, который указывает на запускаемый скрипт, в секции [Options] перечисляются параметры для запуска этого скрипта.

Если теперь запустить созданный нами файл, он будет выполняться с настроенными параметрами.

Возможность указания параметров при старте сценариев является, безусловно, очень полезной и позволяет более тонко контролировать процесс работы скрипта.


xcopy.exe

Местонахождение

Windows\system32

Описание

Extended Copy Utility

Утилита командной строки для копирования файлов и папок.

Синтаксис

XCOPY источник [результат] [/A|M] [/D[:дата]] [/I] [/P] [/S[/E]] [/W] [/C] [/Q] [/F] [/L] [/H] [/R] [/T] [/U] [/K] [/Y|/-Y] [/N] [/V] [/G] [/O] [/X] [/Z]

Параметры

источник
Обязательный параметр. Задает местонахождение и имена файлов для копирования. Параметр должен задавать или диск, или путь.
результат
Задает место, куда будут скопированы файлы. Параметр может включать имя диска с двоеточием, имя каталога, имя файла или их комбинацию.
/A
Копирует только те файлы, которые имеют установленный атрибут архивный. При использовании параметра /a атрибут архивный у исходных файлов не меняется.
/M
Копирует только те файлы, которые имеют установленный атрибут «архивный». В отличие от параметра /a, параметр /m очищает атрибут «архивный» у скопированных файлов.
/D[:дата]
Копирует только файлы, измененные не ранее заданной даты. Если параметр дата не указан, то команда xcopy копирует только файлы-источники, которые новее существующих файлов-результатов. Эта возможность позволяет обновлять только измененные файлы.
/I
Если источником является каталог или источник содержит подстановочные знаки и результат не существует, команда xcopy считает, что результат - это имя каталога, и создает новый каталог. Затем xcopy копирует все указанные файлы в новый каталог. По умолчанию команда xcopy запрашивает подтверждение, является ли параметр результат каталогом или файлом.
/P
Запрашивает подтверждение при создании каждого файла-результата.
/S
Копирует каталоги и подкаталоги, если они не пусты. Если параметр /s не задан, команда xcopy будет работать только с одним каталогом.
/E
Копирует все подкаталоги, включая пустые. Параметр /e используется с параметрами /s и /t.
/W
Выводит сообщение с ожиданием подтверждения начала копирования:
Нажмите любую клавишу, чтобы начать копирование файлов
/C
Игнорирует ошибки.
/Q
Отменяет вывод на экран сообщений команды xcopy.
/F
Выводит имена исходных файлов и файлов-результатов в процессе копирования.
/L
Отображает список копируемых файлов, но само копирование не происходит.
/H
Копирует системные и скрытые файлы. По умолчанию команда xcopy не копирует системные и скрытые файлы.
/R
Копирует файлы с атрибутом Только для чтения
/T
Копирует только структуру подкаталога (т. е. дерево), а не файлы. Для копирования пустых каталогов следует задать ключ /e.
/U
Копирует (обновляет) только те файлы-источники, которые уже существуют в каталоге результата.
/K
Копирует файлы с атрибутом «только для чтения» с сохранением этого атрибута для скопированных файлов, оригиналы которых имеют этот атрибут. По умолчанию команда xcopy удаляет атрибут «только для чтения».
/Y
Устраняет выдачу запроса на подтверждение перезаписи существующего конечного файла.
/-Y
Выдает запрос на подтверждение перезаписи существующего конечного файла.
/N
Копирует с использованием коротких имен файловой системы NTFS. Параметр /n требуется при копировании из файловой системы NTFS в файловую систему FAT или когда на диске-результате требуется использование соглашения об именах файлов как в файловой системе FAT (8.3). Файлы могут записываться в файловую систему FAT или NTFS.
/V
Проверяет каждый скопированный файл на соответствие его оригиналу.
/G
Создает незашифрованные файлы-результаты.
/O
Копирует сведения о принадлежности файлов и избирательной таблице управления доступом (DACL).
/X
Копирует сведения о параметрах аудита файла и системной таблице управления доступом (SACL).
/Z
Копирует по сети в режиме перезапуска. Если во время фазы копирования теряется сетевое подключение (например, если сервер переходит автономный режим, разрывая подключение), копирование возобновляется после восстановления подключения. Использование параметра /z команды вызывает также отображение доли (в процентах) завершенной операции копирования для каждого файла.
/?
Выводит справку.

Примечание

  • Сравнение команд xcopy и diskcopy

    Команда xcopy должна быть использована вместо diskcopy при копировании файлов и подкаталогов на диск другого формата. Так как команда diskcopy копирует диски по дорожкам, требуется, чтобы исходный диск и диск-результат имели одинаковый формат. Для команды xcopy это требование не нужно. Обычно следует использовать команду xcopy, если только не требуется получить два диска с одинаковыми образами.

  • Коды завершения программы xcopy

    При использовании команды xcopy внутри пакетных файлов можно анализировать ее код завершения, который позволяет определить причину завершения выполнения программы. В следующей таблице перечислены коды завершения с кратким описанием.

Код завершения | Описание
0 | Файлы скопированы без ошибок
1 | Файлы для копирования не найдены
2 | Нажата комбинация CTRL+C для остановки команды xcopy
4 | Возникла ошибка инициализации. Недостаточно места в памяти или на диске, введено неверное имя диска или неверный синтаксис вызова команды
5 | Диск защищен от записи

Примеры

Чтобы копировать все файлы и подкаталоги (включая пустые подкаталоги) с диска A на диск B, введите:

xcopy a: b: /s /e

Чтобы включить в операцию копирования предыдущего примера системные и скрытые файлы следует использовать параметр /h:

xcopy a: b: /s /e /h

Чтобы обновить файлы в каталоге \Reports файлами из каталога \Rawdata, измененными после 29 декабря 1993 года, введите:

xcopy \rawdata \reports /d:29-12-1993

Чтобы обновить файлы предыдущего примера, уже существующие в каталоге \Reports, независимо от их даты, введите следующую команду:

xcopy \rawdata \reports /u

Чтобы получить списк файлов, которые были бы скопированы в предыдущем примере, следует ввести команду:

xcopy \rawdata \reports /d:29-12-1993 /l > xcopy.out

Список файлов, которые были бы скопированы, находится в файле Xcopy.out.

Чтобы скопировать каталог \Customer и все подкаталоги \\Public\Address на сетевой диск H, сохранить у файлов атрибут «только для чтения», введите команду:

xcopy \customer h:\public\address /s /e /k /p

Чтобы выдать предыдущую команду, убедиться, что команда xcopy создает каталог \Address и устранить вывод сообщение о создании нового каталога, добавьте параметр /i следующим образом:

xcopy \customer h:\public\address /s /e /k /p /i

Для запуска программы xcopy и анализа кодов завершения можно создать пакетный файл и использовать оператор if для обработки кодов завершения в случае возникновения ошибок. Например, следующая пакетная программа использует замещаемые параметры для задания источникаxcopy и результата:

@echo off
rem COPYIT.BAT копирует все файлы во всех подкаталогах
rem исходного диска или каталога (%1) на другой диск

rem или в другой каталог (%2)

?? xcopy %1 %2 /s /e

??if errorlevel 4 goto lowmemory
?if errorlevel 2 goto abort
?if errorlevel 0 goto exit

??:lowmemory ?
echo Недостаточно памяти для копирования файлов,
задан недопустимый ?echo диск или ошибка в синтаксисе командной строки.
?goto exit
??
:abort ?
echo Нажата комбинация CTRL+C для остановки копирования.
?goto exit ?
?
:exit

Эта пакетная программа может быть использована для копирования всех файлов каталога C:\Prgmcode и его подкаталогов на диск B следующим образом:

copyit c:\prgmcode b:

Командный интерпретатор подставляет C:\Prgmcode вместо параметра %1 и B вместо параметра %2, затем использует команду xcopy с параметрами /e и /s. Если при выполнении xcopy произошла ошибка, пакетная программа считывает код завершения и переходит на метку, указанную в соответствующей инструкции IF ERRORLEVEL. В результате на экран выводится сообщение о характере ошибки и осуществляется выход из пакетной программы.

Обратите внимание, что данная утилита не позволяет создавать зеркала папок. Для этой цели подойдет утилита robocopy.exe, обладающая расширенными возможностями.


xpsrchvw.exe

Местонахождение

%windir%\system32

Описание

Средство просмотра XPS

В состав Windows 7 включено новое приложение, предназначенное для просмотра документов формата XML Paper Specification (XPS).

XML Paper Specification (XPS) - это формат документа, который можно использовать для просмотра, сохранения, подписи и защиты содержимого документа. XPS-документ похож на электронный лист бумаги. Изменить содержание листа после печати нельзя, также нельзя изменить содержимое XPS-документа после сохранения его в формате XPS. В операционной системе Windows 7 можно создавать XPS-документ в любой программе, в которой есть возможность печати, но просматривать, подписывать и устанавливать разрешения для XPS-документов можно только при помощи средства просмотра XPS. XPS-документ - это любой файл, сохраненный в формате XML Paper Specification (XPS). По сути, формат XPS является аналогом формата Adobe PDF.

Приложение поддерживает Windows Rights Management Services, поэтому при желании можно ограничить доступ на открытие XPS-документа.


whoami.exe

Местонахождение

Support\Tools

Описание

Whoami - queries user information

Утилита командной строки позволяет получать информацию о пользователе (учетная запись, SID, привилегии)

Синтаксис

whoami [/option] [/option]

Используйте параметр /help для получения информации о параметрах программы. Например, для получения идентификаторов безопасности используйте строку

whoami /all /sid


AppEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл AppEvent.Evt является журналом событий приложений, используемого реестром Windows


autorun.inf

Все, наверное, видели, как при установке игры с диска значок DVD/CD менялся на значок игры. Всё дело в файле autorun.inf, который лежит в корне диска. Он примерно такой:

[Autorun]
icon=icon.ico

Если же такие файлы переписать на жесткий диск, то поменяется значок диска.

Расширенное описание файла Autorun.inf

[Autorun]
Open=Autorun.exe
Icon=Autorun.exe ,0
Shell\About=About CD
Shell\About\Command=Notepad.exe About.txt

Перед параметрами Open, Icon, Shell\..., Shell\...\Command обязательно должна быть строка [Autorun]

Описание параметров:

Open | Программа, автоматически выполняемая при вставке диска или при выборе в контекстном меню диска пункта Автозапуск. Например: Open=Autorun.exe или Open=Notepad.exe List.txt
Icon | Полные путь имя файла со значком и номер значка в нем. Формат: Icon=File.exe ,n File.exe - полные путь и имя файла со значком n - номер (отсчет начинается с нуля) значка в файле
Shell\name | Описание дополнительного пункта контекстного меню диска. Формат: Shell\mname=mtext Shell\mname\Command=cmdline mname - имя пункта меню mtext - текст пункта меню cmdline - командная строка, выполняющаяся при выборе этого пункта меню.

Примечание

Если параметр Shell\...\Command указан без параметра Shell\..., то в меню будет выведено либо системный текст, либо имя пункта меню.

Примечание:

Файлы Autorun.inf могут работать не только на жестких дисках и CD, они могут работать и на съемных дисках (USB-флешки).


DDORes.dll

В файле DDORes.dll содержатся значки для различных категорий устройств.


desktop.ini

Вы видели, что в Проводнике некоторые папки (Документы, Изображения и т.п.) отображаются собственными специальными значками. Это происходит из-за наличия в этих папках специальных файлов desktop.ini. Если эти специальные папки вдруг стали отображаться как обычные папки, то вероятная причина такого поведения - отсутствие или повреждение файлов desktop.ini. Или же эти файлы имеют неправильные атрибуты.

У файла desktop.ini должны быть атрибуты Скрытый и Только чтение. Дополнительно необходимо установить атрибут Только чтение на пользовательскую папку. Для вступления в силу изменений необходимо завершение сеанса. В случае если файла desktop.ini нет в папке, его необходимо создать. Каждой из пользовательских папок соответствует свое содержимое этого файла, ниже вы найдете содержимое этих файлов по умолчанию. Естественно, после создания файла, ему необходимо присвоить атрибуты, указанные выше.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235

Изображения

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805

Музыка

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806

Видео

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807

Избранное

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173

Рабочий стол

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183

Ссылки

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770


filelist.xml

Местонахождение

WINDOWS\system32\Restore

Скрытый файл filelist.xml содержит список файлов и настроек, за которыми следит программа восстановления системы rstrui.exe. Вы можете просмотреть данный файл в Internet Explorer. Изучив внимательно XML-файл, можно заметить, что он дает указание программе восстановления системы следить за файлами определенных расширений, заданными папками и ветвями реестра


hosts

Местонахождение

WINDOWS\system32\drivers\etc или %systemroot% \SysWOW64\drivers\etc (64-битная версия)

Специальный файл hosts (обратите внимание, что файл без расширения) предназначен для сопоставления IP-адресов и имен серверов. Наиболее распространенное использование - блокировка рекламных сайтов.

Файл hosts связывает IP-адреса с именами хостов. IP-адреса представлены в виде четырех групп цифр – XXX.XXX.XXX.XXX, и в таком виде трудны для запоминания. Чтобы облегчить запоминание и обращение к IP-адресам компьютеров, каждому IP-адресу ставится в соответствие доменное имя. Система преобразует доменное имя, по которому пользователь обращается к определенному компьютеру, в соответствующий IP-адрес, и далее он используется для установления соединения с нужным компьютером.

Этот файл обрабатывается раньше запроса к DNS и потому имеет приоритет, которым можно воспользоваться в своих целях не только для того чтобы ускорить обращения к нужным сайтам, но и предотвратить посещение нежелательных страниц. Для этого нужно открыть в текстовом редакторе файл hosts и добавляем строчки

127.0.0.1 www.somesite.com

127.0.0.1 – это зарезервированный адрес вашего компьютера. Таким образом, запрос на сайт www.somesite.com завернётся в петле внутри компьютера и просто не уйдёт к серверу DNS. При этом браузер вместо запрашиваемого сайта сообщит, что не может открыть страницу. Ещё одно применение этого файла – для перенаправления запросов нежелательных страниц на некоторый другой сайт.

Таким образом можно создать список нежелательных сайтов. Для отсечения всякого рода рекламных и баннерных сайтов можно взять готовый файл на сайте winchanger.whatis.ru.

Ещё одно применение этого файла – быстрый доступ к какому-то определённому сайту. Например, если вы запишите в hosts такую строку:

216.239.39.99 g # google.com
то попадёте на сайт поисковой машины google.com просто после ввода одной буквы g в адресную строку браузера. Обратите внимание на запись # google.com, знак # означает что всё что идёт после него до конца строки – это комментарий и игнорируется. Иногда адресация одной или парой букв удобнее, чем запись наиболее популярных адресов в фаворитах.

Необходимо помнить, что изменить данный файл можете не только вы, но и вирус. Например, такой вирус как W32.Donk.Q прописывает в файл hosts записи, препятствующие подключению к сайтам с обновлениями ведущих антивирусных производителей. Кроме него есть ещё несколько паразитов, вносящих записи в этот файл и нарушающих нормальную работу.

В заключение следует отметить, что иногда неправильные записи в этом файле могут помешать работе браузера и вы можете получить сообщения типа Internet Explorer cannot open the Internet site Web address. A connection with the server could not be established или Internet Explorer cannot open the internet site URL: Web site the connection to the server was reset или вообще попадать на другую страницу вместо запрошенной. Такие проблемы описаны на сайте Microsoft. В таком случае попробуйте изменить имя файла hosts на любое другое (например, hosts.txt) и после перегрузки попробовать еще раз зайти на тот же сайт. Или, если вы точно знаете где ошибка, закомментируйте эту ошибочную строку, поставив знак # в начале строчки.

Ещё одна проблема может возникнуть при использовании очень большого файла hosts – тормоза при работе браузера.

Оригинальный файл выглядит следующим образом:

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a ‘#’ symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handle within DNS itself.
#       127.0.0.1       localhost
#       ::1             localhost

Вы можете удалить ваш файл, заполненный записями (предварительно сделав резервную копию), и создать новый файл, вставив вышестоящий текст, чтобы восстановить оригинальный текст файла.


lusrmgr.msc

Местонахождение

Windows\system32

Локальные пользователи и группы - Local Users and Groups

Оснастка Локальные пользователи и группы — это инструмент, предназначенный для управления локальными пользователями и группами. В Windows XP Home Edition данная оснастка отсутствует.

Будьте осторожны с неиспользуемыми пользовательскими учетными записями. Например, на вашем компьютере была учетная запись сотрудника фирмы. После увольнения сотрудника неиспользуемую учетную запись лучше сразу же отключить. Запустите остнастку и в появившемся окне из соответствующей папки выберите «отслужившего» пользователя. Щелкнув правой кнопкой мыши в свойствах учетной записи активируйте пункт Отключить учетную запись. Читатели могут удивиться: а зачем отключать, если можно удалить? Можно и удалить, но при удалении учетной записи безвозвратно теряется ее идентификатор безопасности SID (даже если вы потом снова создадите новую запись с тем же именем и паролем, идентификатор все равно будет уже другим). А с потерей SID вы потеряете доступ ко всем закодированным файлам и паролям, которые использовал прежний пользователь.

Обладатели XP Home Edition оснастка могут воспользоваться утилитой net для отключения пользователя.

net user имя_пользователя /active :no


mydocs.dll

Местонахождение

Windows\system32

Описание

Пользовательский интерфейс папки "Мои документы"

Windows XP сама создает свои подпапки в папке Мои документы (My Pictures, My Video и др.). При удалении этих папок они создаются заново! Если вам не нравится подобное поведение, то надо лишь выполнить команду regsvr32 /u mydocs.dll и подпапки создаваться не будут. А если захотите вернуть все обратно, то введите в командной строке следующее: regsvr32 mydocs.dll


ntshrui.dll

Местонахождение

Windows\system32

Описание

Расширения оболочки, обеспечивающие доступ к ресурсам - Shell extensions for sharing

Файл, в котором содержатся различные данные, необходимые для работы с ресурсами. В частности в этом файле содержится изображение ладошки, используемое в значках расшаренных ресурсов. Чтобы удалить эту ладошку, можно воспользоваться правкой реестра (смотри Справочник по реестру Windows)


ntuser.dat

Местонахождение

C:\Documents and Settings\ИмяПользователя

Файл ntuser.dat является кустом реестра Windows HKEY_USERS/SID


oeminfo.ini

Местонахождение

Windows\system32

Описание

Если создать текстовый файл oeminfo.ini и поместить его в системную папку Windows (как правило Windows\system32), то в апплете Система Панели управления, появится кнопка Сведения о поддержке

Файл oeminfo.ini имеет следующую структуру:

[General]
Manufacturer=Название компании
Model=Название модели

[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=Бла-бла-бла
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=Всего шесть строчек

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.

Смотри также файл oemlogo.bmp


oemlogo.bmp

Местонахождение

Windows\system32

Описание

Чтобы добавить собственную картинку в апплет Система Панели управления, надо создать или модифицировать картинку, которая находится в файле oemlogo.bmp и поместить файл в системную папку Windows (как правило Windows\system32)

Файл oemlogo.bmp создается в любом графическом редакторе (напр. Paint) с размером 172 на 100 пикселов (русская версия Windows XP). Надо сказать, что размеры картинки в разных версиях Windows постоянно менялись. Как правило, слишком большая картинка просто обрезается. Также необходимо иметь в этой же папке файл oeminfo.ini, иначе картинка не будет выводиться вообще

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.


pfirewall.log

Местонахождение

WINDOWS

В файл pfirewall.log записывается информация, которую впоследствии можно использовать для устранения неполадок. По умолчанию, данный файл находится в папке Windows. Вы можете изменить местонахождение данного файла. Для этого выбираем Пуск Панель управления Брандмауэр Windows Допольнительно Ведение журнала безопасности кнопка Параметры. В диалоговом окне вы можете изменить имя файла и его местоположение. А также управлять размером данного файла. Если вы уберете галочки с двух верхних кнопок, то данного файла на компьютере не будет.


SAM

Местонахождение

WINDOWS\system32\config

Файл SAM (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\SAM


SecEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл SecEvent.Evt является журналом событий безопасности, используемого реестром Windows


SECURITY

Местонахождение

WINDOWS\system32\config

Файл SECURITY (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\SECURITY


shmedia.dll

Местонахождение

Windows\system32

Описание

Извлечение свойств медиа-файлов - Media File Property Extractor Shell Extension

Эта библиотека отвечает за сбор информации об AVI-файлах. На некоторых компьютерах при щелчке правой кнопкой по файлу с расширением AVI выскакивает окно с ошибкой "Explorer.exe Обнаружена ошибка...". В этом случае попробуйте отключить библиотеку

Пуск | Выполнить | regsvr32 /u %SystemRoot%\system32\shmedia.dll


slmgr.vbs

slmgr.vbs (Windows Vista, Windows 7)

Местонахождение

Windows\system32

Описание

Данный файл сценария является средством управления лицензированием программного обеспечения Windows Vista.

Использование

slmgr.vbs [имя_компьютера [Пользователь Пароль]] [параметр]

имя_компьютера - Имя удаленного компьютера (по умолчанию используется локальный компьютер)

Пользователь - Учетная запись с требуемыми привилегиями на удаленном компьютере. На локальном компьютере можно не указывать (при соответствующих правах)

Пароль - пароль упомянутой учетной записи.

Параметры

При использовании параметров можно использовать символы "-" или "/"

-ipk ключ_продукта
Установка ключа продукта (замена существующего ключа)
-upk
Удаление ключа продукта
-ato
Активация Windows
-dli [ID_активации|Все]
Отображение сведений о лицензии (по умолчанию используется текущая лицензия)
-dlv [ID_активации|Все]
Отображение подробных сведений о лицензии (по умолчанию используется текущая лицензия)
-xpr
Дата истечения срока для текущего состояния лицензии
-cpky
Удаление ключа продукта из реестра (предупреждение атак типа перехвата)
-ilc Файл_лицензии
Установка лицензии
-rilc
Переустановка файла лицензии
-rearm
Сброс лицензионного состояния компьютера
-dti
Отображение идентификатора установки для автономной активации
-atp Идентификатор_подтверждения
Активация продукта с идентификатором подтверждения, предоставленным пользователем


software

Местонахождение

WINDOWS\system32\config

Файл software (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\Software


srclient.dll

Местонахождение

WINDOWS\system32

Описание

SR CLIENT DLL

Файл srclient.dll является клиентской DLL для программы восстановления системы rstrui.exe и используется при написании скриптов


Svcpack.log

Местонахождение

Windows

Описание

Файл Svcpack.log является протоколом хода установки сервис-пака. Исследуя лог установки, вы можете найти причины неудачной установки. Например, если вы увидите такие записи: "There is not enough space on the disk. Service Pack 2 installation did not complete", то станет ясно, что программе установки не хватает места на жестком диске. Попробуйте освободить диск от лишних файлов и повторите попытку.


SysEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл SysEvent.Evt является журналом событий системы, используемого реестром Windows


system

Местонахождение

WINDOWS\system32\config

Файл system (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\System


UsrClass.dat

Местонахождение

C:\Documents and Settings\ИмяПользователя\Local Settings\Application Data\Microsoft\Windows

Файл UsrClass.dat является кустом реестра Windows HKEY_USERS/SID_Classes


WindowsUpdate.log

Местонахождение

Windows

Файл, содержащий историю автоматического обновления.


wpa.dbl

Местонахождение

Windows\system32

Описание

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.


zipfldr.dll

Местонахождение

Windows\system32

Описание

Сжатые ZIP-папки

Windows позволяет работать с zip-архивами как с обычными папками. Вы можете отключить эту возможность, если используете другой архиватор или у вас слабый компьютер. Для этого вызовите команду

regsvr32 /u zipfldr.dll

При вызове этой команды на экране появится системное сообщение об успешном отключении библиотеки zipfldr.dll. После этого воспользоваться стандартными средствами Windows для работы с архивными файлами формата ZIP будет нельзя, а также исчезнет пункт Сжатая ZIP-папка из контекстного меню Отправить . Чтобы восстановить работу с zip-архивами как с сжатыми папками, воспользуйтесь командой

regsvr32 %windir%\system32\zipfldr.dll

Примечания

Для работы с командой regsvr32.exe требуются права администратора.

Использование более длинного пути %windir%\system32\zipfldr.dll является более предпочтительным вариантом, если команда используется в сценариях и в программировании, так как позволяет избежать ошибок при нестандартной установке Windows. В стандартной ситуации можно просто указать имя файла (смотри первый пример).


Расширения файлов

OpenWith - бесплатная программа, которая покажет, чем открывать файлы с определенным расширением. После ее установки, в контекстном меню всех файлов появляется дополнительный пункт How Do I Open This?. При выборе его запускается приложение, которое покажет список программ, которыми открывается данный файл, установлены эти программы или нет, и, если не установлены, даст ссылку на их скачивание.

OpenWith ищет эти программы по базе, которая расположена на сайте.

Кстати, если надо быстро посмотреть, чем открыть файл, а программу ставить не хочется, можно сделать это на сайте.

Такая программа подойдет для начинающих пользователей, которые только начинают осваивать компьютер. Кроме того, ей удобно смотреть аналоги используемых программ.


AI

Формат AI (сокращенно от Adobe Illustrator) является базовым форматом векторного пакета Adobe Illustrator.


bat

BAT-файлы

Если Вам требуется последовательно запускать несколько программ Windows, то Вы можете написать для этого .bat файл. Используйте команду START с ключом /W. Например создайте текстовый файл со следующим текстом:

@START /W /MAX "C:\WINDOWS\SCANDSKW.EXE /A /N"
@START /W /MAX "C:\WINDOWS\DEFRAG.EXE /ALL /F /NOPROMPT"

Сохраните его как 1.bat. Кроме /W, Вы можете использовать следующие ключи:

/M
Запускает программу минимизированно
/MAX
Запускает программу, развернув на весь экран
/R
Запускает программу в окне (используется по умолчанию)

Передача параметров в bat-файл

Для того чтобы bat-файл можно было запускать с какими-то параметрами надо в том месте файла, куда вы хотите добавить параметр, набрать %1 - для первого параметра, %2 - для второго и т.д.

Например (файл test.bat):

/тут идут какие-то
/.....
/подготовительные работы
rar m file%1

Теперь если вы запустите этот файл командой "test.bat 0001", то у вас будет создан файл с именем file0001.rar


CDR

Формат CDR используется программой Corel Draw. Позволяет записывать векторную и растровую графику, а также текст. Файл в формате CDR может иметь несколько страниц.


DBX-файлы

В файлах с расширением DBX хранятся записи программы Outlook Express. В этих файлах, называемых Банком сообщений, находятся письма, сообщения новостных групп и т.п. При желании, можно скопировать эти файлы на носитель информации для переноса данных в другой компьютер.


EPS

Формат EPS (Encapsulated PostScript) - это основной полиграфический формат, позволяющий описывать растровые и векторные изображения. Формат разработан фирмой Adobe и поддерживается многими графическими редакторами: Adobe Illustrator, Adobe Photoshop, Adobe PageMaker, CorellDraw, QuarkXPress.


INF-файлы

В данной статье мы рассмотрим, что представляет собой INF-файл, как с его помощью работать с другими файлами и реестром, создавать ярлыки, запускать программы и т.д.

Как известно, для более-менее серьезного программного продукта обычно требуется специальная программа инсталляции, с помощью которой пользователь сможет легко установить и так же легко удалить сам продукт. Существует много инструментальных средств, позволяющих быстро создавать инсталляционные пакеты. Однако, большинство из них добавляют к исходному размеру программы 200–500 Кб. А ведь это далеко не всегда радует. Серьезный продукт не обязательно должен быть внушительных размеров. И если вы хотите сделать инсталляцию доступной в Сети, то эти 200–500 Кб могут сильно сказаться на популярности продукта.

Как выйти из подобной ситуации? Здесь на помощь придут inf-файлы. Именно с помощью inf-файлов можно удалять, копировать другие файлы, добавлять информацию в реестр, в ini-файлы, создавать ярлыки, в общем, все то же, что обеспечивают громоздкие программы установки.

Перейдем к изучению спецификации inf-файлов.

inf-файл представляет собой текстовый файл, который, содержит условия установки программного обеспечения.

Чтобы запустить inf-файл, нужно щелкнуть по нему правой кнопкой мыши и выбрать в открывшемся контекстном меню параметр Установить (Install). Но для подготовки дистрибутива можно воспользоваться IExpress, который поддерживает запуск .inf-файлов. Вооружившись этой программой, а также знанием спецификации .inf-файлов, можно создавать профессиональные инсталляционные пакеты.

Основную информацию в .inf-файле содержат секции, представленные в Таблице 1 (более сложные .inf-файлы могут иметь дополнительные секции).

Секция [Version] обязательно должна включать строку

Эта секция определяет стандартный заголовок для всех inf-файлов Microsoft Windows. Если сигнатура будет не $Chicago$, операционная система Windows не примет inf-файл как принадлежащий любому из классов устройств, признанных Windows.

При написании сигнатуры вы можете использовать как верхний, так и нижний регистры букв — $Chicago$ или $CHICAGO$.

Секция установки [DefaultInstall] может содержать следующие параметры:

CopyFiles — копирование файлов;

RenFiles — переименование файлов;

DelFiles — удаление файлов;

UpdateInis — изменение данных в ini-файлах;

UpdateIniFields — изменение областей в .ini-файлах;

AddReg — добавление информации в реестр;

DelReg — удаление информации из реестра;

Ini2Reg — перемещение строки или секции в ini-файлах;

UpdateCfgSys — изменение файла Config.sys;

UpdateAutoBat — изменение файла Autoexec.bat.

Этим параметрам в качестве значения присваивается имя секции с файлами. Например:

Чуть ниже представлены цифровые обозначения специальных папок, применяемые в .inf-файлах:

10 — C:\WINDOWS;

11 — C:\WINDOWS\System;

12 — C:\WINDOWS\SYSTEM\IOSUBSYS;

13 — C:\WINDOWS\COMMAND;

17 — C:\WINDOWS\Inf;

18 — C:\WINDOWS\Hlp;

20 — C:\WINDOWS\FONTS;

21 — C:\WINDOWS\SYSTEM\VIEWERS;

22 — C:\WINDOWS\SYSTEM\VMM32;

23 — C:\WINDOWS\SYSTEM\COLOR;

30 — Корневой загрузочный диск (обычно C:\).

Например, если нужно скопировать файл в папку Web, которая находится в каталоге Windows, сделайте это так:

Так же можно поступить и с другими папками, находящимися в определенных каталогах.

Параметр CopyFiles содержит имя секции, где находятся имена файлов для копирования с исходного диска в папку назначения. Папка назначения определяется в секции [DestinationDirs] inf-файла. В следующем примере копируются два файла:

Цифры через три запятые обозначают дополнительные флаги при копировании файлов и могут принимать значения, представленные в

Параметр CopyFiles может копировать файл непосредственно из строки. Для этого перед именем файла нужно поставить символ @. В следующем примере копируются два текстовых файла:

Параметр RenFiles содержит секции, которые в свою очередь содержат имена файлов для переименования. Папка, где будет происходить переименование, должна быть определена в секции [DestinationDirs] inf-файла. В следующий примере происходит переименование двух файлов из .bmp в .txt:

Все старые имена файлов (Example1.bmp, Example2.bmp) должны быть определены в секции [SourceDisksFiles].

Параметр DelFiles содержит секции, которые содержат имена файлов для удаления. Папка, где будет происходить удаление, как всегда, должна быть определена в секции [DestinationDirs] .inf-файла. Следующий пример удаляет два файла:

В параметре AddReg указываются секции, которые содержат информацию о добавлении или изменении ключей, значений в реестре. Следующий пример регистрирует вашу копию операционной системы Windows.

С помощью этого файла в реестр добавляется следующая информация:

Обратите внимание на запятые в inf-файле. Если нужно добавить в реестр параметр по умолчанию, запятые должны быть проставлены иначе. Например, в рассмотренном нами ключе реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion сделаем параметр по умолчанию равным единице (1):

Ниже представлены корневые имена реестра, применяемые в inf-файлах.

HKCR — HKEY_CLASSES_ROOT;

HKCU — HKEY_CURRENT_USER;

HKLM — HKEY_LOCAL_MACHINE;

HKU — HKEY_USERS;

HKR — относительный ключ, используется классом installer; обычно применяется для дисков устройства.

В параметре DelReg указываются секции, которые содержат информацию об удалении подключей с параметрами и значениями из реестра. Следующий пример демонстрирует удаление подключа Graphviz со всеми параметрами и значениями этого раздела реестра — HKEY_CURRENT_USER\Software\AT&T\Graphviz:

Корневые имена реестра, естественно, обозначаются так же, как и при добавлении информации в реестр.

В процессе установки можно прервать выполнение .inf-файла для показа пользователю какого-нибудь документа (после закрытия которого установка продолжится) или запустить определенный процесс. Следующий пример отображает файл справки About.hlp и текстовый файл About.txt, после чего запускает другой inf-файл — Example.inf:

После того как определенные в секции [ExampleView] команды выполнятся, записи, добавленные в реестр, будут автоматически удалены из него. Таким образом можно запускать и другие процессы, например апплеты Панели управления:

В следующем примере показано, как с помощью inf-файла изменить содержимое ini-файла:

С помощью inf-файлов можно также создавать/удалять ярлыки в меню Пуск. Ярлык можно создать в уже созданной группе программ. Если таковой не существует, она будет создана автоматически.

Следующий пример создает группу программ Windows + + в меню Пуск > Программы и ярлыки к утилитам winipcfg.exe (Конфигурация IP), Regedit.exe (Редактор реестра) и Winfile.exe (Диспетчер файлов — только в Win98). Все они есть у вас на компьютере и лежат в папке Windows.

Ярлык прописывается в таком порядке:

1. Название группы программ. В нашем случае — Windows + +.

2. Имя ярлыка.

3. Путь к программе, к которой создается ярлык.

4. Рабочий каталог, обычно тот же, что и путь. Некоторые программы не работают, если это условие не выполняется.

5. Имя программы с расширением.

Параметр %30%\ определяет корневой диск. Если вы хотите создать ярлык к файлу, который находиться в каталоге Program Files, смело прописывайте полный путь (не используйте короткие имена), например %30%\Program Files\Setup Generator Pro\Sgpro.exe.

Для удаления ярлыка нужно убрать все записи, указанные после имени ярлыка. В следующем примере удаляется ярлык Конфигурация IP из программной группы Windows + +.

Если вы удаляете один из ярлыков программной группы, то удаление не затронет другие ярлыки. Для полного удаления программной группы нужно прописать данное действие для каждого ярлыка.

К сожалению, вы не сможете с помощью inf-файла обычным способом скопировать файлы с длинными именами. Поддержка длинных файловых имен в .inf-файлах немного усложнена, но главное, что она существует. Для этого нужно проделать следующее: исходный файл должен быть с коротким именем, после установки его имя нужно сделать подлиннее. Для удаления процесс повторяется в обратном порядке: длинное файловое имя делается коротким и удаляется уже файл с 8.3-именем. Происходит все это с помощью реестра. Для этих действий в реестре предусмотрены специальные ключи:

Для действий переименования или удаления нужно добавить подключ с любым именем в соответствующую ветвь реестра. Минимум два ключа должны быть определены. Первый ключ содержит имя каталога, где будет происходить переименование или удаление файлов. Следующий ключ содержит имена файлов: первое — короткое, второе — длинное и его атрибуты, если нужно:

1 — Только для чтения;

2 — Скрытый;

3 — Системный.

Следующий пример демонстрирует переименование в каталоге C:\Files файла About.txt в About View files.txt и установление ему атрибута «Скрытый», а также переименование того же файла в подкаталоге Xmp папки C:\Files с установлением ему атрибута «Только для чтения»:

Ключи для удаления файлов имеют такую же структуру. Рассмотрим пример, который в каталоге C:\Files удаляет файл About View files.txt и такой же файл удаляет в подкаталоге Xmp папки C:\Files:

Параметры Example и SubDir могут быть любыми, например названием вашей программы, подкаталога и т.д. Важно, чтобы они были разными, т.к. переименование/удаление происходит в разных каталогах.

Данная статья не претендует на полноту, но надеюсь, поможет читателю освоить inf-файлы хотя бы поверхностно. Не бойтесь экспериментировать, но будьте предельно осторожны, особенно с процессами удаления.


ISO

ISO-файлы

ISO-файл – это формат файлов образа диска, разработанный международной организацией по стандартизации ISO (International Standards Organization).

В последнее время Microsoft используется данный формат для скачивания операционных систем, пакетов Office и других продуктов.

Виртуальные машины типа VMware Workstation или Microsoft Virtual PC способны монтировать ISO-файлы на виртуальных DVD-приводах.

В Windows 7 появилась утилита isoburn.exe, способная прожигать образ диска на записывающих дисках.

Кроме того, имеются множество утилит, способные извлекать отдельные файлы из образа ISO, например, 7-Zip, Magic ISO, Virtual CloneDrive, WinRAR, Daemon Tools Lite и др.


HTA-файлы

HTML-приложения

Начиная с Internet Explorer 5.0 появилась возможность создавать HTML-приложения с любым пользовательским интерфейсом при помощи JavaScript или VBScript. Причем, созданное html-приложение будет запускаться вне браузера и ничем не будет отличаться от стандартных Windows-приложений.

Созданное приложение будет присутствовать на панели задач, иметь свое собственное окно, меню и значок. Плюс ко всему отпадает необходимость подтверждать использование ActiveX-компонентов (система защиты Internet Explorer предусматривает появление предупреждающих сообщений при попытке использования ActiveX в HTML-документах). Вы имеете полный контроль над системой, включая чтение/запись файлов, данных в реестре, управление процессами. Для создания такого приложения достаточно обычного Блокнота (или другой текстовый редактор).

Данные html-приложения должны иметь расширение *.hta. Простейший случай будет выглядеть так:

Создайте подобный файл и запустите его. Как видите, появившееся окно ничем не напоминает браузер, однако вы можете использовать такую возможность, например, как Refresh документа (в нашем случае это главное окно будущего приложения) или изменение кодировки на лету. Для удаления полосы прокрутки мы воспользовались параметром SCROLL=no в тэге BODY, можно также воспользоваться специальными свойствами тэга HTA.

HTA-файлы обрабатывается программой mshta.exe, задача которой - обеспечить связь вашей программы с браузером.

Для того чтобы полностью использовать новые возможности, необходимо включить тэг HTA:APPLICATION между тэгами HEAD.

Как видно из приведенного примера, в тэге HTA:APPLICATION мы определяем специфические для HTA параметры. Рассмотрим их подробнее.

  • ID - идентификатор, который позволяет обращаться к нему как к объекту в скриптах

    Например:

  • APPLICATIONNAME - возвращает имя вашего приложения. Должно быть уникальным.

  • BORDER - позволяет задать тип окантовки окна. Доступны следующие значения:

    thick — толстая рамка, позволяющая изменять размер окна;

    dialog — обычная рамка без возможности изменять размер;

    none — рамка отсутствует;

    thin — тонкая без возможности изменять размер;

    Дополнительно указывается стиль рамки при помощи атрибута BORDERSTYLE, который может иметь следующие значения:

    normal — обычная;

    raised — приподнятая (3D);

    complex — комбинация стилей raised и sunken;

    static — может использоваться для окон, в которых не предусмотрен пользовательский ввод, - к примеру, для создания «флэш»-окон;

    sunken — вдавленная (3D).

  • CAPTION - определяет, будет ли окно отображаться с заголовком. Может принимать значения yes или no.
  • ICON - путь к файлу, содержащему значок (*.ico), содержащий картинку 32х32 пикселя. Можно использовать в качестве иконки и обычный bmp-файл - главное, чтобы соблюдались размеры картинки.
  • SHOWINTASKBAR - если это свойство имеет значение yes, окно будет сворачиваться в панель задач, а также отображаться на Панели задач
  • SINGLEINSTANCE - позволяет разрешить запуск только одной копии вашего приложения; для того чтобы определить, запущенно ваше приложение во второй раз или нет, это свойство использует APPLICATIONNAME. Может принимать значения yes/no.
  • SYSMENU - будет ли отображаться системное меню.
  • WINDOWSTATE - определяет, в каком виде приложение будет стартовать.

    Принимает следующие значения:

    normal — обычное окно.

    minimize — свернуто.

    maximize — на весь экран.

  • MAXIMIZEBUTTON и MINIMIZEBUTTON принимают значения yes/no и отвечают за отображение кнопок Maximize и Minimize соответственно в заголовке окна.

Помимо атрибутов, характеризующих внешний вид программы, может быть задана версия продукта — например, так:

Для управления полосой прокрутки в окне HTA есть целых два параметра: SCROLL со значениями yes/no/auto и SCROLLFLAT — yes/no.

Если у вас установлен IE5.5, то вы можете воспользоваться дополнительным атрибутом NAVIGABLE, который позволяет переход по ссылке в окне HTA.

Для управления текстом предусмотрен параметр SELECTION (yes/no).

В дополнение ко всему перечисленному, вы можете иметь доступ к параметрам командной строки посредством свойства commandLine. Внимание, это свойство не имеет HTML-синтаксиса и может быть доступно только из скриптов! Немаловажно заметить, что все перечисленные параметры во время выполнения доступны только для чтения.

Давайте приступим к написанию своего первого скриптового приложения - создадим простейший текстовый редактор.

Константы для работы с диалогами открытия и сохранения файлов:

CdlOFNFileMustExist — пользователь может вводить только имя существующего файла, в противном случае возникнет предупреждение.

CdlOFNHideReadOnly — прячет опцию Hide Only (открыть только для чтения).

Константы для работы с файлами:

ForReading — файл открывается для чтения;

ForWriting — для записи в файл.

Создаем объект для доступа к файловой системе:

И настраиваем общие свойства для диалога открытия и сохранения:

Заголовок диалога:

Фильтр, для отображения групп файлов.

Вызываем диалог открытия и в случае если пользователь осуществил выбор пытаемся прочитать файл и отобразить его.

Естественно, дополнительными тэгами все вкусности скриптовых приложений не исчерпываются. Особую ценность представляет возможность повторного использования однажды написанного кода, создание универсальных компонентов, с которыми можно работать аналогично COM-компонентам. Дополнительную информацию, а также примеры и некоторую документацию вы можете найти по следующим адресам:

http://www.wshscripting.com/ — открытый исходный код и множество примеров скриптов для WSH (Windows Scripting Host).

Также стоит посетить http://www.serialscripter.com/, где помимо бесплатных HTA-приложений, сопровождающихся подробными описаниями, находится неплохая подборка ссылок на ресурсы, тем или иным образом связанные со скриптовым программированием.

Источник: http://www.mycomp.com.ua/


pdf

PDF-файлы

Формат Adobe Portable Document Format (сокращенно PDF) позволяет пользователям открывать документы PDF без надобности устанавливать программное обеспечение, в котором документ был создан. Стандарт и формат публично открыты.

Стандарт PDF

Векторный и масштабируемый стандарт Portable Document Format был впервые опубликован Adobe Systems в 1993 году, после чего он превратился в открытый стандарт ISO 320001:2008 в 2008 году (PDF 1.7). Стандарт предназначен для создания, чтения и печати документов независимо от платформы, то есть аппаратное и программное обеспечение, а также операционная система для работы с документами совершенно не принципиальны. Кроме того, этот стандарт используется и для профессиональной печати (PDF/X).

этот формат весьма полезен для устранения таких распространённых проблем, как отсутствующие шрифты, неправильная разбивка страниц или несовместимые форматы файлов, например, между Word 2003 (.doc) и Word 2007 (.docx). Кроме того, формат PDF не только включает всё содержимое документов, но и добавляет элементы контроля, такие как оглавление с возможностью перехода, иконки предварительного просмотра или формы внутри документа. Наконец, формат PDF можно защитить, так что оригинал будет весьма проблематично изменить. На документы PDF можно установить пароль, а также есть возможность запрета печати.

Для просмотра и открытия документов PDF требуется Adobe Acrobat Reader, который доступен для всех популярных операционных систем на 35 разных языках. Кроме того, существуют альтернативы, такие как Foxit, Ghostscript или Okular.

У документов PDF нет ограничения на размер, равно как и на количество страниц в одном файле. Среди популярных форматов страниц есть Letter и A4, но ещё после Acrobat 7 появилась возможность создавать страницы крупных размеров. Каждый элемент внутри документа PDF хранится в виде объекта, то есть документ PDF с картинками, шрифтами, национальными кодировками, комментариями, формами и другой информацией может содержать тысячи объектов.

PDF базируется на трёх элементах: графическая модель, которая очень похожа на PostScript, система управления шрифтами, чтобы встраивать нужные шрифты в документ PDF, а также структурированное хранилище, управляющее всеми объектами, а также сжатием.

Создание документа PDF выполняется через интеграцию в приложение (утилита PDF получает информацию от исходного приложения, такого как MS Office) или файлы PDF создаются путём печати документа. Утилита создания PDF устанавливает драйвер принтера, который позволяет выполнять все необходимые настройки и сохраняет документ PDF в указанное место.

Дополнительно

Создание документов PDF: тест разных утилит | THG.RU


XPS

Расширение XPS (xml paper specification) - это эффективный открытый стандарт, который являтеся аналогом популярного, но патентованного формата PDF от Adobe Acrobat. В Windows 7 вы можете создавать, редактировать, печатать и сохранять XPS-документы - создайте файл в любом текстовом редакторе (notepad, wordpad, word и т.д.) и нажмите Печать…. Затем выберите автоматически установленный принтер xps для "печати" документа в файл xps.


SVG

Формат SVG (Scalable Vector Graphics) - формат описания векторных графических изображений, основанный на языке XML. Разработан консорциумом W3C. В последнее время набирает большую популярность. В векторном редакторе Inkscape данный формат является основным.


wfw

WFW-файлы

В WFW-файлах содержатся настройки Брандмауэра Windows


WMF

Формат WMF (Windows Media File) применяется в Windows для описания векторной информации.


desk.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Экран\Разрешение экрана

Описание

Элемент панели управления (.cpl)

Запускает элемент Панели управления Разрешение экрана. Также можно запустить через Панель управления→Экран→ссылка Настройка разрешения экрана


hdwwiz.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Система\ссылка Диспетчер устройств

Описание

Диалоговое окно Диспетчер устройств


inetcpl.cpl

Местонахождение

Windows\system32

Описание

Элемент панели управления (.cpl)

Запускает диалоговое окно Свойства: Интернет. Также можно запустить через Панель управления→Все элементы панели управления→Свойства обозревателя


intl.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Язык и региональные стандарты

Описание

Элемент панели управления (.cpl)

Запускает диалоговое окно Язык и региональные стандарты. Также можно запустить через утилиту командной строки:

control international


irprops.cpl

Местонахождение

Windows\system32

Описание

Свойства инфракрасных портов. Окно вызывается, если порты установлены в системе.


joy.cpl

Местонахождение

[Файловая система]
%windir%\system32

Описание

Элемент панели управления (.cpl)

Запускает диалоговое окно Игровые устройства. Также можно запустить через Пуск→Игры→меню Сервис→Устройства ввода


main.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Мышь

Описание

Свойства: мышь

Выводит диалоговое окно Свойства: мышь. Также можно запустить через утилиту командной строки:

control mouse


mmsys.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Звук

Описание

Звук

Выводит диалоговое окно Звук.


sysdm.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Система\ссылка Изменить параметры

Описание

Выводит диалоговое окно Свойства системы компонента панели управления Система

Совет

Для быстрого вызова компонента можно использовать комбинацию клавиш WIN+Pause/Break

Часть диалоговых окон апплета можно вызвать через утилиту rundll32.exe


Speech Recognition Options

Данный апплет отображает одноименный диалог, предназначенный для настройки речевого управления компьютером. С помощью этой функции вы можете с голоса вводить текст в каком-нибудь текстовом редакторе и воздействовать на возможности операционной системы — выключать компьютер, открывать программы, каталоги и файлы, открывать различные окна и выполнять навигацию по ним. К сожалению, на данный момент функция распознавания речи доступна только при установке английского языкового пакета.

Способы запуска

Если используется вид По категориям, тогда доступ к соответствующему значку можно получить при помощи одноименного элемента категории Специальные возможности

Через команды:

  • rundll32.exe %windir%\system32\speech\speechux\SpeechUX.dll, RunWizard

    • Данная команда отображает мастер настройки модуля по распознаванию голосовых команд операционной системы Windows Vista

  • rundll32.exe %windir%\system32\speech\speechux\SpeechUX.dll, RunWizard Tutorial

    • Данная команда отображает мастер обучения (Speech Recognition Tutorial) модуля по распознаванию голосовых команд

  • rundll32.exe %windir%\system32\speech\speechux\SpeechUX.dll, RunWizard UserTraining

    • Данная команда отображает мастер Voise Training

  • rundll32.exe %windir%\system32\speech\speechux\SpeechUX.dll, RunWizard MicTraining

    • Данная команда отображает мастер Microphone Setup Wizards

  • rundll32.exe %windir%\system32\speech\speechux\SpeechUX.dll, RunWizard UserEnrollment

    • Данная команда отображает мастер Set Up Speech Recognition.


Windows CardSpace

Если используется вид По категориям, элемент Windows CardSpace находится категории Учетные записи пользователей.

С его помощью можно создать электронную пластиковую карту для безопасной оплаты покупок в интернет-магазинах (если они поддерживают такой способ оплаты). Если вы будете использовать этот способ, при оформлении покупки вам больше не придется вводить дополнительные сведения и свои реквизиты: вся информация будет храниться в электронной пластиковой карте.

Созданная таким образом электронная пластиковая карта ничем не будет отличаться от обычной пластиковой карты, и вы сможете использовать ее при осуществлении покупок в интернет-магазине. Вся информация о посреднике и вашей электронной пластиковой карте хранится в файле с расширением .crd.


timedate.cpl

Местонахождение

[Файловая система]
%windir%\system32

[Панель управления]
Панель управления\Все элементы панели управления\Дата и время

Описание

Дата и время

Компонент панели управления Дата и время существует с Windows 95 и служит для просмотра и изменения даты и системного времени.

При стандартных настройках текущая дата и время отображаются на панели задач в правом углу в области уведомлений. Для того чтобы открыть диалог просмотра даты и времени, нажмите на кнопку часов в области уведомлений. В диалоговом окне можно увидеть время в цифровом формате и в виде обыкновенных часов. Также в этом окне отображается календарь, в котором подсвечивается текущая дата. При нажатии на кнопки со стрелками, расположенными по обе стороны от названия месяца в диалоге будет отображаться предыдущий или следующий месяц, в зависимости от того на какую кнопку вы нажимали. Для перехода к выбору месяца текущего года нажмите на названии месяца. При нажатии на названии года отображается последнее десятилетие, еще одним нажатием можно отобразить года за 100 лет.

Открыть компонент «Дата и время» можно следующими способами:

  • Щелкните на часах в области уведомлений и в появившемся окне перейдите по ссылке «Изменение настроек даты и времени»;
  • Откройте «Панель управления» и из списка компонентов панели управления выберите «Дата и время»;
  • В поисковой строке кнопки Пуск введите timedate.cpl
  • Через командную строку: control date/time

В диалоговом окне «Дата и время» присутствуют три вкладки. На вкладке «Дата и время» вы можете изменять текущую дату и время, а также выбирать часовой пояс. На вкладке «Дополнительные часы» можно добавить часы для других часовых поясов. Вкладка «Время по Интернету» позволяет вам синхронизировать ваше системное время с серверами времени в интернете или вашей интрасети.

Для того чтобы изменить текущие дату и время, нажмите на кнопку «Изменить дату и время…» (Требуются права администратора). В появившемся диалоговом окне «Настройка времени и даты» вы можете изменить дату и время. Для изменения даты выберите нужную дату в календаре. Для изменения времени, щелкните левой кнопкой мыши на часах, минутах или секундах и увеличьте или уменьшите значение кнопками со стрелками, расположенными справа или при помощи клавиш с цифрами на клавиатуре.

Из этого диалогового окна вы также можете перейти к диалоговому окну изменений параметров календаря, щелкнув левой кнопкой мыши по ссылке «Изменение параметров календаря». При нажатии на эту ссылку откроется вкладка «Дата» диалогового окна «Настройка формата», где вы можете выбрать краткий и полный формат даты, первый день недели и прочие настройки. После внесения изменений нажмите на кнопку «ОК».

Дату и время также можно изменять при помощи командной строки CMD.EXE и командной оболочки Windows PowerShell.

Для изменения даты и времени при помощи командной строки существуют команды TIME и DATE (описания команд можно найти в справочнике Командная строка).

Для изменения даты и времени при помощи PowerShell используются командлеты Get-Date и Set-Date (описания команд можно найти в справочнике PowerShell на примерах).

На вкладке «Дата и время» вы также можете изменить часовой пояс. Для этого нажмите на кнопку «Изменить часовой пояс». В диалоговом окне «Выбор часового пояса» выберите текущий часовой пояс в раскрывающемся списке и нажмите на кнопку «ОК». Также в этом диалоговом окне вы можете включить или отключить функцию перехода на летнее время. Если флажок установлен, то при наступлении даты перехода на летнее или зимнее время, операционная система автоматически изменит время. Этой настройке соответствует параметр реестра DynamicDaylightTimeDisabled (описание параметра можно найти в справочнике по реестру Windows).

Вкладка «Дополнительные часы» компонента панели управления «Дата и время» предназначена для отображения времени других часовых поясов наряду с вашим. В операционной системе Windows 7 для установки дополнительных часов других часовых поясов, установите флажок «Показать эти часы», в раскрывающемся списке выберите нужный для вас часовой пояс и в текстовом поле «Отображаемое имя» введите название нового часового пояса.

Добавлять дополнительные часы также можно при помощи реестра - ищите в справочнике по реестру по слову AdditionalClocks

Вкладка «Время по Интернету» позволяет синхронизировать системные часы с сервером времени в Интернете или Интранете. Эта функция позволяет обновлять показания системных часов в соответствии с сервером времени, что гарантирует точность локальных часов. Для того чтобы синхронизировать время, перейдите на вкладку «Время по Интернету» и нажмите на кнопку «Изменить параметры».

В диалоговом окне «Настройка времени по Интернету» установите флажок на опции «Синхронизировать с сервером времени в Интернете», выберите нужный сервер времени или введите имя домена, и нажмите на кнопку «ОК».

Синхронизацию времени можно настроить также при помощи команды командной строки W32tm.exe или с помощью параметров реестра, расположенных в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\

При подготовке использовался материал с сайта Компонент панели управления "Дата и время" в Windows 7


Значки области уведомлений

Местонахождение

Панель управления\Все элементы панели управления\Значки области уведомлений

Способы вызова

control /name Microsoft.NotificationAreaIcons


Системные значки

Местонахождение

Панель управления\Все элементы панели управления\Значки области уведомлений\Системные значки

Способы вызова

rundll32.exe shell32.dll Options_RunDLL 4
control /name Microsoft.NotificationAreaIcons /page SystemIcons


ncpa.cpl

Местонахождение

%systemroot%\System32

Компонент Панели управления Сетевые подключения. Можно быстро вызвать это окно, набрав команду ncpa.cpl в строке поиска кнопки Пуск


Центр начальной настройки

С помощью данного апплета можно выполнить основные действия по настройке операционной системы и ее компонентов, а также просмотреть конфигурацию компьютера и количество дней, оставшихся до активации операционной системы.

Способы запуска:

1. Если используется вид По категориям, тогда доступ к данному апплету можно найти в категории Система и ее обслуживание

2. Можно запустить командой

rundll32.exe oobefldr.dll, ShowWelcomeCenter


Монитор стабильности системы

Местонахождение

Панель управления\Все элементы панели управления\Центр поддержки\Монитор стабильности системы

Описание

В Windows Vista появилось новое приложение, которое позволяло следить за общей стабильностью системы. Это приложение называлось «Монитор стабильности системы» и оно входило в состав утилиты «Монитор надежности и производительности». Также при помощи монитора стабильности системы вы могли следить за событиями, представляющими собой либо изменения в вашей системе, которые могут повлиять на стабильность, либо события, подтверждающие нестабильность. В операционной системе Windows 7 эти два приложения отделились. «Монитор стабильности системы» теперь является передовой утилитой оценивающей проблемы оборудования и программного обеспечения, а также другие изменения компьютера.

«Монитор стабильности системы» отображает все изменения в системе в виде графика и генерирует показатель стабильности системы с течением времени. На диаграмме стабильности системы можно увидеть индекс стабильности, который может варьироваться от 1 до 10, где максимальная величина соответствует стабильно работающей системе, а минимальная – снижению стабильности. Этот индекс можно использовать для оценки стабильности компьютера. Любое изменение, внесенное в конфигурацию компьютера, или возникшая проблема компьютера влияет на индекс стабильности.

Открыть приложение «Монитор стабильности системы» вы можете следующими способами:

  1. Откройте «Центр поддержки». Для этого:
    • Нажмите на кнопку «Пуск» для открытия меню, откройте «Панель управления», из списка компонентов панели управления выберите категорию «Система и безопасность», а затем перейдите по ссылке «Центр поддержки»;
    • Нажмите на значок «Центр поддержки» в области уведомлений и в появившемся диалоге перейдите по ссылке «Открыть центр поддержки»;

    2. *
    Увеличить рисунок

    В окне «Центр поддержки» разверните категорию «Обслуживание» и в группе «Поиск решений для указанных в отчетах проблем» перейдите по ссылке «Показать журнал стабильности работы»;

  2. Нажмите на кнопку «Пуск» для открытия меню, в поле поиска введите стабильност и в найденных результатах откройте приложение «Просмотр журнала надежности системы»;
  3. Воспользуйтесь комбинацией клавиш * +R для открытия диалога «Выполнить». В диалоговом окне «Выполнить», в поле «Открыть» введите %windir%\system32\control.exe /name Microsoft.ActionCenter /page pageReliabilityView и нажмите на кнопку «ОК».

Перед открытием диаграммы стабильности системы, монитор стабильности системы создает отчет.

Первое, что вы сможете увидеть в окне «Монитор стабильности системы» - это график со столбцами, которые соответствуют дням. В каждом из столбцов вы можете увидеть разные значки, которые соответствуют информационным событиям, предупреждениям или критическим событиям. Справа от графика на легенде вы можете увидеть категорию сообщения.

*
Увеличить рисунок

«Монитор стабильности системы» позволяет просматривать индекс стабильности работы компьютера в разрезе дней или недель. Для изменения периода времени нажмите на соответствующую ссылку над диаграммой. По умолчанию, дополнительные сведения в «Мониторе стабильности системы» отображаются за последний день. Для того чтобы просмотреть информацию за любой день, просто выделите нужный для вас столбец в диаграмме стабильности системы.

Более подробную информацию о программе читайте в статье Работа с монитором стабильности системы в Windows 7


wscui.cpl

Местонахождение

Windows\system32

Описание

Центр обеспечения безопасности Windows - Security Center

Новый апплет панели управления, появившийся после выхода Пакета обновления 2 (Service Pack 2)

Центр обеспечения безопасности помогает управлять параметрами безопасности Windows.

Пример разрешения выполнения программы с помощью брандмауэра Windows

  1. Откройте апплет Центр обеспечения безопасности Windows - Пуск | Выполнить | wscui.cpl
  2. Нажмите на ссылку Брандмауэр Windows.
  3. В диалоговом окне Брандмауэр Windows откройте вкладку Исключения и нажмите кнопку Добавить программу.
  4. В диалоговом окне Добавление программы выберите программу в предложенном списке или нажмите кнопку Обзор и найдите ее самостоятельно.
  5. Выбрав программу, нажмите кнопку ОК.
  6. Убедитесь, что на вкладке Исключения флажок напротив названия нужной программы установлен, и нажмите кнопку ОК.

Примечание. Если в будущем возникнет необходимость удалить программу из списка исключений, снимите этот флажок.

Добавление программы в список исключений имеет следующие преимущества:

  • не нужно знать номер сопоставленного программе порта
  • порт, который используется программой из списка исключений, открывается только в том случае, когда программа ожидает получения данных извне.

Открытие портов вручную с помощью брандмауэра Windows

  1. Откройте апплет Центр обеспечения безопасности Windows - Пуск | Выполнить | wscui.cpl
  2. Нажмите на ссылку Брандмауэр Windows.
  3. На вкладке Исключения нажмите кнопку Добавить порт.
  4. В диалоговом окне Добавление порта введите в поле Номер порта номер открываемого порта и выберите вариант TCP или UDP.
  5. Введите название порта и нажмите кнопку ОК (например, Игровой порт).
  6. Чтобы просмотреть или изменить область исключения для порта, нажмите кнопку Изменить область, а затем — OК.
  7. Убедитесь, что на вкладке Исключения указана новая служба. Чтобы открыть порт, установите флажок рядом с новой службой и нажмите кнопку OК


ciadv.msc

Местонахождение

Windows\system32

Служба индексирования

Служба индексирования извлекает сведения из набора документов и собирает их в структуру, обеспечивающую быстрый и удобный доступ к этим сведениям с помощью команды Найти Windows XP, формы запроса службы индексирования или обозревателя. Эти сведения могут включать текст (содержимое) документа, характеристики и параметры (свойства) документа, такие как имя автора. После создания индекса можно запросить в нем документы, содержащие ключевые слова, фразы или свойства. Например, можно запросить все документы, содержащие слово «продукт», либо все документы Microsoft Office, созданные определенным автором. Служба индексирования возвращает список всех документов, соответствующих указанным условиям поиска.


compmgmt.msc

Местонахождение

Windows\system32

Управление компьютером

Оснастка Управление компьютером — это инструмент, предназначенный для управления локальным и удаленным компьютерами.


devmgmt.msc

Местонахождение

Windows\system32

Диспетчер устройств (Device Management)

Диспетчер устройств используют для обновления драйверов (или программного обеспечения) оборудования, изменения настроек оборудования, а также для устранения неполадок.


diskmgmt.msc

Местонахождение

Windows\system32

Управление дисками - Disk Management

Оснастка Управление дисками предназначена для таких задач, как создание и форматирование разделов и томов и назначение букв дисков. В Windows Vista программа управления дисками дает гораздо больше возможностей чем в Windows XP, например, появилаось возможность управления размером раздела.

Смотри также

Переназначить буквы дисков


gpedit.msc

Местонахождение

Windows\system32

Редактор локальной групповой политики

Оснастка Групповая политика используется для определения параметров политики, которые будут применяться к компьютерам или пользователям. С помощью данной оснастки можно запретить доступ пользователя к отдельно взятым оснасткам консоли. Очень подробную информацию можно почерпуть из справки.

Примеры

Чтобы заблокировать команду Повторное открытие последнего сеанса просмотра в меню Сервис Internet Explorer 8 - Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Internet Explorer и установите у данного свойства значение Включен. Имейте в виду, что блокируется только команда меню, но сама история последних сеансов просмотра по-прежнему сохраняется в dat-файлах.
Примечание: в реестре используется параметр NoReopenLastSession для аналогичных действий.

Чтобы запретить отображение поля поиска в Internet Explorer - Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Internet Explorer и установите у свойства Запретить отображение поля поиска Internet Explorer в значение Включен
Примечание: в реестре используется параметр NoSearchBox для аналогичных действий.

Отключить всплывающие подсказки для кнопки Пуск - Конфигурация пользователя | Административные шаблоны | Меню Пуск и панель задач | параметр "Удалить всплывающие подсказки для элементов главного меню")
Примечание: в реестре используется параметр NoSMBalloonTip для аналогичных действий.

Справочник по реестру доступен по адресу user.alexanderklimov.ru

Ошибка при запуске политики

Если у вас при запуске gpedit.msc всплывает следующее сообщение: "Ошибка инициализации оснастки. Имя:Групповая политика CLSID:{8FC0B734-A0E1-11D1-A7D3-0000F87571E3}", и оснастка не работает, то вероятно в значении переменной окружения PATH не указан путь к папке %SystemRoot%\System32\WBEM либо значение переменной PATH оканчивается обратным слэшем (\). Откройте апплет Панели управления Система и на вкладке Допольнитетельно | кнопка Переменные среды выберите из списка строку PATH. Измените строчку для этой переменной - удалите лишний слэш или добавьте правильный путь SystemDir%\System32\Wbem. Если это не поможет, перерегистрируйте некоторые библиотеки:

  • regsvr32 C:\WINDOWS\System32\gpedit.dll
  • regsvr32 C:\WINDOWS\System32\fde.dll
  • regsvr32 C:\WINDOWS\System32\framedyn.dll


fsmgmt.msc

Местонахождение

Windows\system32

Общие папки (Shared Folders)

Компонент «Общие папки» может быть использован для управления общими ресурсами по сети. При помощи компонента «Общие папки» можно осуществлять контроль над разрешениями учетных записей пользователей, сеансами и свойствами общих ресурсов.


ntmsmgr.msc

Местонахождение

Windows\system32

Съемные ЗУ

Служба «Съемные ЗУ» упрощает отслеживание съемных носителей и управление библиотеками, например устройствами смены дисков.


perfmon.msc

Местонахождение

Windows\system32

Производительность (Performance Monitor)

Огромное количество счетчиков производительности компьютера (в т.ч. компьютера в сети) Загруженность процессора, памяти, кэша, логических дисков. Большое количество настроек и возможностей. Можно, например, узнать активность жесткого диска, его загруженность или отследить сколько байт занимает отдельно взятая программа в файле подкачки и т.д.


secpol.msc

Местонахождение

%WINDIR%\system32

Параметры безопасности

Оснастка расширения "Параметры безопасности" дополняет оснастку "Групповая политика" и позволяет определять политики безопасности для компьютеров в вашем домене.

Например, с ее помощью можно настроить параметры входа в Windows

Включение классического окно входа в систему (как в Windows 2000)

Для включения классического окна входа в систему, в котором можно ввести имя пользователя и пароль, раскройте группу Локальные политики | Параметры безопасности. Откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен. Этот параметр безопасности определяет, будет ли в экране входа в систему показано имя последнего пользователя, выполнившего вход.


services.msc

Местонахождение

Windows\system32

Службы (Services)

Оснастка «Службы» используется для управления службами на локальном или удаленном компьютерах.


taskschd.msc

Местонахождение

%systemroot\system32

Планировщик заданий (Windows Vista/Windows 7)

Планировщик заданий — это оснастка MMC, позволяющая назначать автоматически выполняемые задания, запуск которых производится в определенное время или при возникновении определенных событий. Планировщик заданий содержит библиотеку всех назначенных заданий, обеспечивая возможность быстрого просмотра и удобного управления заданиями. Из библиотеки можно запустить, отключить, изменить и удалить задание. Пользовательский интерфейс планировщика заданий заменил расширение Scheduled Tasks Explorer в Windows XP, Windows Server 2003 и Windows 2000.

Как очистить журнал Планировщика заданий?

Планировщик заданий в Windows Vista/7 записывает события для каждой задачи, которые можно посмотреть на вкладке Журнал. Сами записи хранятся в логах журнала событий Windows. Чтобы очистить журнал Планировщика заданий, вызовите Eventvwr.msc, перейдите на ветку Журналы приложений и служб | Microsof | Windows | TaskScheduler | Operational. Щелкните правой кнопкой на Operational и выберите команду Очистить журнал… и нажмите на кнопку Очистить. Тем самым вы очистите журнал для всех задач.


wf.msc

Местонахождение

%systemroot\system32

Брандмауэр Windows в режиме повышенной безопасноти (Windows Vista/Windows 7)

В режиме повышенной безопасности брандмауэр позволяет конфигурировать не только локальный компьютер, но и удаленные компьютеры и объекты групповой политики.

Подробнее о программе Брандмауэр Windows в режиме повышенной безопасноти смотрите в справочнике Windows.Народные советы


Services

Службы в Windows

Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить ненужные службы можно через оснастку Службы (Services). Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы. Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в реестре найдите раздел HKLM\SYSTEM\CurrentControlSet\Serviсes. Не рекомендуется отключать службы через утилиту msconfig.exe.

Список служб в Windows

  • Служба шлюза уровня приложения (Application Layer Gateway Service)

Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).

  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, чтобы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому каждый должен сам решать, что можно отключить.


Alerter

Оповещатель (Alerter)

Посылает выбранным пользователям и компьютерам административные оповещения. Если служба остановлена, программа, использующая административные оповещения их не получит. Если данная служба неразрешена, не удастся запустить любые явно зависимые службы, например, не будет работать команда net send

Установки по умолчанию

Вручную

Рекомендации

Данная служба нужна для посылки сообщений по локальной сети. В большинстве случаев можете ее отключить.


COMSysApp

Системное приложение COM+ (COM+ System Application)

Управление настройкой и отслеживанием компонентов COM+. Если данная служба остановлена, большинство компонентов COM+ не будет работать правильно.

Установки по умолчанию

Вручную

Рекомендации

Нет необходимости менять настройки по умолчанию


CryptSvc

Службы криптографии (Cryptographic Services)

Предоставляет три службы управления: службу баз данных каталога, которая проверяет цифровые подписи файлов Windows; службу защищенного корня, которая добавляет и удаляет сертификаты доверенного корня центра сертификации с этого компьютера; и службу ключей, которая позволяет подавать заявки на сертификаты с этого компьютера. Если эта служба остановлена, все эти службы управления не будут работать. Если эта служба отключена, любые службы, которые явно зависят от нее, не могут быть запущены."

Установки по умолчанию

Авто

Рекомендации

Нет необходимости менять настройки по умолчанию. Иначе будут проблемы при установке драйверов, автоматического обновления, сервис-паков, DirectX и т.д.


clipsrv.exe

Местонахождение

WINDOWS\system32

Описание

Windows NT DDE Server

Сервер папки обмена (ClipBook) позволяет хранить информацию и делить ее с удаленными компьютерами. Если данная служба остановлена, то такой возможности не будет.

Значение по умолчанию | Рекомендуемое значение
Автоматически | Вручную

Зависимости данной службы

Network DDE Network DDE DSDM


Microsoft Games

%programfiles%\Microsoft Games (Windows Vista)

Папка Microsoft Games содержит папки с встроенными играми Windows. По сравнению с предыдущей версией Windows XP были добавлены игры Chess (Шахматы), Inkball, Mahjong, Purple Place.


System Volume Information

В папке C:\System Volume Information находится кэш службы восстановления системы. Для его удаления сначала отключить восстановление системы (Панель управления | Система | Восстановление системы | Отключить восстановление системы на всех дисках). Но лучше воспользоваться кнопкой Параметры и ограничить объем дискового пространства, резервируемого системой.

По умолчанию, данная папка является скрытой. Программа восстановления системы создает копии реестра в данной папке. Данная папка содержит один или несколько подпапок вида _restore{GUID}RPx\Snapshot. По своей сути, они являютя каталогами точек восстановления системы. Обычным способом Windows не позволяет просматривать содержимое этой папки. Существуют способы обойти эти ограничения, но данная операция небезопасна и не рекомендуется для использования на собственном рабочем компьютере.


C:\Documents and Settings

В папке C:\Documents and Settings находятся профили пользователей, работающих с системой Windows XP. Например, если вы входите в систему под учетной записью Alexandr, то в папке C:\Documents and Settings будет создана папка Alexandr, в котором будет содержаться различные ваши данные. Например, в этой папке Alexandr будет содержаться файл ntuser.dat

Смотри также

Default Pictures
CD Burning


C:\Documents And Settings\All Users\Application Data\Microsoft\User Account Pictures\Default Pictures

В папке C:\Documents And Settings\All Users\Application Data\Microsoft\User Account Pictures\Default Pictures содержатся картинки-пиктограммы, используемые на странице приветствия для идентификации пользователей. Вы можете модифицировать имеющиеся картинки, либо добавить свои. Когда вы воспользуетесь апплетом Учетные записи пользователей, то войдите в любую имеющую запись и выберите команду Изменение изображения, и вы увидите ваши собственные картинки в этом окне


C:\Documents and Settings\(имя пользователя)\Local Settings\Application Data\ Microsoft\CD Burning

В папке C:\Documents and Settings\(имя пользователя)\Local Settings\Application Data\ Microsoft\CD Burning Windows создает файл образа будущего компакта-диска.


SendTo

Папка SendTo является папкой, в которой находятся ярлыки программ для команды Отправить контекстного меню Проводника. Когда вы щелкаете правой кнопкой на файле или папке выбираете пункт Отправить и там выбираете, куда хотите отправить, то выбранный вами файл копируется (перемещается) в ту папку, которую вы выбрали. В отличие от старых версий Windows, в Windows XP папка находится в C:\Documents and Settings\имя пользователя. По умолчанию в этой папке уже есть несколько ярлыков. Можно добавить самому свои ярлыки, которые будут отображаться в контекстном меню. Порядок работы с папкой следующий:

  • Создаёте ярлык программы для папки SendTo
  • Копируете этот ярлык в папку SendTo
  • Выбираете из контекстного меню выбранного файла пункт Отправить и ищете нужный вам подпункт

Например, я использую эту возможность для отправки обновлений в папку программы Ad-Aware SE Personal


Driver Cache\i386

Windows\Driver Cache\i386

В папке Driver Cache\i386 находится кэш драйверов. Некоторые пользователи рекомендуют удалять эту папку после установки всего оборудования. Имейте в виду, что при добавлении любого нового оборудования Windows будет запрашивать установочный диск.


Media

Windows\Media

В папке Windows\Media хранятся звуковые файлы WAV для озвучивания системных событий. Если у вас осталось слишком мало места на жестком диске, а звуковыми колонками не пользуетесь, то можете удалить эти файлы (почти 2 мегабайта). Также отключите звуковые схемы в апплете Звуки и аудиоустройства Панели управления, что разгрузить немного оперативную память.


Minidump

Windows\Minidump

Малый дамп памяти — это специальная запись минимального набора сведений, необходимых для определения причины неполадок. Windows каждый раз при возникновении неустранимой ошибки будет автоматически создавать новый файл в данной папке. Данная папка задается в диалоговом окне Загрузка и восстановление (апплет Система | вкладка Дополнительно | кнопка Параметры рамки Загрузка и восстановление | Папка малого дампа).


msagent

Windows\msagent

Папка msagent содержит подпапки и файлы, необходимые для работы с технологией MS Agent 2.0. В частности, подпапка Chars служит для хранения анимированных персонажей. По умолчанию, Windows XP уже имеет одного такого персонажа. Более подробно о технологии MS Agent 2.0 вы сможете прочитать в книге А.Климова MS Agent. Графические персонажи для интерфейсов, выпущенной издательством BHV

С использованием технологии Microsoft Agent


ShellNew

Windows\ShellNew

В папке Windows\ShellNew хранятся файлы-шаблоны, которые используются при выборе пункта меню Создать контекстного меню Проводника. О том как создавать новые команды в данном пункте меню можно прочитать в справочнике по реестру


SoftwareDistribution

WINDOWS\SoftwareDistribution

В папке WINDOWS\SoftwareDistribution хранятся папки и файлы, закачанные с помощью автоматического обновления. В принципе, эту папку можно удалить. В этом случае Windows заново создаст эту папку. На различных форумах некоторые пользователи утверждали, что удаление этой папки иногда помогало решить проблему сбоев при автоматическом обновлении.


Temp

Windows\Temp

Папка Temp предназначена для хранения временных файлов. Очень многие программы при своей установке временно копируют в эту папку свои файлы для дальнейшей инсталляции. К сожалению, порой эти программы забывают самостоятельно удалить свои временные файлы. Рекомендуется регулярно заглядывать в папку для очистки мусора


WinSxS

Папка Windows\WinSxS, или Windows Side by Side (бок о бок), является еще одним новшеством Windows XP. Microsoft создала систему, позволяющую сохранять несколько версий одинаковых библиотек DLL (проблема DLL-Hell) и использовать при необходимости именно ту, что требует конкретная программа. Дело в том, что некоторые программы перезаписывают при инсталляции даже более новую версию библиотеки, что может привести ко всякого рода неприятностям, поэтому, если какая-нибудь программа вздумает беспричинно заменить уже имеющуюся в системном каталоге DLL, операционная система поместит сомнительную библиотеку в специальную папку (WinSxS), а программа так и останется уверенной, что сделала свое дело...

Windows Vista: Практически эта папка в Vista заменила папки Windows\system32\dllcache и i386 в Windows XP.

Но, на самом-то деле, папка не потребляет столько дискового пространства, как об этом сообщают встроенные инструменты (DIR и Explorer). На практике практически каждый файл в папке WinSxS является «жесткой ссылкой» (hard link) на физически существующий файл, то есть все файлы находятся вне этой папки. Так, к примеру, в папке WinSxS находится файл advapi32.dll, размер которого составляет более 700Кб, но, на самом деле, это жесткая ссылка на одноименный файл из папки Windows\System32. При подсчете объема Windows Explorer учитывает этот файл дважды.

Папка WinSxS также обеспечивает возможность оффлайн-обслуживания. До Windows Vista поддержка развертывания осуществлялась лишь через процедуру инсталляции. ИТ-специалисты должны были установить ОС и затем с помощью инструментов для снятия образа скопировать его, чтобы впоследствии развернуть на другие компьютеры. На тот момент Windows создавалась без каких-либо предположений об образах. Около 80% систем разворачивались и обслуживались с помощью технологий, которые не поддерживались самой Windows, поэтому требовали от ИТ-отделов использования сторонних решений для эффективного развертывания и управления Windows. Состояние, хранимое в папке WinSxS, доступно и в оффлайн-режиме, то есть для установки обновлений не требуется загрузки или запуска образа. Эти функции папки WinSxS обеспечивают непревзойденную гибкость и значительную экономию, упрощая процедуру создания и обслуживания стандартных корпоративных образов в режиме оффлайн.

Это правда, что папка WinSxS занимает определенное пространство на диске, поскольку она все же существует и хранит огромное количество мета-данных, папок, манифестов, но она занимает гораздо меньше места, чем об этом сообщает Windows Explorer. Реальный объем этой папки зависит от конкретного компьютера, но в среднем – около 400Мб.

Некоторые говорят, что ничего страшного в том, чтобы удалить папку WinSxS, нет. И это правда, что сразу после установки вы можете удалить ее, но после загрузки она появится вновь. Но как вы понимаете, ничего, кроме лишней головной боли, это не принесет, поскольку удалив эту папку, вы лишите систему возможности обслуживания, обновления и настройки опциональных компонентов системы. Высвобождаемое при удалении или перемещении папки пространство не стоит этого риска.

Более подробно об этой папке можно почитать в статье Дисковое пространство


dllcache

Windows\system32\dllcache

В папке Windows\system32\dllcache находится кэш защищенных системных файлов, которые используются для автоматического восстановления в случае повреждения системы. По умолчанию размер этой папки - 50 мб (он задается в реестре параметром SFCQuota, находящемся в ключе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon). Изменить размер папки до нуля можно командой sfc:

sfc /cachesize=0

Если поставить, например, 10, то размер папки уменьшится до 10 мб


config

Windows\system32\config

В папке Windows\system32\config содержатся файлы, которые работают с реестром

Возможный список файлов

  • AppEvent.Evt
  • default
  • default.LOG
  • default.sav
  • SAM
  • SAM.LOG
  • SecEvent.Evt
  • SECURITY
  • SECURITY.LOG
  • software
  • software.LOG
  • software.sav
  • SysEvent.Evt
  • system
  • system.LOG
  • system.sav
  • TempKey.LOG
  • userdiff
  • userdiff.LOG

Обратите внимание, что некоторые файлы не имеют расширения


Restore

Windows\system32\Restore

В папке Windows\system32\Restore содержатся программа восстановления системы rstrui.exe и сопутствующие файлы. В частности здесь находится интересный файл filelist.xml


Windows.old

Папка Windows.old появляется на диске после установки на него операционной системы. Указанная папка содержит файлы предыдущей установки Windows, которая была на этом же разделе.

Удаление папки Windows.old

Попытка удаления этой папки стандартным способом обычно не приносит успеха, поскольку пользователь не обладает достаточными правами для осуществления этого действия. Microsoft предложила описание решения проблемы в статье базы знаний How to remove the Windows.old folder that is generated when you perform a custom installation of Windows Vista

Запустите компонент Очистка диска, щелкнув ярлык, расположенный в меню Пуск (Пуск | Все программы | Стандартные – Служебные | Очистка диска).

В раскрывающемся списке Диски диалогового окна Очистка диска выберите диск, где расположена папка Windows.old (обычно C:) и нажмите ОК. В диалоговом окне Очистка диска перейдите на одноименную вкладку. В поле Удалить следующие файлы установите галочку Предыдущие установки Windows, после чего щелкните OK. В окне предупреждения щелкните кнопку Удалить файлы.

Другой способ описан в http://www.oszone.net/9296/


Cookies

C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Cookies

В папке C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Cookies находятся файлы cookies. По умолчанию, папка скрыта и не доступна через Проводник./p>


Saved Games

В папке Saved Games находятся подпапки игр, в которых сохраняются файлы при выходе из игры. В частности, в этой папке находится подпапка Microsoft Games. Например, если вы сохраните игру Косынка, то в папке Microsoft Games появится папка Solitaire с файлом сохранения. Обратите внимание, что в Проводнике папки отображаются под локализованными именами Сохраненные игры>Microsoft Games>Косынка.


Почему папки желтые

Почему папки желтые
Папка — одна из самых известных метафор экранных интерфейсов. Это очень мощный и сильный символ. За достаточно короткий период времени он сумел затмить термин, который был призван обозначать. Понятие «директория» или «каталог» канули в Лету. Хотя «папка» когда была лишь метафорой для их обозначения в графических оболочках.

В процессе работы собирал разные факты об этой иконке, скидывал в один файл. Решил, что будет не лишним привести в более менее читабельный вид и поделиться.

Directory (от лат. directorium — маршрут движения) в общем смысле обозначает некую структуру, содержащую набор определенной информации. Это может быть список людей или каталог адресов.

Своим появлением она обязана идее оснастить графический интерфейс легендарной рабочей станции Xerox Star (Xerox 8010) метафорами, понятными рядовому офисному клерку. Идеи черпались из стандартного канцелярского оснащения тогдашних офисов. Первым же коммерческим воплощением на массовом рынке стал интерфейс Apple Lisa.

Basic folder appearanceA folder is drawn as a white rectangle (filled in by the application) with a thin (one pixel) black border. Every folder has a tab, which looks like a tab on a standard manilla folder. The tab is always above the upper left corner of the folder. It is called the title tab. The rectangular portion of the folder that holds the folder’s contents is called the body of the folder

“Lisa user interface standards” (1980)

Бумажная папка
Прототипом для метафоры послужила так называемая «манильская папка» (manila folder). Насколько я знаю в русском языке подобный термин отсутсвует (хотя иногда и мелькает в художественной литературе, что, впрочем, может являться лишь ляпом). Правильно будет говорить просто «бумажная папка» или «папка».
Конструктивно она представляет собой согнутый лист бумаги, внутрь которого можно вкладывать или подшивать документы..

Folder=fold (сгибать, собирать)+er (суффикс для образования существительного)

Данный тип папок не был известен на территории бывшего СССР, поэтому иконка папки отчасти являлась симулякром, т.е. не имела под собой предметной части, а только свойство. В системах Win 9x объект казался просто желтым прямогольничком с выступом, т.е. вещью абстрактной.

Бумага. Почему папки желтые.

Американский тип папок изготовляют из прочной бумаги, называемой «манильской». В ее состав входит «манильская пенька», волокна, добываемые из листьев текстильного банана или абаки (растение, родом с Филиппин). Волокна очень жесткие и обладают равномерной толщиной, легко окрашиваются. Хотя, как правило, манильскую бумагу не подвергают обработке красителями. Она сохраняет естественный цвет волокон: желтовато-бежевый. Вот почему иконки папок Windows и некоторых других систем — желтые или бежевые.

Помимо бумаги манильскую пеньку, используют для производства морских канатов. По этой причине второе название манильской бумаги — «канатная».

Из манильского волокна изготовляют чайные пакетики. Технологию разработал американский инженер Фэй Осборн. Во время второй мировой войны, в самый разгар исследований Осборна, манильская пенька стала стратегическим сырьем для флота. Инженеру пришлось придумать способ получения манильских волокон для чайных пакетиков из… старых канатов.

Материал для изготовления папок достаточно гладкий, в составе бумаги нет грубых частиц, чтобы не поцарапать документы. Отсуствуют и химические активные компоненты, способные, вступить в реакцию с фотобумагой и повредить снимки, хранящиеся в папках. Существует стандарт, который требует, чтобы папки, попав в воду, не окрашивали содержимое в какой-либо посторонний оттенок.
«Леопардовая» иконка папки из MacOs, хорошо видна неоднородная бумажная фактура.

В Microsoft Windows Vista/7 папки развернуты на 90 градусов. Это сделано для придания определенной свежести иконкам. А также символизирует более широкую трактовку понятия «папка» в этой системе. В частности, она больше не ассоциируется лишь с физической директорией на диске. У развернутой папки есть свое преимущество: в ней легче компоновать изображение документов.

Продолжение следует...

Источник: Почему папки желтые / Иконосказ / Хабрахабр


Windows Sysinternals

Для справки

С 2006 года Sysinternals была приобретена Microsoft, а ключевая фигура этой компании – Марк Руссинович с тех пор работает в Microsoft. Марк известен своими утилитами, книгой Windows Internals, блогом и является признанным специалистом по архитектуре Windows.

Все Ps-утилиты, распространяются Microsoft совершенно бесплатно. Все они являются консольными приложениями. На странице с каждой программой есть свои примеры. Скачать PS-утилиты можно со страницы http://technet.microsoft.com/ru-ru/sysinternals/bb897541(en-us).aspx

PsExec

Позволяет удаленно запускать программы. Вариантов использования такой утилиты великое множество. А главное все делается достаточно просто с помощью коротких команд.

PsFile

Данная утилита покажет вам список всех открытых удаленно файлов. Кроме того она позволяет закрывать эти файлы, как по имени, так и по их идентификатору. Вполне удобно, учитывая, что хоть какое-то средство для таких нужд необходимо при работе с удаленной машиной.

PsGetSID

Служит для отображения SID текущей системы, а также получение SID на удаленных машинах. Может пригодиться системным администраторам, особенно в тех случаях, когда они занимаются клонированием систем.

PsInfo

Отображает солидную информацию об удаленной системе: число и тип процессоров, физическую память, сборку ядра, владельца и организацию, дату установки системы и некоторые другие параметры.

PsKill

PsKill убивает любые процессы на удаленной машине. При этом интересно то, что если вы введете Notepad, то будут убиты все его копии. Одна из самых полезных утилит в наборе PS-программ. Команды в ней чрезвычайно просты.

PsList

Выдает сведения по запущенным процессам, выводя на консоль различную дополнительную информацию по ним. PsList вполне проста в плане использования, хотя и имеет достаточно обширный набор команд.

PsLoggedOn

Отображает список пользователей вошедших в систему. Естественно, и удаленных тоже.

PsPasswd

С помощью этой утилиты системный администратор сможет менять пароли пользователей на компьютерах. Важное средство для корпоративной среды. Особенно в тех случаях, когда пароли нужно менять на регулярной основе.

PsShutdown

Еще одна сетевая утилита, которая позволяет выключать и перезагружать компьютеры, заканчивать сессию того или иного пользователя. При этом консольные команды для этого в ней достаточно простые, так что у пользователей проблем возникнуть не должно.


Process Explorer

Process Explorer – альтернатива стандартному Диспетчеру задач. Эта утилита, как и многие другие утилиты Sysinternals, здорово расширяет возможности контроля и управления системой. Главное новшество только что вышедшей 14-ой версии — возможность мониторить сетевую активность процессов. Далее небольшой обзор возможностей этой утилиты.

Колонки в главном окне

1

2

Для каждого процесса:
  1. Имя процесса
  2. Владелец процесса, я использую сортировку по этому полю, чтобы первыми шли пользовательские процессы, потом системные
  3. Загрузка CPU процессом
  4. Суммарное затраченное время CPU, интересно иногда обращать на это внимание, полезен для таймирования
  5. Private bytes — объем занимаемой процессом памяти (реально выделенные страницы, исключая shared)
  6. Peak private bytes — пиковое значение Private bytes, интересно иногда взглянуть до чего дело доходило
  7. I/O read bytes — суммарный объем считанных с диска данных, по изменению видна активность
  8. I/O write bytes — суммарный объем записанных на диск данных, по изменению видна активность
  9. Network receive bytes — суммарный объем считанных из сети данных, по изменению видна активность
  10. Network send bytes — суммарный объем переданных в сеть данных, по изменению видна активность
  11. Описание процесса
  12. Название компании
  13. Полный путь к образу процесса (тут можно точно понять откуда стартовал процесс)
  14. Командная строка запуска процесса

Сервисы внутри svchost

При наведении курсора на svchost (процесс который хостит в себе сервисы) можно видеть перечень сервисов – довольно полезная фича.

Суммарные графики активности, процесс с максимальной активностью

Сверху основного окна расположены графики основных суммарных параметров – память, дисковая, сетевая и CPU активность. При перемещении курсора по истории параметра, показан процесс который дал максимальный вклад в это значение в данный момент времени. Кроме того в тултипе есть информация о мгновенном значении параметра (зависит от частоты обновления). На следующей картинке — график сетевой активности.

В окне «system information» графики собраны вместе, здесь удобнее смотреть корреляцию параметров.

Суммарные графики активности в трее, процесс с максимальной активностью

Очень удобная функциональность – выведение в область уведомлений значков с графиками суммарной активности. Там могут быть графики дисковой активности, CPU и память. Я использую первые два – поглядываю туда, при возникновении вопросов достаточно навести курсор и узнать какой процесс дает максимальный вклад в параметр. К сожалению сетевую активность туда нельзя выставить, я надеюсь это вопрос времени.

Сетевые соединения процесса

В свойствах процесса в закладке TCP/IP можно посмотреть текущие активные соединения. К сожалению сетевая активность по ним не видна, эта функциональность пока доступна в другой утилите – tcpview.

Потоки процесса, их активность, стек потока с загрузкой символов

В свойствах процесса в закладке threads видны все его потоки и загрузка CPU по потокам. Допустим хочется рассмотреть стек потока, который интенсивно что-то делает или висит. Для этого сперва надо его распознать, допустим по загрузке CPU, потом полезно приостановить процесс, чтобы спокойно рассмотреть его состояние — это можно сделать прямо в этом окне по кнопке “suspend”. Далее выделяем поток и нажимаем “stack”. В большинстве случаев стек будет начинаться в недрах системы и обрываться не совсем понятным образом. Дело в том, что не имея отладочной информации по системным библиотекам не удастся корректно развернуть стек и разобраться в нем. Есть решение – нужно сконфигурировать доступ с символьной информации с сайта Microsoft. Надо проделать несколько шагов:

  1. Установить Debugging Tools. Из приведенной ссылки надо пойти по ссылке “Debugging Tools for Windows 32-bit Versions” или “Debugging Tools for Windows 64-bit Versions”. Далее выбрать для скачивания последнюю версию не интегрированную в SDK, иначе это выльется в скачивание огромного объема SDK, а так всего несколько Mb.
  2. Настроить доступ к символам в Process Explorer. Options –> Configure Symbols. В одном поле задаем путь к dbghelp.dll, которая находится внутри установленного продукта из шага 1. Во втором настраиваем такую хитрую строку: “srv*C:\Symbols*http://msdl.microsoft.com/download/symbols”. Часть строки указывает на локальный кэш для PDB файлов, вторая часть на путь к серверу для скачивания.
  3. Теперь список потоков и стек будут более информативны. При открытии этих окон может происходить задержка на время подкачки PDB файлов с сервера Microsoft, но делается это один раз для каждой версии модуля, результат кэшируется в выбранной папке.

Информация по использованию памяти в системе

В окне «system information» закладка «memory». Здесь есть два графика – commit и physical. Physical – использование физической памяти без учета файлового кэша, под который уходит все что остается. Commit – сколько памяти выделено для процессов включая используемую виртуальную память. Под графиками в разделе «Commit Charge» есть поля Limit и Peak. Limit определяется суммой физической и виртуальной памяти, т.е. это максимальный суммарный объем памяти, который может выделить система. Peak – это максимум графика Commit за время работы утилиты. Процентные соотношения Current/Limit и Peak/Limit удобны для быстрой оценки насколько состояние системы приближалось к критическому лимиту по доступной памяти.

Handles и DLL процесса

В главном окне можно включить разделитель и снизу отображать DLL или handles выделенного процесса. При борьбе с вирусами и отладке программ это бывает очень полезно. На картинке — список handles для opera, первый handle файловой системы – это flash ролик в временном каталоге.

Для DLL можно добавить колонку с полным путем к образу, отсортировав по нему, проанализировать нет ли каких подозрительных модулей. На картинке видно, что подключен модуль от Logitech, есть подозрение что это что-то типа хука внедряющегося во все процессы. Следующим пунктом посмотрим где он еще встречается.

Поиск handles и DLL

Поиск по имени handle или DLL во всех процессах. Вводим имя DLL от Logitech из предыдущего пункта и убеждаемся что подключается он почти везде.

Другой пример – надо понять, кто блокирует файл или работает с папкой. Вводим часть пути и находим все процессы, которые открыли подобные объекты системы. Можно щелкнуть на элементе из списка и перейти к процессу, при этом будет подсвечен соответствующий handle или DLL.

Для отображения некоторых полей (например сетевая статистика) требуются административные привилегии. Повысить привилегии в уже запущенном Process Explorer можно с помощью команды в меню File. Только при наличии таких привилегий есть возможность добавить такие колонки. Я считаю такое поведение неверным, т.к. скрывает потенциальные возможности приложения от пользователя. Если поля добавлены и при следующем запуске нет административных прав, то они будут пустыми. Можно задать ключ "/e" в командной строке, чтобы форсировать поднятие привилегий при старте Process Explorer.

Источник: Process Explorer. Обзор некоторых возможностей


MpCmdRun.exe

Местонахождение

%ProgramFiles%\Microsoft Security Essentials

Описание

Microsoft Malware Protection Command Line Utility

В справке утилиты командной строки MpCmdRun.Exe допущена неточность в параметрах сканирования системы, а именно:

-Scan [-ScanType]
     0  Default, according to your configuration
     1  Quick scan
     2  Full system scan

То есть предполагается выполнение такой команды для быстрого сканирования:

MpCmdRun.Exe –scan –1

А для полного сканирования:

MpCmdRun.Exe –scan –2

На самом же деле обе вышеуказанные команды выполняют только быстрое (частичное) сканирование системы.

Для корректного выполнения сканирования воспользуйтесь одной из этих команд:

Для быстрого сканирования системы:

MpCmdRun.exe -Scan -ScanType 1

Для полного сканирования системы:

MpCmdRun.exe -Scan -ScanType 2

Источник: Справка по параметрам командной строки Microsoft Security Essentials (MpCmdRun.Exe)


Софт для работы с программами

На сайте www.programchecker.com имеется онлайновая база по программам и файлам, содержащая несколько десятков тысяч записей. Также можно скачать отдельную программу. С помощью данной базы можно определить, является ли программа частью операционной системы, вирусом или частью программного обеспечения какой-то компании.


Знакомство с командной строкой

К сожалению, утилиты командной строки в Windows редко используются пользователями (в основном ими пользуются системные администраторы). А ведь с их помощью можно сделать очень много и быстрее.

Как работать в командной строке

Чтобы использовать командную строку, нужно запустить программу cmd.exe удобным вам способом. Например, ее можно запустить через Пуск | Все программы | Стандартные | Командная строка. На самом деле это командный интерпретатор, который пришел на смену command.com из мира DOS и Windows 9x.

В результате запуска у вас появится консольное окна черного цвета (цвет можно настроить), в котором нужно вручную вводить команды.

Есть несколько простых приемов, которые нужно запомнить. Например, если не хочешь ждать завершения первой команды, можно ввести сразу несколько команд, разделив их амперсандом:

команда1 & команда2 & ... & командаN

Если эту последовательность команд приходится выполнять постоянно, то удобнее создать специальный командный файл - обычный текстовый файл с расширением cmd. Каждая команда записывается в отдельной строке, но можно и использовать амперсанды. Многие по-привычке создают файлы с расширением BAT (любовно называя их батниками). Особой разницы нет, в целях совместимости старое расширение работает также с командной строке.

Иногда требуется выполнять программы в определенной последовательности, дождавшись определенного результата от предыдущей команды. И если результат успешен, выполнить следующую команду. Это можно реализовать с помощью двойного амперсанда:

команда1 && команда2

Вторая команда будет выполнена, если код завершения первой команды равен нулю (успешное завершение).

Иногда программа выдает результат в таком большом количестве, что не успеваешь прочитать весь текст. В этом случае нужно добавить параметр more для постраничного просмотра. Тогда текст будет выводиться кусками и можно листать текст при помощи клавиши пробела.

команда | more

Символ «|» используется для перенаправления стандартного вывода одной команды на стандартный ввод другой. Что будет делать с этим выводом другая программа, зависит только от нее.

Для перенаправления вывода команды в файл используются символы «>» и «>>»:

команда > файл

команда >> файл

В первом примере, если файл существует, то будет перезаписан, а во втором примере информация добавляется в конец файла. Для подавления вывода команды можно перенаправить вывод в пустое устройство:

команда > NUL

Если окно командной строки забито текстом, который вам мешает, то можете просто очистить экран через команду:

cls

Команды

Команды бывают внутренними и внешними. Внутренние команды выполняет сам cmd.exe. Внешние команды - обычные исполняемые exe-файлы, которые иногда еще называют утилитами командной строки. Когда мы вводим команду, cmd определяет, что это за команда. Если внутренняя, то он выполняет ее сам, если внешняя, тогда cmd производит поиск исполняемого файла в текущем каталоге и по пути поиска программ (переменная окружения PATH). Просмотреть содержимое переменной PATH можно так:

echo %PATH%

Описания внутренних и внешних команд представлены в данном справочнике.

Примеры

shutdown.exe - В Unix есть очень программа shutdown. С ее помощью можно не только завершить работу системы (или перезагрузить ее), но и указать время завершения. Аналог этой команды есть и в Windows. С ее помощью можно просто выключить систему, выполнить перезагрузку, убить активных пользователей, перейти в режим пониженного энергопотребления и закончить сеанс без отключения компьютера. Очень полезен параметр '-t', позволяющий задать в секундах тайм-аут операции.

systeminfo.exe - полная информация о системе

ping.exe - отправка ICMP-пакетов на указанный узел для проверки его доступности

net.exe - управение сетью из командной строки

nslookup.exe - просмотр записей DNS-сервера

netstat.exe - вывод информации о сети

chkdsk.exe - проверка дисков

diskpart.exe - позволяет разбить диск на разделы, создать/удалить логические диски, выбрать активный раздел и т.д.

Сценарии

Сценарии - это текстовые файлы с инструкциями, которые должна выполнить diskpart. Вызвать diskpart можно так:

diskpart /s <имя_сценария>

Пример сценария diskpart

select disk 0

clean

create partition primary

select partition 1

assign letter=c:

active

format

exit

Обратите внимание, как осуществляется работа с объектами. Сначала с помощью команды select мы выбираем диск (select disk). Затем мы производим две операции (clean и create partition). Далее выбираем другой объект - раздел (select partition) и производим операции с ним (делаем раздел активным и форматируем его).

Можно указать размер создаваемого раздела (в данном случае 5 Гб), например:

create partition primary size=5000


Использование переменных среды в Cmd.exe

Среда командной оболочки Cmd.exe определяется переменными, задающими поведение командной оболочки и операционной системы. Имеется возможность определить поведение среды командной оболочки или среды всей операционной системы с помощью двух типов переменных среды: системных и локальных. Системные переменные среды определяют поведение глобальной среды операционной системы. Локальные переменные среды определяют поведение среды в данном экземпляре Cmd.exe.

Системные переменные среды заданы заранее в операционной системе и доступны для всех процессов Windows XP. Только пользователи с привилегиями администратора могут изменять эти переменные. Эти переменные наиболее часто используются в сценариях входа в систему.

Локальные переменные среды доступны, только когда пользователь, для которого они были созданы, вошел в систему. Локальные переменные из HKEY_CURRENT_USER подходят только для текущего пользователя, но определяют поведение глобальной среды операционной системы.

В следующем списке представлены различные типы переменных в порядке убывания приоритета.

  1. Встроенные системные переменные
  2. Системные переменные куста HKEY_LOCAL_MACHINE
  3. Локальные переменные куста HKEY_CURRENT_USER
  4. Все переменные среды и пути указаны в файле Autoexec.bat.
  5. Все переменные среды и пути указаны в сценарии входа в систему (если он имеется).
  6. Переменные, используемые интерактивно в сценарии или пакетном файле

В командной оболочке каждый экземпляр Cmd.exe наследует среду своего родительского приложения. Поэтому можно изменять переменные в новой среде Cmd.exe, что не повлияет на среду родительского приложения.

В следующей таблице приведен список системных и локальных переменных среды для Windows XP.

Переменная | Тип | Описание
%ALLUSERSPROFILE% | Локальная | Возвращает размещение профиля «All Users».
%APPDATA% | Локальная | Возвращает используемое по умолчанию размещение данных приложений.
%CD% | Локальная | Возвращает путь к текущей папке.
%CMDCMDLINE% | Локальная | Возвращает строку команд, с помощью которой был запущен данный экземпляр Cmd.exe.
%CMDEXTVERSION% | Системная | Возвращает номер версии текущих расширений обработчика команд.
%COMPUTERNAME% | Системная | Возвращает имя компьютера.
%COMSPEC% | Системная | Возвращает путь к исполняемой командной оболочке.
%DATE% | Системная | Возвращает текущие данные. Использует тот же формат, что и команда date /t. Создается командой Cmd.exe. Дополнительные сведения о команде date см. в разделе Date.
%ERRORLEVEL% | Системная | Возвращает код ошибки последней использовавшейся команды. Значение, не равное нуля, обычно указывает на наличие ошибки.
%HOMEDRIVE% | Системная | Возвращает имя диска локальной рабочей станции, связанного с основным каталогом пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%HOMEPATH% | Системная | Возвращает полный путь к основному каталогу пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%HOMESHARE% | Системная | Возвращает сетевой путь к общему основному каталогу пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%LOGONSEVER% | Локальная | Возвращает имя контроллера домена, который проверял подлинность текущей сессии.
%NUMBER_OF_PROCESSORS% | Системная | Задает количество процессоров, установленных на компьютере.
%OS% | Системная | Возвращает имя операционной системы. При использовании Windows 2000 имя операционной системы отображается как Windows_NT.
%PATH% | Системная | Указывает путь поиска для исполняемых файлов.
%PATHEXT% | Системная | Возвращает список расширений файлов, которые рассматриваются операционной системой как исполняемые.
%PROCESSOR_ARCHITECTURE% | Системная | Возвращает архитектуру процессора. Значения: x86, IA64.
%PROCESSOR_IDENTFIER% | Системная | Возвращает описание процессора.
%PROCESSOR_LEVEL% | Системная | Возвращает номер модели процессора, установленного на компьютере.
%PROCESSOR_REVISION% | Системная | Возвращает номер модификации процессора.
%PROMPT% | Локальная | Возвращает параметры командной строки для текущего интерпретатора. Создается командой Cmd.exe.
%RANDOM% | Системная | Возвращает произвольное десятичное число от 0 до 32767. Создается командой Cmd.exe.
%SYSTEMDRIVE% | Системная | Возвращает имя диска, содержащего корневой каталог Windows XP (т. е. системный каталог).
%SYSTEMROOT% | Системная | Возвращает размещение системного каталога Windows XP.
%TEMP% и %TMP% | Системная и пользовательская | Возвращает временные папки, по умолчанию используемые приложениями, которые доступны пользователям, выполнившим вход в систему. Некоторые приложения требуют переменную TEMP, другие — переменную TMP.
%TIME% | Системная | Возвращает текущее время. Использует тот же формат, что и команда time /t. Создается командой Cmd.exe. Дополнительные сведения о команде time см. в разделе Time.
%USERDOMAIN% | Локальная | Возвращает имя домена, содержащего список учетных записей пользователей.
%USERNAME% | Локальная | Возвращает имя пользователя, выполнившего вход в систему.
%USERPROFILE% | Локальная | Возвращает размещение профиля для текущего пользователя.
%WINDIR% | Системная | Возвращает размещение каталога операционной системы.


Call

Описание

Команда Call служит для вызова одного пакетного файла из другого без завершения выполнения первого файла. Команда Call принимает метки в качестве объекта вызова. Используемая в командной строке, а не в сценарии или пакетном файле, команда Call игнорируется.

Синтаксис

call [[диск:][путь] имя_файла [пакетные_параметры]] [:метка [аргументы]]

Параметры

[диск:][путь] имя_файла
Задает имя и местоположение пакетного файла для запуска. Параметр имя_файла должен иметь расширение .bat или .cmd
пакетные_параметры
Задает данные командной строки, используемые программой пакетной обработки, включая параметры командной строки, имена файлов, пакетные параметры (в диапазоне от %0 до %9) или переменные (например %baud%)
:метка
Указывает метку, на которую должно быть передано управление программы пакетной обработки. При использовании команды call с этим параметром создается новый контекст пакетного файла, а управление передается инструкции, следующей за указанной меткой. Когда первый раз встречается конец пакетного файла (после перехода на метку), управление возвращается на инструкцию, следующую за инструкцией call. При втором достижении конца файла выполнение пакетной программы прекращается.
аргументы
Задает данные командной строки, которые передаются в новый экземпляр программы пакетной обработки, начинающейся с :метки, включая параметры командной строки, имена файлов, пакетные параметры (в диапазоне от %1 до %9) или переменные (например %baud%).
/?
Выводит справку в командной строке

Примечание

Создание пакетных файлов, которые вызывают сами себя (рекурсия), допускается, однако в этом случае необходимо задать условия выхода. В противном случае родительская и дочерняя программы будут вызывать друг друга в бесконечном цикле.

Пример

Для вызова программы Checknew.bat из другого пакетного файла в тексте родительского пакетного файла введите следующую строку:

call checknew

Если родительская пакетная программа принимает два пакетных параметра и требуется передать их в файл Checknew.bat, включите следующую команду в родительскую пакетную программу:

call checknew %1 %2


CHDIR

CHDIR и CD

Описание

Вывод имени либо смена текущего каталога. При использовании только с именем диска (например chdir C:) команда chdir выводит имена текущих диска и папки. Выполненная без параметров команда chdir выводит текущие диск и каталог.

Синтаксис

chdir [[/d] [диск:][путь] [..>]] [[/d>] [диск:][путь] [..]]

cd [[/d] [диск:][путь] [..]] [[/d] [диск:][путь] [..]]

Параметры

/d
Смена текущего диска или текущего каталога на диске.
[диск:][путь]
Задание имени диска (если он отличается от текущего) и каталога, в который требуется перейти.
[..]
Переход в родительскую папку.
/?
Выводит справку в командной строке

Примечания

  • Если расширения командного процессора разрешены (задано по умолчанию), имена папок в пути к текущему каталогу отображаются точно так же, как на жестком диске, в том же формате имен папок с учетом регистра. Например, если имя папки на жестком диске — C:\Temp, команда CD C:\TEMP задает текущий каталог C:\Temp, соответствующий формату имени этой папки на жестком диске.

    Чтобы запретить расширения командного процессора для определенного процесса, введите следующую команду:

    cmd e:off

    Если расширения командного процессора запрещены, в команде chdir нельзя использовать пробелы в качестве разделителей. Таким образом, можно перейти в подкаталог, имя которого содержит пробел, не заключая параметр [путь] в кавычки. Например, следующий путь позволяет перейти в подкаталог \Start menu.

    cd \winnt\profiles\username\programs\start menu
  • Переход в корневой каталог

    Корневой каталог является вершиной дерева каталогов на диске. Чтобы перейти в корневой каталог, введите следующую команду:

    cd\
  • Переход из основного каталога одного диска в основной каталог другого

    Чтобы перейти в основной каталог диска отличного от текущего, введите следующую команду:

    chdir [диск:\[каталог]]

cd [диск:\[каталог]]

    Чтобы проверить переход к этому каталогу, введите одну из следующих команд:

    chdir [диск:]

cd [диск:]
  • Команда chdir с другими параметрами доступна в консоли восстановления.

Пример

Используемая с именем диска команда chdir позволяет перейти в текущий каталог этого диска. Например, если ввести команду cd c: в приглашении каталога C:\Temp, отобразится следующая строка:

C:\Temp

Чтобы перейти в текущий каталог Cats, введите одну из следующих команд:

chdir \cats

cd \reports

Чтобы перейти из текущего каталога в подкаталог \Cats\Barsik, введите следующую команду:

cd \Cats\Barsik

Или, если текущим каталогом является \Cats, введите следующую команду, чтобы перейти в подкаталог \Cats\Barsik:

cd Barsik

Чтобы перейти из подкаталога в родительский каталог, введите следующую команду:

cd ..

Для вывода на экран имени текущего каталога можно использовать команду chdir или cd без параметров. Например, если текущим каталогом является \Cats\Barsik на диске B, вызов команды chdir приведет к следующему результату:

B:\Cats\Barsik

Если при работе на диске D требуется скопировать все файлы каталогов \Public\Jones и \Public\Lewis на диске C в корневой каталог диска D, введите следующую последовательность команд:

chdir c:\public\jones

copy c:*.* d:\

chdir c:\public\lewis

copy c:*.* d:\

Если требуется скопировать все файлы каталогов \Public\Jones и \Public\Lewis в текущий каталог диска D, введите следующие команды:

chdir c:\public\jones

copy c:*.* d:

chdir c:\public\lewis

copy c:*.* d: